We have moved at community.getvera.com

Author Topic: New 7.0.27 firmware available  (Read 6887 times)

Offline rafale77

  • Community Beta
  • Hero Member
  • ******
  • Posts: 1749
  • Karma: +101/-27
  • HA ≠ IoT as a blue sky is cloudless.
Re: New 7.0.27 firmware available
« Reply #15 on: July 18, 2018, 05:40:04 pm »
On the vera plus I just noticed it killed my zigbee network. I had to downgrade to recover... no joy.
openLuup (79 devices, 141 scenes, 19 apps) master to VeraPlus (142 zwave nodes, 8 Zigbee nodes, 221 devices,  20 scenes , 2 apps) +  Hubitat (15 Zigbee nodes) + Home-Assistant (API Integrations). Bridged to Siri and Alexa. Homewave. VeraPlus ExtRooted and mios server independent.

Offline picomo

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Re: New 7.0.27 firmware available
« Reply #16 on: July 18, 2018, 11:48:26 pm »
Linear Garage door openers GD00Z-4 stopped working with latest firmware
Downgraded to 1.7.3831 and they are working again

Offline BrianLBeaton

  • Sr. Member
  • ****
  • Posts: 325
  • Karma: +12/-1
Re: New 7.0.27 firmware available
« Reply #17 on: July 19, 2018, 06:02:01 am »
My garage door opener (Linear GD00Z-4) works fine after upgrading to firmware 1.7.4001 on VeraPlus.

Offline timtownsend

  • Sr. Newbie
  • *
  • Posts: 28
  • Karma: +0/-0
Re: New 7.0.27 firmware available
« Reply #18 on: July 19, 2018, 01:49:24 pm »
Upgraded my VeraPlus, everything is fine. As far as I know I have no Zigbee devices, though.

I have a Zooz ZSE40 4-in-1 sensor that I had previously been unable to add, so I added it after upgrading to the new firmware. It added the 4 devices, but the temperature, humidity and light level all report incorrect values, and they never change. The motion sensor never reports any motion. Probably a bad sensor?

Offline rafale77

  • Community Beta
  • Hero Member
  • ******
  • Posts: 1749
  • Karma: +101/-27
  • HA ≠ IoT as a blue sky is cloudless.
Re: New 7.0.27 firmware available
« Reply #19 on: July 19, 2018, 01:58:09 pm »
Upgraded my VeraPlus, everything is fine. As far as I know I have no Zigbee devices, though.

I have a Zooz ZSE40 4-in-1 sensor that I had previously been unable to add, so I added it after upgrading to the new firmware. It added the 4 devices, but the temperature, humidity and light level all report incorrect values, and they never change. The motion sensor never reports any motion. Probably a bad sensor?

They probably haven't been configured yet. trying waking them up by poking at the wake button.
openLuup (79 devices, 141 scenes, 19 apps) master to VeraPlus (142 zwave nodes, 8 Zigbee nodes, 221 devices,  20 scenes , 2 apps) +  Hubitat (15 Zigbee nodes) + Home-Assistant (API Integrations). Bridged to Siri and Alexa. Homewave. VeraPlus ExtRooted and mios server independent.

Offline RV

  • Full Member
  • ***
  • Posts: 136
  • Karma: +0/-0
Re: New 7.0.27 firmware available
« Reply #20 on: July 20, 2018, 06:48:35 pm »
up to VeraPlus: 1.7.4001. this may have fixed my "16 alerts for 1 event" issue the started after the last update.

Offline anthonyris

  • Sr. Member
  • ****
  • Posts: 250
  • Karma: +6/-1
Re: New 7.0.27 firmware available
« Reply #21 on: July 22, 2018, 09:43:36 pm »
As previously reported, latest firmware upgrade once again resets manual network settings to ?Automatic? and turns Wifi radio back on. Also required power cycle after waiting 30 mins.

Reported here: http://forum.micasaverde.com/index.php/topic,81524.msg395120.html#msg395120

Vera3x2, Leviton, GE dimmers, relays and lamp modules, Sonos, Nests...

Offline RV

  • Full Member
  • ***
  • Posts: 136
  • Karma: +0/-0
Re: New 7.0.27 firmware available
« Reply #22 on: July 23, 2018, 05:01:50 pm »
it did not enable wifi for me

Offline 3rdStng

  • Full Member
  • ***
  • Posts: 124
  • Karma: +1/-0
Re: New 7.0.27 firmware available
« Reply #23 on: July 26, 2018, 08:08:40 pm »
Prior to my upgrade I was getting "Luup : Downloading Luup Plugins" messages. This started at the same time as the Firmware notifications, so I thought they were related. I took all my normal backups and clicked Upgrade. When the upgrade to 7.0.27.4001 on my VeraPlus completed, I was still getting those errors, plus a new one that my EventWatcher Startup Lua Failed. After cruising the forums I realized that my EventWatcher is REALLY old. So I removed it/uninstalled it and now I am getting even more Startup Lua Failures along with a system failure about EventWatcher. "System error : Device: 329. Fail to load implementation file D_EventWatcher.xml" Device 329 was an attempt to reinstall EventWatcher.

All this leads me to two questions.
1. How can I remove device 329 from the LUA startup?
2. I am getting System Errors trying to save scenes. The last time this happened I was out of storage. What can I safely clear up to free up a little room? I cannot even enable remote support.
Code: [Select]
System error : Device: 329. Fail to load implementation file D_EventWatcher.xml
Luup : Downloading Luup Plugins
Luup : Downloading Luup Plugins
Luup : Downloading Luup Plugins
Luup : Failed to download all plugins. Will retry in 10 minutes.
GCal3 Matt[134] : Startup Lua Failed
ERROR : Error in lua for scenes and events
GCal3 Holidays[224] : Startup Lua Failed

Filesystem                Size      Used Available Use% Mounted on
rootfs                    8.6M      8.4M    212.0K  98% /
/dev/root                10.0M     10.0M         0 100% /rom
tmpfs                   124.8M    364.0K    124.4M   0% /tmp
/dev/mtdblock7            8.6M      8.4M    212.0K  98% /overlay
overlayfs:/overlay        8.6M      8.4M    212.0K  98% /
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/mtdblock10          50.0M      1.5M     48.5M   3% /storage
/dev/mtdblock10          50.0M      1.5M     48.5M   3% /etc/cmh-firmware
/dev/mtdblock10          50.0M      1.5M     48.5M   3% /etc/cmh-backup
/dev/sda1               487.9M      4.2M    447.8M   1% /tmp/log/cmh
/dev/mtdblock9           10.0M     10.0M         0 100% /mios

Offline Tsviper

  • Sr. Newbie
  • *
  • Posts: 48
  • Karma: +4/-0
Re: New 7.0.27 firmware available
« Reply #24 on: July 26, 2018, 09:13:48 pm »
Prior to my upgrade I was getting "Luup : Downloading Luup Plugins" messages. This started at the same time as the Firmware notifications, so I thought they were related. I took all my normal backups and clicked Upgrade. When the upgrade to 7.0.27.4001 on my VeraPlus completed, I was still getting those errors, plus a new one that my EventWatcher Startup Lua Failed. After cruising the forums I realized that my EventWatcher is REALLY old. So I removed it/uninstalled it and now I am getting even more Startup Lua Failures along with a system failure about EventWatcher. "System error : Device: 329. Fail to load implementation file D_EventWatcher.xml" Device 329 was an attempt to reinstall EventWatcher.

All this leads me to two questions.
1. How can I remove device 329 from the LUA startup?
2. I am getting System Errors trying to save scenes. The last time this happened I was out of storage. What can I safely clear up to free up a little room? I cannot even enable remote support.
Code: [Select]
System error : Device: 329. Fail to load implementation file D_EventWatcher.xml
Luup : Downloading Luup Plugins
Luup : Downloading Luup Plugins
Luup : Downloading Luup Plugins
Luup : Failed to download all plugins. Will retry in 10 minutes.
GCal3 Matt[134] : Startup Lua Failed
ERROR : Error in lua for scenes and events
GCal3 Holidays[224] : Startup Lua Failed

Filesystem                Size      Used Available Use% Mounted on
rootfs                    8.6M      8.4M    212.0K  98% /
/dev/root                10.0M     10.0M         0 100% /rom
tmpfs                   124.8M    364.0K    124.4M   0% /tmp
/dev/mtdblock7            8.6M      8.4M    212.0K  98% /overlay
overlayfs:/overlay        8.6M      8.4M    212.0K  98% /
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/mtdblock10          50.0M      1.5M     48.5M   3% /storage
/dev/mtdblock10          50.0M      1.5M     48.5M   3% /etc/cmh-firmware
/dev/mtdblock10          50.0M      1.5M     48.5M   3% /etc/cmh-backup
/dev/sda1               487.9M      4.2M    447.8M   1% /tmp/log/cmh
/dev/mtdblock9           10.0M     10.0M         0 100% /mios

I had the same issues with every update since since about May...I have the DataMine 2 Plugin installed and it uses just enough space to fill it up.  This is how I solved my issue: http://forum.micasaverde.com/index.php/topic,81524.msg386059.html#msg386059

Hope this helps.

Offline 3rdStng

  • Full Member
  • ***
  • Posts: 124
  • Karma: +1/-0
Re: New 7.0.27 firmware available
« Reply #25 on: July 26, 2018, 09:21:15 pm »
Hmm. I do have that plugin too. But since I mounted a USB drive and stored all the logs there I didn't think that much room was being used.

Offline Dansker

  • Full Member
  • ***
  • Posts: 108
  • Karma: +0/-0
Re: New 7.0.27 firmware available
« Reply #26 on: July 27, 2018, 02:49:57 am »
Updated 1x Plus and 2x Edge with simple setups:

All took first time and the two Veras with most use report no Vera or luup reboots/restarts since installed 4 days ago (per SysMon). Encouraging, rarely would it run for 2 days.

Offline Tsviper

  • Sr. Newbie
  • *
  • Posts: 48
  • Karma: +4/-0
Re: New 7.0.27 firmware available
« Reply #27 on: July 27, 2018, 11:34:29 am »
Hmm. I do have that plugin too. But since I mounted a USB drive and stored all the logs there I didn't think that much room was being used.

I have the same setup with data being logged to a USB, however the plugin itself takes up 2.4mb which is quite large considering the partition is only about 8.6mb or so if I remember correctly.  That is about 28% of the partition just for this one plugin.  My guess is that anyone who has this plugin installed is having a similar problem.
« Last Edit: July 27, 2018, 11:37:25 am by Tsviper »

Offline rafale77

  • Community Beta
  • Hero Member
  • ******
  • Posts: 1749
  • Karma: +101/-27
  • HA ≠ IoT as a blue sky is cloudless.
Re: New 7.0.27 firmware available
« Reply #28 on: July 27, 2018, 11:51:46 am »
Hmm. I do have that plugin too. But since I mounted a USB drive and stored all the logs there I didn't think that much room was being used.

I have the same setup with data being logged to a USB, however the plugin itself takes up 2.4mb which is quite large considering the partition is only about 8.6mb or so if I remember correctly.  That is about 28% of the partition just for this one plugin.  My guess is that anyone who has this plugin installed is having a similar problem.

If storage space continues to be a problem, I am considering moving the rootfs of the vera to an external USB SSD.
https://wiki.openwrt.org/doc/howto/extroot
Not for the faint of heart but could be the solution.
openLuup (79 devices, 141 scenes, 19 apps) master to VeraPlus (142 zwave nodes, 8 Zigbee nodes, 221 devices,  20 scenes , 2 apps) +  Hubitat (15 Zigbee nodes) + Home-Assistant (API Integrations). Bridged to Siri and Alexa. Homewave. VeraPlus ExtRooted and mios server independent.

Offline RichardTSchaefer

  • Community Beta
  • Master Member
  • ******
  • Posts: 10091
  • Karma: +764/-143
Re: New 7.0.27 firmware available
« Reply #29 on: July 27, 2018, 11:56:49 am »
The right solution is for Vera to NOT release the OS every time ...
They need to break their current installation into:
    a) An OS piece
    b) A Vera piece
Then they olnly need enough space for the Vera Stuff  with each release ...
Then they can release an OS independent of the Vera Stuff and visa-versa.
Note: There is already a
    c) User/Controller specific piece that is supposed to survive an update