Author Topic: FortezZ WV01 Water shutoff functions somehow reversed on my dashboard?  (Read 451 times)

Offline Firebird1999us

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
This is the shutoff I've had installed since 2016:

https://www.fortrezz.com/shop/wireless-water-valve-indoor

I did the most recent firmware upgrade on my vera plus (with help from customer support/remote access because my unit got stuck in an update loop). Since it came back on the water valve has the functions reversed with Close always selected and open deselected. As such I have to open the valve through my dashboard or phone to close it. I've unpaired, deleted and reattached the FortezZ. I Even unplugged it. However I can't get the functions to correct/reverse. Any idea how to fix this?

I've also started getting messages that say "Sorry, the node reports it's busy. Please try again later..Sorry, the node reports it's busy. Please try again later." on my dashboard??
« Last Edit: July 30, 2018, 09:33:32 am by Firebird1999us »

Offline Jamr

  • Hero Member
  • *****
  • Posts: 812
  • Karma: +28/-8
This is the shutoff I've had installed since 2016:

https://www.fortrezz.com/shop/wireless-water-valve-indoor

I did the most recent firmware upgrade on my vera plus (with help from customer support/remote access because my unit got stuck in an update loop). Since it came back on the water valve has the functions reversed with Close always selected and open deselected. As such I have to open the valve through my dashboard or phone to close it. I've unpaired, deleted and reattached the FortezZ. I Even unplugged it. However I can't get the functions to correct/reverse. Any idea how to fix this?

I've also started getting messages that say "Sorry, the node reports it's busy. Please try again later..Sorry, the node reports it's busy. Please try again later." on my dashboard??

Not much you can do until Vera fixes it unless you know how to code.

Offline bobmoorman

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Re: FortezZ WV01 Water shutoff functions somehow reversed on my dashboard?
« Reply #2 on: September 11, 2018, 08:06:56 am »
I am having the same problen with my Watercop Valve basically identical to FortezZ. I did figure out a way to correct the open and close through a fix from Vera. See Below. I do hope they can figure out the anoying "Sorry, the node reports it's busy. Please try again later." Also I have to show the device as a relay instead of a Valve.
 
To reverse the ON/OFF status of the valve you have to go to Devices > click on the ?>? button for the valve > click on Advanced > New Service and fill out the input fields as follows:

New service: urn:micasaverde-com:serviceId:HaDevice1
New variable: ReverseOnOff
New value: 1

> click on Add > then click on Reload Engine.

Once the engine reloads the status should be displayed correctly. However you might also have to activate the valve in order for the status to update

Click on your device and go to "Advanced".
Under "device_type" it will probably say, "urn:schemas-upnp-org:device:BinaryLight:1" - Change this to say "urn:schemas-micasaverde-com:device:Relay:1" (Thank you Don Diego)
Scroll down to "device_file". It will probably say "D_BinaryLight1.xml" - Change this to say "D_Relay1.xml"
Scroll down to "device_json". It will probably say "D_BinaryLight1.json" - Change this to say "D_Relay1.json"