Author Topic: VeraPlus - turn off zigbee and bluetooth  (Read 980 times)

Offline runjo

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
VeraPlus - turn off zigbee and bluetooth
« on: August 07, 2018, 07:27:23 am »
Hello!

I want to turn off zigbee and bluetooth for now, can I do that on the VeraPlus?  ::)

Offline wilme2

  • Hero Member
  • *****
  • Posts: 1217
  • Karma: +28/-13
Re: VeraPlus - turn off zigbee and bluetooth
« Reply #1 on: August 10, 2018, 05:02:58 pm »
I too would like to disable bluetooth and zigbee on my VeraSecure, as I am not using them, at least not yet.

Should be an easy thing right?  It should be under Settings, Zigbee Settings.  But there is no option to disable...

I haven't seen anyone post a way to do it at the OS level either, like you can do with wi-fi...
Long Live UI5!  (OK finally made the switch to UI7 in January 2018, and am pretty happy....)

Offline Nameless

  • Full Member
  • ***
  • Posts: 179
  • Karma: +3/-0
Re: VeraPlus - turn off zigbee and bluetooth
« Reply #2 on: August 13, 2018, 01:38:04 pm »
I'd like this too. No need for the Zigbee radio on when I control all my Zigbee devices with a competitor's hub, since my Vera can't.

Sent from my LGUS992 using Tapatalk


Offline cmille34

  • Sr. Newbie
  • *
  • Posts: 31
  • Karma: +3/-1
Re: VeraPlus - turn off zigbee and bluetooth
« Reply #3 on: August 15, 2018, 02:29:01 pm »
I realize this will fall on deaf ears as most suggestions do but I too would like to be able to disable the bluetooth and zigbee radios on my VeraPlus.

Offline Inzax

  • Sr. Member
  • ****
  • Posts: 392
  • Karma: +26/-64
Re: VeraPlus - turn off zigbee and bluetooth
« Reply #4 on: August 16, 2018, 11:59:54 am »
Checking in....would love to turn off Zigbee and bluetooth.
Proud Member of the Epic Smite Thread.
VeraSecure; Concord 4 Panel; 6 IP Cameras; Imperiehome; Housemodes; system monitor; DeusexmachinaII; Vera Concierge

Offline rafale77

  • Hero Member
  • *****
  • Posts: 1248
  • Karma: +62/-23
Re: VeraPlus - turn off zigbee and bluetooth
« Reply #5 on: August 16, 2018, 12:21:57 pm »
Not being critical but just being curious, what would that do for you? I personally use the zigbee radio but I don't think bluetooth is on.
openLuup (97 devices, 134 scenes, 20 apps) controlling HomeAss + VeraPlus (138 zwave nodes, 8 Zigbee nodes, 205 devices, 20 scenes , 2 app) Bridged to Homekit and Alexa. VeraPlus ExtRooted!

Offline Nameless

  • Full Member
  • ***
  • Posts: 179
  • Karma: +3/-0
Re: VeraPlus - turn off zigbee and bluetooth
« Reply #6 on: August 16, 2018, 02:04:07 pm »
For me, I'm looking to avoid interference. I have an existing Zigbee network on a Wink 2 hub already. I also find my Bluetooth is active when searching for connections, so it is apparently on in some way.

I've been noticing some connections drop recently, so trying to eliminate a few unneeded networks.

Sent from my LGUS992 using Tapatalk


Offline rafale77

  • Hero Member
  • *****
  • Posts: 1248
  • Karma: +62/-23
Re: VeraPlus - turn off zigbee and bluetooth
« Reply #7 on: August 16, 2018, 03:14:11 pm »
I just checked and in spite on the bluetooth LED being on, it is not discoverable and my spectrum scanner shows that it is off. My zigbee is on and if you worry about interference, you could just move it's channel to a free space. The zigbee signal is very narrow and is unlikely to interfere...
openLuup (97 devices, 134 scenes, 20 apps) controlling HomeAss + VeraPlus (138 zwave nodes, 8 Zigbee nodes, 205 devices, 20 scenes , 2 app) Bridged to Homekit and Alexa. VeraPlus ExtRooted!

Offline Nameless

  • Full Member
  • ***
  • Posts: 179
  • Karma: +3/-0
Re: VeraPlus - turn off zigbee and bluetooth
« Reply #8 on: August 16, 2018, 08:09:11 pm »
What's strange for me is that I've been able to see active Bluetooth signals from my Plus when pairing random devices in my house, even my Wink Hub 2.

I do need to look at the Zigbee channel and try to put it on something other than my Wink network. That hadn't even crossed my mind. They're in close proximity.

Sent from my LGUS992 using Tapatalk


Offline rafale77

  • Hero Member
  • *****
  • Posts: 1248
  • Karma: +62/-23
Re: VeraPlus - turn off zigbee and bluetooth
« Reply #9 on: August 17, 2018, 02:18:42 am »
I found a way to disable bluetooth by SSHing into the unit and editing the file /etc/init.d/bluetoothd and commenting out the content of the start service function. After that reboot your vera and BLE should not start.

Edit: It seems like i had disabled mine a while ago without thinking too much about it. Go under /etc/config/bluetooth, open the file and change the

Code: [Select]
config bluetoothd
option enabled   0
« Last Edit: August 17, 2018, 03:18:30 am by rafale77 »
openLuup (97 devices, 134 scenes, 20 apps) controlling HomeAss + VeraPlus (138 zwave nodes, 8 Zigbee nodes, 205 devices, 20 scenes , 2 app) Bridged to Homekit and Alexa. VeraPlus ExtRooted!

Offline runjo

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
Re: VeraPlus - turn off zigbee and bluetooth
« Reply #10 on: August 17, 2018, 05:40:36 am »
Thanks, will try to turn off BT.

Can we SSHinging into the file and turn off Zigbee?

Reason to turn off is to be sure of no interference and also minimize exposure. We turn off wifi also every night.. just to be on the safe side..  ::)

Offline rafale77

  • Hero Member
  • *****
  • Posts: 1248
  • Karma: +62/-23
Re: VeraPlus - turn off zigbee and bluetooth
« Reply #11 on: August 19, 2018, 10:17:21 am »
Unfortunately, I have not found a way to disable zigbee...
openLuup (97 devices, 134 scenes, 20 apps) controlling HomeAss + VeraPlus (138 zwave nodes, 8 Zigbee nodes, 205 devices, 20 scenes , 2 app) Bridged to Homekit and Alexa. VeraPlus ExtRooted!

Offline wilme2

  • Hero Member
  • *****
  • Posts: 1217
  • Karma: +28/-13
Re: VeraPlus - turn off zigbee and bluetooth
« Reply #12 on: August 21, 2018, 11:17:42 am »
I just checked and in spite on the bluetooth LED being on, it is not discoverable and my spectrum scanner shows that it is off. My zigbee is on and if you worry about interference, you could just move it's channel to a free space. The zigbee signal is very narrow and is unlikely to interfere...

In my neighborhood my spectrum analyzer shows frequent interference all over the spectrum.  433 mhz is practically unusable, and for my motorized blinds I had to put in multiple gateways all sending the same commands a few seconds apart - usually ONE of the signals gets received by each of the blinds.  Between the neighborhood interference, and the fact my home is a 3 story brownstone, configuring wireless network is a real challenge - disabling anything not in use is important...
Long Live UI5!  (OK finally made the switch to UI7 in January 2018, and am pretty happy....)

Offline rafale77

  • Hero Member
  • *****
  • Posts: 1248
  • Karma: +62/-23
Re: VeraPlus - turn off zigbee and bluetooth
« Reply #13 on: August 21, 2018, 10:33:45 pm »
To be clear both bluetooth and zigbee are on 2.4GHz. The bluetooth is BLE. It's range is actually quite short. Not to get too much into physics but the higher the frequency, the more amplitude the signal needs to have to be able to reach the same range because it is much more attenuated over both air and obstacles. I am not saying, don't turn it off. I obviously turned of BT myself and am using Zigbee. It is just that the zigbee signal is very narrow and relatively weak and is more likely to be interfered with than to interfere with others. I had one such case with my sonos-net completely killing my hue and yet my sonos didn't feel anything.
openLuup (97 devices, 134 scenes, 20 apps) controlling HomeAss + VeraPlus (138 zwave nodes, 8 Zigbee nodes, 205 devices, 20 scenes , 2 app) Bridged to Homekit and Alexa. VeraPlus ExtRooted!