We have moved at community.getvera.com

Author Topic: SQBlaster Plugin in UI5 apps.mios.com broken...  (Read 1953 times)

Offline guessed

  • Community Beta
  • Master Member
  • ******
  • Posts: 5301
  • Karma: +92/-22
  • Release compat is not a bolted-on afterthought
SQBlaster Plugin in UI5 apps.mios.com broken...
« on: April 14, 2012, 03:51:15 pm »
Folks,
There's a bug in http://apps.mios.com that's causing the UI5 SQBlaster Plugin to break.  The MCV Team is aware of this, and will work on addressing the problem.

For now, users can work-around the problem by setting the downloaded Device to use an implementation file explicitly, using the Advanced Tab of the dialog.  This value should be:

    I_SQBlaster1.xml


Thanks to @Roy S for bringing this to my attention.

Offline manfaiho

  • Jr. Member
  • **
  • Posts: 70
  • Karma: +0/-0
Re: SQBlaster Plugin in UI5 apps.mios.com broken...
« Reply #1 on: April 24, 2012, 01:05:42 pm »
I tried to add this workaround then Go to Add AV Device and go to the command test page. When click the button, it still prompts me No IR Bluster. Even I use the workaround from another thread for GC, no test on each codeset then let is create AV device. But seems I can't properly send the correct command to my IR device from there. What's the problem this workaround fixing? Sorry for my naive question.

Offline guessed

  • Community Beta
  • Master Member
  • ******
  • Posts: 5301
  • Karma: +92/-22
  • Release compat is not a bolted-on afterthought
Re: SQBlaster Plugin in UI5 apps.mios.com broken...
« Reply #2 on: April 24, 2012, 03:08:02 pm »
What's the problem this workaround fixing? Sorry for my naive question.
This specific fix relates to the apps.mios.com store.  When you download this plugin, it's files contains 2x [different] I_xxxxx.xml files (intentionally).

Everything is setup to tell them to use I_SQBlaster1.xml but, for some unknown reason, they're chosing the other implementation file... which stops the Plugin itself from loading.

There's still the separate issue you're citing, which relates to new IR Device creation, in general, being broken in UI5.

Offline vascodp

  • Sr. Newbie
  • *
  • Posts: 41
  • Karma: +0/-0
Re: SQBlaster Plugin in UI5 apps.mios.com broken...
« Reply #3 on: April 27, 2012, 02:07:16 pm »
@guessed, before you manually set the value "I_SQBlaster1.xml", the field was supposed to be empty ? Or "I_SQBlasterController1.xml", as in my case ?

Offline guessed

  • Community Beta
  • Master Member
  • ******
  • Posts: 5301
  • Karma: +92/-22
  • Release compat is not a bolted-on afterthought
Re: SQBlaster Plugin in UI5 apps.mios.com broken...
« Reply #4 on: May 04, 2012, 09:29:18 am »
apps.mios.com is incorrectly setting "I_SQBlasterController1.xml" into the field.  The work-around here is to set it back to the correct value, which is "I_SQBlaster1.xml"