Author Topic: [SOLVED] RFXtrx433E WON'T PAIR WITH SOMFY  (Read 129 times)

Offline bartzzimpson

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
[SOLVED] RFXtrx433E WON'T PAIR WITH SOMFY
« on: September 05, 2018, 09:58:31 am »
Solved  :), well sort-of.
I just used the Windows RFXmngr utility to pair the bridge with my Somfy blind using an arbitrary unit ID (I used 1,1) and then created a Somfy device in Vera with the same ID.

-------------------------------------------------------------

I've followed the guides on Vesternet.
I've created the master device using D_RFXtrx.xml
From that I've created a Somfy device using category RFY.
When I try and send a PROGRAM command to pair the RFXtrx322E with the Somfy, nothing happens. I know this because the LEDs on the RFXtrx433E don't blink.
Yet, if I send an UP or DOWN command using the Somfy device in Vera, the LEDs blink as expected.

I found these 2 consecutive entries in the log...

luup_log:101: RFXtrx: dbg: sendUnusualCommand 102 PROGRAM <0x74d73520>
LuaInterface::CallFunction_Job device 101 function SRFXtrx_rfxtrx1_SendCommand_run failed [string "module("L_RFXtrx", package.seeall)..."]:6193: attempt to concatenate field 'deviceType' (a nil value) <0x74d73520>



Incidentally, if I connect the RFXtrx433E to the USB port on my laptop and run the Windows RFXmngr utility, I can successfully pair with the Somfy and raise and lower the blind.

My versions are
    Vera Edge 1.7.4000
    RFXtrx Plugin version: 1.50
    RFXtrx firmware: 1024
    RFXtrx firmware type: Ext2
    RFXtrx hardware: 1.3

Any and all suggestions greatly appreciated.
« Last Edit: September 09, 2018, 06:35:48 pm by bartzzimpson »

Offline roblor

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: [SOLVED] RFXtrx433E WON'T PAIR WITH SOMFY
« Reply #1 on: September 17, 2018, 02:09:39 am »
Could you explain how you create a "Somfy device using category RFY in Vera with the same ID" ?
Any help greatly appreciated

Offline bartzzimpson

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: [SOLVED] RFXtrx433E WON'T PAIR WITH SOMFY
« Reply #2 on: September 19, 2018, 12:36:32 am »
You need to follow the two guides on Vesternet
https://www.vesternet.com/resources/application-notes/apnt-116/
https://www.vesternet.com/resources/application-notes/apnt-79/

In the second guide (Controlling Somfy RTS Blinds with the RFXtrx433E)
when you get to the section called "Add a Window Covering device to the Vera UI7"
set the ID and UNIT CODE values to match the values you used in the RFXmngr application.

See attached picture for the Vera screen.