Author Topic: Next Plugin Update  (Read 574 times)

Offline tinman

  • Full Member
  • ***
  • Posts: 212
  • Karma: +13/-0
Next Plugin Update
« on: October 06, 2018, 12:54:13 pm »
The plugin has been updated to handle the Pro firmware types. There are a couple of minor issues with the previous version that have been reported that are not addressed in this update. I'll have to try to troubleshoot those as time allows. All the plugin files are in the attached Zip file. The only files modified are:
L_RFXtrx.lua
J_RFXtrx.js
S_RFXtrx.xml

Offline madmaniac73

  • Newbie
  • *
  • Posts: 18
  • Karma: +1/-0
Re: Next Plugin Update
« Reply #1 on: October 06, 2018, 05:50:11 pm »
Great work! You beat me to it by 8 minutes, i was just about to release a fixed version myself since I didn't know if you had the time to do it. :)

Thanks again for your effort! FYI, one thing that isn't working (and I can't figure out why) is to enable and disable protocols from the UI. Even if you choose Save it just shows the same protocols as before when refreshing. No big deal, it can be done from RFXmngr, but it is a bit annoying to have to disconnect the RFX every time.

Offline tinman

  • Full Member
  • ***
  • Posts: 212
  • Karma: +13/-0
Re: Next Plugin Update
« Reply #2 on: October 06, 2018, 06:54:20 pm »
I've tested my system pretty thoroughly and have not seen any problems like you've described. If you're using any Pro version I've found that if you've selected a different frequency (i.e. 433.42 or 434.40) and you've enabled either of the associated protocols (Funkbus or MCZ), you cannot switch away from that frequency until that protocol is disabled. My version of the plugin does that automatically. Also, if you've enabled one or more protocols at 433.92 Mhz, switched to a different frequency and enabled a protocol, all protocols enabled under 433.92 will be disabled by the transceiver - not by the plugin.

Offline madmaniac73

  • Newbie
  • *
  • Posts: 18
  • Karma: +1/-0
Re: Next Plugin Update
« Reply #3 on: October 07, 2018, 07:06:01 am »
Let me show what's happening here:

I first go to the protocol setting in the UI of Vera: See Capture1.JPG

Then I disable X10 and click Save RFX Settings: See Capture2.JPG

I wait until i see the response in Last Received message, then click back, then refresh the browser and go into the protocol setting again: See Capture3.JPG.

Voila X10 still enabled.

I use Pro1 version 1028, no strange protocols enabled, 433.92Mhz, nothing unusual.

Apparently i do something different from you, but i can't figure out what it would be?

Offline tinman

  • Full Member
  • ***
  • Posts: 212
  • Karma: +13/-0
Re: Next Plugin Update
« Reply #4 on: October 07, 2018, 08:38:20 am »
OK - I was testing with version 1027; surprised to see another firmware update so soon. If you would, try version 1027. I'll try 1028.

UPDATE! I just tried Pro1 firmware version 1028. It all seems to work with the plugin as expected. I took a look at the screen shots you posted. They are NOT from the latest version (1.60) of the plugin. Make sure that you've uploaded the three modified files.

« Last Edit: October 07, 2018, 09:07:10 am by tinman »

Offline madmaniac73

  • Newbie
  • *
  • Posts: 18
  • Karma: +1/-0
Re: Next Plugin Update
« Reply #5 on: October 07, 2018, 10:51:12 am »
Hi tinman,

I certainly did upload the changed files, but now I did it again, and as you said, now it looks different and works. I guess the update of files is not 100% consequent in Vera, I've seen before that uploads seems OK, but the file is still old. Thanks for helping me out!

/Johan

Offline thetriathlete

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: Next Plugin Update
« Reply #6 on: October 16, 2018, 10:58:54 pm »
Hi I need help

I recently purchased the rfxtrx433e, connected it to my veraplus on firmware 1.7.4001. Follow the instructions to configure. I can create the master device using plugin 1.6 but when i go to create a new device for RFY, managing somfy blinds it just sits on vera will reload to validate changes. Nothing happens, after a while the new device will show up in the devices list. When i go to the master device to configure the new device i run the program command but nothing happens. I can manage the blinds using rfxcom manager on a windows pc so why is it not working from the vera plus device? Any help would be greatly appreciated.

Offline DrD

  • Sr. Newbie
  • *
  • Posts: 25
  • Karma: +0/-0
Re: Next Plugin Update
« Reply #7 on: January 08, 2019, 07:27:10 am »
 :)Hi.
-I have installed the 38 RFXtrx files from ''lobodomo'' (thanks)
-Vera3 UI7 version
-I Installed the RFX plug in (was that necessary?)
-I just enabeled roller troll in the RFXtrx controller device Icon
-My vera now controls Roller troll shade blinds....suuuuuuper
-With my laptop Windows7: it works very good and responsive.
-With my Cell phone android 8.0 (Note8) and Vera mobile app:  the delay response is much longer, no precision with the commands up-stop-down.
-What can I do to solve this problem?:
 Should I reinstall RFXtrx controler device ?
Would it work better with vera edge or vera plus...
Can my Smatthings hub V3 make an interference???

Thanks for your precious input
Pierre

Offline tinman

  • Full Member
  • ***
  • Posts: 212
  • Karma: +13/-0
Re: Next Plugin Update
« Reply #8 on: January 08, 2019, 09:55:08 am »
I'm not sure what you mean by 'the 38 RFXtrx files from ''lobodomo''' or exactly the source of the " RFX plug in ". If you've used the zip file available in this forum and the version number displayed in the RFXtrx Help tab is 1.61 then you've installed the correct files. You did not need to install anything else.
As for the problem you're seeing, I can't be sure but I suspect that re-installing any files will make no difference. It may be merely the delays caused by a command triggered in your cell phone - transmitted via cell towers then to wifi - then to your router - then to the Vera. All of that takes time. Does your phone automatically connect to your wifi router when it can? This may eliminate the cell tower link.