Author Topic: Push Notification Plugin  (Read 122470 times)

Offline harkonen

  • Newbie
  • *
  • Posts: 19
  • Karma: +0/-0
Re: Push Notification Plugin
« Reply #360 on: August 22, 2017, 06:15:27 am »
I've downloaded PushOver app from appstore and testing it right now. Seems that push messages are working fine. It is 7 day trial and after that you have to buy 5,50? licence/device..

Offline aquavass

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Re: Push Notification Plugin
« Reply #361 on: October 30, 2017, 05:53:48 am »
Hi,

Has something changed as PushOver stopped working for me

Offline pls90

  • Sr. Member
  • ****
  • Posts: 299
  • Karma: +2/-0
Re: Push Notification Plugin
« Reply #362 on: January 01, 2018, 08:44:22 am »
Hi,

Has something changed as PushOver stopped working for me
same here, just stopped working.
Has anything on the pushover api side changed? I did not make any changes on the vera side.

Offline TheCivvie

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
Re: Push Notification Plugin
« Reply #363 on: January 02, 2018, 01:01:37 pm »
Also been trying to get this to work

I see in the log when I try to send a message :

luvd_get_info mg conn can't read /etc/cmh-ludl//data_requestid=lu_action&serviceId=urn:micasaverde-com:serviceId:HomeAutomationGateway1&action=RunLua&Code=luup.call_action("urn:upnp-org:serviceId:IOSPush1", "SendPushOverNotification",{ Subject= "Test Subject", Message="test", Priority="0", URL="", URLTitle="", Sound=""},21) or /etc/cmh-lu//data_requestid=lu_action&serviceId=urn:micasaverde-com:serviceId:HomeAutomationGateway1&action=RunLua&Code=luup.call_action("urn:upnp-org:serviceId:IOSPush1", "SendPushOverNotification",{ Subject= "Test Subject", Message="test", Priority="0", URL="", URLTitle="", Sound=""},21) from filename /data_requestid=lu_action&serviceId=urn:micasaverde-com:serviceId:HomeAutomationGateway1&action=RunLua&Code=luup.call_action("urn:upnp-org:serviceId:IOSPush1", "SendPushOverNotification",{ Subject= "Test Subject", Message="test", Priority="0", URL="", URLTitle="", Sound=""},21) pPtrFile (null) <0x73964520>

Offline pls90

  • Sr. Member
  • ****
  • Posts: 299
  • Karma: +2/-0
Re: Push Notification Plugin
« Reply #364 on: January 03, 2018, 06:17:10 pm »
I deactivated the  "encrypted" option over at pushover.net for one of 4 devices and it started working again for ALL my devices.
Might be a coincidence but maybe worth a try.

Offline TheCivvie

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
Re: Push Notification Plugin
« Reply #365 on: January 04, 2018, 03:34:51 pm »
I deactivated the  "encrypted" option over at pushover.net for one of 4 devices and it started working again for ALL my devices.
Might be a coincidence but maybe worth a try.
Tried and no success. Guessing the lack of any answer the app is not worth using

Sent from my Vivo XL2 using Tapatalk


Offline RichardTSchaefer

  • Master Member
  • *******
  • Posts: 10061
  • Karma: +759/-141
Re: Push Notification Plugin
« Reply #366 on: January 04, 2018, 04:06:14 pm »
I just tested Pushover and PushBullet on my Ipad using the Vera Alerts Plugin ... both are working just fine.

Offline TheCivvie

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
Re: Push Notification Plugin
« Reply #367 on: January 04, 2018, 04:13:15 pm »
I just tested Pushover and PushBullet on my Ipad using the Vera Alerts Plugin ... both are working just fine.
I wish I knew why it wouldn't work for me. I have tried everything. I know that I will do something and it will, but for now it is driving me nuts.
Going to try and uninstall and restart my plus then reinstall

Sent from my Vivo XL2 using Tapatalk


Offline TheCivvie

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
Re: Push Notification Plugin
« Reply #368 on: January 05, 2018, 09:28:13 am »
Uninstalled and restarted, then added the app again. When I went in to setup Pushover it flashed some error message about ios push. It was too fast to see and I had to back out.
Then went back into Pushover setup, which started normally this time. Then added the details but when I pressed save and back and then re-entered the pushover configuration, all settings were back to a configuration setup.

Went into advanced and added the details there. I am guessing to use my own pushover app, I had to set PushOveruseCustomAppKey to 1. I have noticed that it reset back to 0 and all settings have reset to what is the installation configuration

After making sure all setting were correct, went to send message and nothing goes. It just sits there. 5 minutes later, I decided to restart the system in case it needed a reboot

So after reboot everything went back to original, all my settings are lost

This is before the reboot
(https://uploads.tapatalk-cdn.com/20180105/c2728014bc8d0958a004e2934ac30b62.jpg)

And after the reboot
(https://uploads.tapatalk-cdn.com/20180105/c406dcc9ef31df2653dfe413e1101b90.jpg)

I am at a loss as to what to do now

Sent from my Vivo XL2 using Tapatalk


Offline pls90

  • Sr. Member
  • ****
  • Posts: 299
  • Karma: +2/-0
Re: Push Notification Plugin
« Reply #369 on: January 05, 2018, 09:40:57 am »
there is a bug in the send message function.
Try actions tab instead.

Offline oliwa

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
Re: Push Notification Plugin
« Reply #370 on: January 05, 2018, 03:24:26 pm »
I recently installed version 0.99 from the mios store and it is working fine for me. I had to edit the user key and api token from the variables page but after reading this entire thread it seems like this was a common issue.

I use PushOver and the luup code snippet in the first post works great and I was able to easily tie in a push notification for battery low triggers.

It is true that there hasn't been an update in nearly 4 years but if it works and serves the intended purpose, updates are not needed.


Offline TheCivvie

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
Re: Push Notification Plugin
« Reply #371 on: January 06, 2018, 07:44:18 am »
I reinstalled it and then added the luas notification to a scene to test it.

And joy it works. Thanks everyone. I have appreciate all the help.

Waiting on some z-wave sensors to arrive and will get my teeth into it

Sent from my Vivo XL2 using Tapatalk


Offline Tlex

  • Sr. Newbie
  • *
  • Posts: 39
  • Karma: +1/-0
PushOver implementation question
« Reply #372 on: March 27, 2018, 10:48:34 am »
Just realizing that when not using the PushOverCustomAppKey the icon displayed is different (basically showing to upgrade to .98) I was wondering how complicate it would be to transform the PushOverCustomAppKey as a luup.call_action variable in order to have multiple customappkey and send different icons based on context...

Thanks for your help :)