We have moved at community.getvera.com

Author Topic: New VeraLite, do I still need my Aeon Labs Z-Stick 2 ? mControl & Vera -RESOLVED  (Read 21019 times)


Offline cw-kid

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1612
  • Karma: +18/-2
Re: New VeraLite, do I still need my Aeon Labs Z-Stick 2 ? mControl & Vera
« Reply #16 on: August 15, 2012, 08:34:53 am »
You have the same appliance module as me! So not sure what is wrong? can you tell me the exact version / modified date of the Vera Luup driver files you have ? Or can you email them to me.

I am sure Win7 and WHSV1 mcontrol use the same driver files, I am thinking maybe you have an older driver version that works?

Cheers


Offline cw-kid

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1612
  • Karma: +18/-2
Re: New VeraLite, do I still need my Aeon Labs Z-Stick 2 ? mControl & Vera
« Reply #17 on: August 15, 2012, 11:05:24 am »
From the mControl log file:

Working Dimable Module:

Code: [Select]
version="1.0"?><root LoadTime="1345043503" DataVersion="43503354" UserData_DataVersion="43503001" TimeStamp="1345043906" ZWaveStatus="1" LocalTime="2012-08-15 16:18:26 D"><startup><tasks></tasks></startup><devices><device id="3" status="4"><states><state id="95" service="urn:upnp-org:serviceId:SwitchPower1" variable="Status" value="0"></state><state id="96" service="urn:upnp-org:serviceId:Dimming1" variable="LoadLevelStatus" value="0"></state><state id="97" service="urn:upnp-org:serviceId:Dimming1" variable="LoadLevelTarget" value="0"></state></states><Jobs><Job id="25" name="job#25 :Level 99 node 2 (0xb09ed0) N:2 P:35 S:4" icon="LEVEL" comments="Transmit was ok" status="4"></Job><Job id="26" name="job#26 :Level 0 node 2 (0xad30f8) N:2 P:35 S:4" icon="LEVEL" comments="Transmit was ok" status="4"></Job></Jobs><tooltip display="1" tag2="Transmit was ok"></tooltip></device><device id="7" status="-1"><tooltip display="0"></tooltip></device><device id="17" status="-1"><tooltip display="0"></tooltip></device></devices><scenes><scene id="2" status="-1" active="true"><Jobs></Jobs><tooltip display="0"></tooltip></scene></scenes></root>
2012-08-15 16:18:42.671 00:17:51.5287875 (013) I0 Automation command [3, "3", "On", 0, "EAVeraLuup", 1]
2012-08-15 16:18:42.671 00:17:51.5364877 (017) D0 EAVeraLuup: message sent (W) through [http://192.168.0.11:49451/]: data_request?id=lu_action&output_format=xml&DeviceNum=3&serviceId=urn:upnp-org:serviceId:Dimming1&action=SetLoadLevelTarget&newLoadlevelTarget=100|<cr>
2012-08-15 16:18:42.671 00:17:51.5366961 (030) D0 EAVeraLuup: received message from device through [http://192.168.0.11:49451/]: <?xml version="1.0"?><u:SetLoadLevelTargetResponse xmlns:u="urn:schemas-upnp-org:service:Dimming:1"><JobID>29</JobID></u:SetLoadLevelTargetResponse>
2012-08-15 16:18:42.671 00:17:51.5368458 (017) I0 Broadcasted notification: ["EAVeraLuup:3", "100"] for device [Lamp (Left)]
2012-08-15 16:18:46.375 00:17:55.2364158 (013) I0 Automation command [3, "3", "Off", 100, "EAVeraLuup", 1]
2012-08-15 16:18:46.390 00:17:55.2473811 (017) D0 EAVeraLuup: message sent (W) through [http://192.168.0.11:49451/]: data_request?id=lu_action&output_format=xml&DeviceNum=3&serviceId=urn:upnp-org:serviceId:SwitchPower1&action=SetTarget&newTargetValue=0|<cr>
2012-08-15 16:18:46.390 00:17:55.2488134 (030) D0 EAVeraLuup: received message from device through [http://192.168.0.11:49451/]: <?xml version="1.0"?><u:SetTargetResponse xmlns:u="urn:schemas-upnp-org:service:SwitchPower:1"><JobID>30</JobID></u:SetTargetResponse>
2012-08-15 16:18:46.390 00:17:55.2497783 (017) I0 Broadcasted notification: ["EAVeraLuup:3", "0"] for device [Lamp (Left)]

Not working appliance Module:

Code: [Select]
version="1.0"?><u:SetTargetResponse xmlns:u="urn:schemas-upnp-org:service:SwitchPower:1"><JobID>50</JobID></u:SetTargetResponse>
2012-08-15 16:24:18.703 00:23:27.6105379 (015) I0 Broadcasted notification: ["EAVeraLuup:17", "1"] for device [Fireplace]
2012-08-15 16:24:20.156 00:23:29.0651568 (013) I0 Automation command [13, "17", "Off", 1, "EAVeraLuup", 1]
2012-08-15 16:24:20.171 00:23:29.0777945 (030) D0 EAVeraLuup: message sent (W) through [http://192.168.0.11:49451/]: data_request?id=lu_action&output_format=xml&DeviceNum=17&serviceId=urn:upnp-org:serviceId:SwitchPower1&action=SetTarget&newTargetValue=0|<cr>
2012-08-15 16:24:20.171 00:23:29.0781143 (015) D0 EAVeraLuup: received message from device through [http://192.168.0.11:49451/]: <?xml version="1.0"?><u:SetTargetResponse xmlns:u="urn:schemas-upnp-org:service:SwitchPower:1"><JobID>51</JobID></u:SetTargetResponse>
2012-08-15 16:24:20.171 00:23:29.0783680 (030) I0 Broadcasted notification: ["EAVeraLuup:17", "0"] for device [Fireplace]
2012-08-15 16:24:24.578 00:23:33.4876463 (030) D0 EAVeraLuup: message sent (W) through [http://192.168.0.11:49451/]: data_request?id=lu_status2&output_format=xml&DataVersion=43503574&LoadTime=1345043503|<cr>
2012-08-15 16:24:24.578 00:23:33.4879329 (004) D0 EAVeraLuup: received message from device through [http://192.168.0.11:49451/]: <?xml version="1.0"?><root LoadTime="1345043503" DataVersion="43503588" UserData_DataVersion="43503001" TimeStamp="1345044266" ZWaveStatus="1" LocalTime="2012-08-15 16:24:26 D"><startup><tasks></tasks></startup><devices><device id="7" status="-1"><tooltip display="0"></tooltip></device><device id="17" status="4"><Jobs><Job id="50" name="job#50 :OFF node 7 (0xade448) N:7 P:35 S:4" icon="OFF" comments="Transmit was ok" status="4"></Job><Job id="51" name="job#51 :OFF node 7 (0xaa5d08) N:7 P:35 S:4" icon="OFF" comments="Transmit was ok" status="4"></Job></Jobs><tooltip display="1" tag2="Transmit was ok"></tooltip></device></devices></root>
2012-08-15 16:24:36.078 00:23:44.9899531 (013) I0 Automation command [13, "17", "On", 0, "EAVeraLuup", 1]
2012-08-15 16:24:36.093 00:23:44.9990968 (030) D0 EAVeraLuup: message sent (W) through [http://192.168.0.11:49451/]: data_request?id=lu_action&output_format=xml&DeviceNum=17&serviceId=urn:upnp-org:serviceId:SwitchPower1&action=SetTarget&newTargetValue=1|<cr>
2012-08-15 16:24:36.093 00:23:44.9994334 (004) D0 EAVeraLuup: received message from device through [http://192.168.0.11:49451/]: <?xml version="1.0"?><u:SetTargetResponse xmlns:u="urn:schemas-upnp-org:service:SwitchPower:1"><JobID>53</JobID></u:SetTargetResponse>
2012-08-15 16:24:36.093 00:23:44.9997024 (030) I0 Broadcasted notification: ["EAVeraLuup:17", "1"] for device [Fireplace]
2012-08-15 16:24:37.578 00:23:46.4896613 (013) I0 Automation command [13, "17", "Off", 1, "EAVeraLuup", 1]
2012-08-15 16:24:37.593 00:23:46.4983015 (004) D0 EAVeraLuup: message sent (W) through [http://192.168.0.11:49451/]: data_request?id=lu_action&output_format=xml&DeviceNum=17&serviceId=urn:upnp-org:serviceId:SwitchPower1&action=SetTarget&newTargetValue=0|<cr>
2012-08-15 16:24:37.593 00:23:46.4984717 (015) D0 EAVeraLuup: received message from device through [http://192.168.0.11:49451/]: <?xml version="1.0"?><u:SetTargetResponse xmlns:u="urn:schemas-upnp-org:service:SwitchPower:1"><JobID>54</JobID></u:SetTargetResponse>
2012-08-15 16:24:37.593 00:23:46.4985893 (004) I0 Broadcasted notification: ["EAVeraLuup:17", "0"] for device [Fireplace]
« Last Edit: August 15, 2012, 04:34:00 pm by oTi@ »

Offline cw-kid

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1612
  • Karma: +18/-2
Re: New VeraLite, do I still need my Aeon Labs Z-Stick 2 ? mControl & Vera
« Reply #18 on: August 15, 2012, 11:59:57 am »
Clutching at straws now, but one difference I can see between a dimmer module and an appliance module is the appliance module has no capabilities listed, is this relevant?

I've tried removing an appliance module from Vera and re-adding, I've also ran the Z-WAVE repair thing in Vera still no go with appliance modules and the mControl Vera Luup Driver.

EDIT: I ran a repair again on just this appliance module and now it has things listed next to capabilities, but still doesn't work with mControl.
« Last Edit: August 15, 2012, 12:11:53 pm by cw-kid »

Offline cw-kid

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1612
  • Karma: +18/-2
Re: New VeraLite, do I still need my Aeon Labs Z-Stick 2 ? mControl & Vera
« Reply #19 on: August 15, 2012, 12:44:57 pm »
Plan B instead of using the mControl Vera Luup Driver is to add the Aeon Labs Z-stick as a secondary controller to VeraLite primary. The Z-stick would stay in the back of the WHS PC and mControl would use that to send direct z-wave commands to devices instead of going via Vera using the Luup Driver.

Just tried this using the tools in HomeSeer - I followed this post which tells you how to do it:

http://board.homeseer.com/showthread.php?p=1021471

It has added a _SceneController in to Vera but is status is Red and I dont think its worked properly, See screen shot.

I have searched these forums but cannot find any clear how to's to add the Z-stick as a secondary does anyone know  how to do this ???



Offline cw-kid

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1612
  • Karma: +18/-2
Re: New VeraLite, do I still need my Aeon Labs Z-Stick 2 ? mControl & Vera
« Reply #20 on: August 15, 2012, 02:25:14 pm »
Plan B might just work! Even though the Z-stick was not properly added to VeraLite as a secondary I connected it back up to the WHS PC anyway's, looking in the mControl Z-wave adapter util I could see that z-wave devices had been added back on to the Z-stick (I wiped it clean prior to trying to add to VeraLite) So the homeseer transfer must have done something, I then set back some devices in mControl from using the Vera Luup Driver to being proper Z-wave devices again instead and I was able to turn on and off  the appliance modules via mControl as normal. I also had no issues with the status feedback not being displayed properly.

However for some reason in the mControl Z-wave adapter util it said that node ID1 the VeraLite was a secondary, it also said node 11 the Z-stick was a secondary, also the z-stick was no longer polling the z-wave modules correctly and was failing which is bad. If there is a correct way to setup the Z-stick as a secondary to VeraLite primary? then this might be the best option rather than using the mControl Vera Luup driver and ditching the Z-stick completely.

Or Plan C how bad would it be? To have the Z-stick as primary and VeraLite as secondary any thoughts ?

Thanks
« Last Edit: August 15, 2012, 02:27:15 pm by cw-kid »

Offline cw-kid

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1612
  • Karma: +18/-2
Re: New VeraLite, do I still need my Aeon Labs Z-Stick 2 ? mControl & Vera
« Reply #21 on: August 15, 2012, 03:41:55 pm »
Just talking to my friend Martin he got me to run these two lines in Chrome browser:

OFF:

http://192.168.0.11:49451/data_request?id=lu_action&output_format=xml&DeviceNum=17&serviceId=urn:upnp-org:serviceId:SwitchPower1&action=SetTarget&newTargetValue=0

ON:

http://192.168.0.11:49451/data_request?id=lu_action&output_format=xml&DeviceNum=17&serviceId=urn:upnp-org:serviceId:SwitchPower1&action=SetTarget&newTargetValue=1

They both work and the appliance module is turned on / off OK. So if mControl has produced these URLs? that work in the browser, why don't they work when I click on or off on this appliance device in mControl UI, its really strange.

« Last Edit: August 15, 2012, 03:45:20 pm by cw-kid »

Offline oTi@

  • Community Beta
  • Master Member
  • ******
  • Posts: 4041
  • Karma: +32/-6
  • UI what ?!
Re: New VeraLite, do I still need my Aeon Labs Z-Stick 2 ? mControl & Vera
« Reply #22 on: August 15, 2012, 03:58:25 pm »
IIUC, there was an On command, that was followed by an Off command just 1.5 seconds later?

2012-08-15 16:24:36.078   00:23:44.9899531   (013)   I0   Automation command [13, "17", "On", 0, "EAVeraLuup", 1]
2012-08-15 16:24:36.093   00:23:44.9990968   (030)   D0   EAVeraLuup: message sent (W) through [http://192.168.0.11:49451/]: data_request?id=lu_action&output_format=xml&DeviceNum=17&serviceId=urn:upnp-org:serviceId:SwitchPower1&action=SetTarget&newTargetValue=1|<cr>

2012-08-15 16:24:37.578   00:23:46.4896613   (013)   I0   Automation command [13, "17", "Off", 1, "EAVeraLuup", 1]
2012-08-15 16:24:37.593   00:23:46.4983015   (004)   D0   EAVeraLuup: message sent (W) through [http://192.168.0.11:49451/]: data_request?id=lu_action&output_format=xml&DeviceNum=17&serviceId=urn:upnp-org:serviceId:SwitchPower1&action=SetTarget&newTargetValue=0|<cr>
Dezwaved at the moment...

Offline cw-kid

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1612
  • Karma: +18/-2
Re: New VeraLite, do I still need my Aeon Labs Z-Stick 2 ? mControl & Vera
« Reply #23 on: August 15, 2012, 04:02:40 pm »
IIUC, there was an On command, that was followed by an Off command just 1.5 seconds later?

2012-08-15 16:24:36.078   00:23:44.9899531   (013)   I0   Automation command [13, "17", "On", 0, "EAVeraLuup", 1]
2012-08-15 16:24:36.093   00:23:44.9990968   (030)   D0   EAVeraLuup: message sent (W) through [http://192.168.0.11:49451/]: data_request?id=lu_action&output_format=xml&DeviceNum=17&serviceId=urn:upnp-org:serviceId:SwitchPower1&action=SetTarget&newTargetValue=1|<cr>

2012-08-15 16:24:37.578   00:23:46.4896613   (013)   I0   Automation command [13, "17", "Off", 1, "EAVeraLuup", 1]
2012-08-15 16:24:37.593   00:23:46.4983015   (004)   D0   EAVeraLuup: message sent (W) through [http://192.168.0.11:49451/]: data_request?id=lu_action&output_format=xml&DeviceNum=17&serviceId=urn:upnp-org:serviceId:SwitchPower1&action=SetTarget&newTargetValue=0|<cr>

That was probably me clicking the buttons in the mControl UI

Offline cw-kid

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1612
  • Karma: +18/-2
Re: New VeraLite, do I still need my Aeon Labs Z-Stick 2 ? mControl & Vera
« Reply #24 on: August 15, 2012, 04:05:47 pm »
I can't understand if mControl is generating the correct URLs as Martin has just shown me that they work in the browser then why when I click the on or off button in the mControl UI for this appliance module it doesn't switch? Just doesnt make any sense, I tried turning the firewall off on the PC where mControl is installed made no difference, Martin commented on the port number however

"The port number is odd - I would have expected 3480"

The one being used by mControl to talk to Vera is 49451

EDIT: Changing the port number in the mControl Vera Luup driver setup to 3480 makes no difference to the appliance module not working.
The dimmers still work on/off however with this new port number.
« Last Edit: August 15, 2012, 04:10:06 pm by cw-kid »

Offline oTi@

  • Community Beta
  • Master Member
  • ******
  • Posts: 4041
  • Karma: +32/-6
  • UI what ?!
Re: New VeraLite, do I still need my Aeon Labs Z-Stick 2 ? mControl & Vera
« Reply #25 on: August 15, 2012, 04:15:02 pm »
That was probably me clicking the buttons in the mControl UI
Sure, but 1.5 seconds is a bit quick. I'm assuming you have tried with just clicking On and then giving it, say, 30 seconds?
Dezwaved at the moment...

Offline cw-kid

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1612
  • Karma: +18/-2
Re: New VeraLite, do I still need my Aeon Labs Z-Stick 2 ? mControl & Vera
« Reply #26 on: August 15, 2012, 04:23:45 pm »
I am not 100% the URLs are correct that are created by mControl?

Martin suggested the ones shown in the log files above where slightly different due to the formatting of the log file however:

Working URL in browser:

http://192.168.0.11:3480/data_request?id=lu_action&output_format=xml&DeviceNum=17&serviceId=urn:upnp-org:serviceId:SwitchPower1&action=SetTarget&newTargetValue=1

URL from log file:

http://192.168.0.11:3480/]: data_request?id=lu_action&output_format=xml&DeviceNum=17&serviceId=urn:upnp-org:serviceId:SwitchPower1&action=SetTarget&newTargetValue=1?

There are two difference there is a ]: before data_request and a ? at the end.

Now if I run

http://192.168.0.11:3480/data_request?id=lu_action&output_format=xml&DeviceNum=17&serviceId=urn:upnp-org:serviceId:SwitchPower1&action=SetTarget&newTargetValue=1?

With the ? at the end, the appliance does not turn ON ! Delete the ? and it does turn on.

Strangely if I turn the appliance on with a correct URL in the browser, I can then go in to the mControl UI and click the Off button and the off button is working and does turn off the appliance. Why the off button is working in mControl I don't know? But it appears the problem could be with the On button in the mControl UI and possibly the URL that is produced ?





« Last Edit: August 15, 2012, 04:30:44 pm by cw-kid »

Offline cw-kid

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1612
  • Karma: +18/-2
Re: New VeraLite, do I still need my Aeon Labs Z-Stick 2 ? mControl & Vera
« Reply #27 on: August 15, 2012, 04:27:50 pm »
I just cleared the log file and pressed on button for the appliance module waited maybe 5 secs and then clicked the off button.

There answer is in here somewhere LOL:

2012-08-15 21:26:25.156   00:17:56.9339854   (005)   I0   Automation command [15, "17", "On", 0, "EAVeraLuup", 1]
2012-08-15 21:26:25.156   00:17:56.9397194   (006)   D0   EAVeraLuup: message sent (W) through [http://192.168.0.11:3480/]: data_request?id=lu_action&output_format=xml&DeviceNum=17&serviceId=urn:upnp-org:serviceId:SwitchPower1&action=SetTarget&newTargetValue=1?<cr>
2012-08-15 21:26:25.156   00:17:56.9400161   (017)   D0   EAVeraLuup: received message from device through [http://192.168.0.11:3480/]: <?xml version="1.0"?><u:SetTargetResponse xmlns:u="urn:schemas-upnp-org:service:SwitchPower:1"><JobID>360</JobID></u:SetTargetResponse>
2012-08-15 21:26:31.453   00:18:03.2341146   (017)   D0   EAVeraLuup: message sent (W) through [http://192.168.0.11:3480/]: data_request?id=lu_status2&output_format=xml&DataVersion=54550933&LoadTime=1345054549?<cr>
2012-08-15 21:26:31.531   00:18:03.3223884   (006)   X0   Error opening port COM1
2012-08-15 21:26:31.531   00:18:03.3223884   (006)   X1   System.UnauthorizedAccessException: Access to the port 'COM1' is denied.
2012-08-15 21:26:31.531   00:18:03.3223884   (006)   X2      at System.IO.Ports.InternalResources.WinIOError(Int32 errorCode, String str)
2012-08-15 21:26:31.531   00:18:03.3223884   (006)   X3      at System.IO.Ports.SerialStream..ctor(String portName, Int32 baudRate, Parity parity, Int32 dataBits, StopBits stopBits, Int32 readTimeout, Int32 writeTimeout, Handshake handshake, Boolean dtrEnable, Boolean rtsEnable, Boolean discardNull, Byte parityReplace)
2012-08-15 21:26:31.531   00:18:03.3223884   (006)   X4      at System.IO.Ports.SerialPort.Open()
2012-08-15 21:26:31.531   00:18:03.3223884   (006)   X5      at EmbeddedAutomation.mServer.CommLib.BufferedSerialPort.Open()
2012-08-15 21:26:31.531   00:18:03.3224080   (006)   D0   EALiteTouch: using port [COM1]
2012-08-15 21:26:31.531   00:18:03.3224141   (006)   D0   EALiteTouch can not open port [COM1]
2012-08-15 21:26:31.656   00:18:03.4346658   (030)   D0   EAVeraLuup: received message from device through [http://192.168.0.11:3480/]: <?xml version="1.0"?><root LoadTime="1345054549" DataVersion="54550947" UserData_DataVersion="54549003" TimeStamp="1345062395" ZWaveStatus="1" LocalTime="2012-08-15 21:26:35 N"><startup><tasks></tasks></startup><devices><device id="3" status="-1"><tooltip display="0"></tooltip></device><device id="17" status="4"><Jobs><Job id="359" name="job#359 :OFF node 7 (0x828790) N:7 P:35 S:4" icon="OFF" comments="Transmit was ok" status="4"></Job><Job id="360" name="job#360 :OFF node 7 (0x7f37d0) N:7 P:35 S:4" icon="OFF" comments="Transmit was ok" status="4"></Job></Jobs><tooltip display="1" tag2="Transmit was ok"></tooltip></device><device id="18" status="2"><tooltip display="1" tag2="Unable to get any information on node"></tooltip></device></devices></root>
2012-08-15 21:26:31.734   00:18:03.5172487   (018)   X0   Error opening port COM1
2012-08-15 21:26:31.734   00:18:03.5172487   (018)   X1   System.UnauthorizedAccessException: Access to the port 'COM1' is denied.
2012-08-15 21:26:31.734   00:18:03.5172487   (018)   X2      at System.IO.Ports.InternalResources.WinIOError(Int32 errorCode, String str)
2012-08-15 21:26:31.734   00:18:03.5172487   (018)   X3      at System.IO.Ports.SerialStream..ctor(String portName, Int32 baudRate, Parity parity, Int32 dataBits, StopBits stopBits, Int32 readTimeout, Int32 writeTimeout, Handshake handshake, Boolean dtrEnable, Boolean rtsEnable, Boolean discardNull, Byte parityReplace)
2012-08-15 21:26:31.734   00:18:03.5172487   (018)   X4      at System.IO.Ports.SerialPort.Open()
2012-08-15 21:26:31.734   00:18:03.5172487   (018)   X5      at EmbeddedAutomation.mServer.CommLib.BufferedSerialPort.Open()
2012-08-15 21:26:31.734   00:18:03.5172710   (018)   D0   EASomfyRs485RtsTransmitter: using port [COM1]
2012-08-15 21:26:31.734   00:18:03.5172777   (018)   D0   EASomfyRs485RtsTransmitter can not open port [COM1]
2012-08-15 21:26:31.921   00:18:03.7010553   (006)   X0   Error opening port COM1
2012-08-15 21:26:31.921   00:18:03.7010553   (006)   X1   System.UnauthorizedAccessException: Access to the port 'COM1' is denied.
2012-08-15 21:26:31.921   00:18:03.7010553   (006)   X2      at System.IO.Ports.InternalResources.WinIOError(Int32 errorCode, String str)
2012-08-15 21:26:31.921   00:18:03.7010553   (006)   X3      at System.IO.Ports.SerialStream..ctor(String portName, Int32 baudRate, Parity parity, Int32 dataBits, StopBits stopBits, Int32 readTimeout, Int32 writeTimeout, Handshake handshake, Boolean dtrEnable, Boolean rtsEnable, Boolean discardNull, Byte parityReplace)
2012-08-15 21:26:31.921   00:18:03.7010553   (006)   X4      at System.IO.Ports.SerialPort.Open()
2012-08-15 21:26:31.921   00:18:03.7010553   (006)   X5      at EmbeddedAutomation.mServer.CommLib.BufferedSerialPort.Open()
2012-08-15 21:26:31.921   00:18:03.7010748   (006)   D0   EANuVo: using port [COM1]
2012-08-15 21:26:31.921   00:18:03.7010815   (006)   D0   EANuVo can not open port [COM1]
2012-08-15 21:26:32.765   00:18:04.5575465   (017)   X0   Error opening port COM1
2012-08-15 21:26:32.765   00:18:04.5575465   (017)   X1   System.UnauthorizedAccessException: Access to the port 'COM1' is denied.
2012-08-15 21:26:32.765   00:18:04.5575465   (017)   X2      at System.IO.Ports.InternalResources.WinIOError(Int32 errorCode, String str)
2012-08-15 21:26:32.765   00:18:04.5575465   (017)   X3      at System.IO.Ports.SerialStream..ctor(String portName, Int32 baudRate, Parity parity, Int32 dataBits, StopBits stopBits, Int32 readTimeout, Int32 writeTimeout, Handshake handshake, Boolean dtrEnable, Boolean rtsEnable, Boolean discardNull, Byte parityReplace)
2012-08-15 21:26:32.765   00:18:04.5575465   (017)   X4      at System.IO.Ports.SerialPort.Open()
2012-08-15 21:26:32.765   00:18:04.5575465   (017)   X5      at EmbeddedAutomation.mServer.CommLib.BufferedSerialPort.Open()
2012-08-15 21:26:32.765   00:18:04.5575658   (017)   D0   JetStream: using port [COM1]
2012-08-15 21:26:32.765   00:18:04.5575719   (017)   D0   JetStream can not open port [COM1]
2012-08-15 21:26:33.296   00:18:05.0849663   (018)   X0   Error opening port COM1
2012-08-15 21:26:33.296   00:18:05.0849663   (018)   X1   System.UnauthorizedAccessException: Access to the port 'COM1' is denied.
2012-08-15 21:26:33.296   00:18:05.0849663   (018)   X2      at System.IO.Ports.InternalResources.WinIOError(Int32 errorCode, String str)
2012-08-15 21:26:33.296   00:18:05.0849663   (018)   X3      at System.IO.Ports.SerialStream..ctor(String portName, Int32 baudRate, Parity parity, Int32 dataBits, StopBits stopBits, Int32 readTimeout, Int32 writeTimeout, Handshake handshake, Boolean dtrEnable, Boolean rtsEnable, Boolean discardNull, Byte parityReplace)
2012-08-15 21:26:33.296   00:18:05.0849663   (018)   X4      at System.IO.Ports.SerialPort.Open()
2012-08-15 21:26:33.296   00:18:05.0849663   (018)   X5      at EmbeddedAutomation.mServer.CommLib.BufferedSerialPort.Open()
2012-08-15 21:26:33.296   00:18:05.0849859   (018)   D0   RadioRA: using port [COM1]
2012-08-15 21:26:33.296   00:18:05.0849923   (018)   D0   RadioRA can not open port [COM1]
2012-08-15 21:26:33.562   00:18:05.3524772   (005)   I0   Automation command [15, "17", "Off", 0, "EAVeraLuup", 1]
2012-08-15 21:26:33.578   00:18:05.3592029   (018)   D0   EAVeraLuup: message sent (W) through [http://192.168.0.11:3480/]: data_request?id=lu_action&output_format=xml&DeviceNum=17&serviceId=urn:upnp-org:serviceId:SwitchPower1&action=SetTarget&newTargetValue=0?<cr>
2012-08-15 21:26:33.578   00:18:05.3596275   (030)   D0   EAVeraLuup: received message from device through [http://192.168.0.11:3480/]: <?xml version="1.0"?><u:SetTargetResponse xmlns:u="urn:schemas-upnp-org:service:SwitchPower:1"><JobID>361</JobID></u:SetTargetResponse>
« Last Edit: August 15, 2012, 04:42:57 pm by cw-kid »

Offline oTi@

  • Community Beta
  • Master Member
  • ******
  • Posts: 4041
  • Karma: +32/-6
  • UI what ?!
Re: New VeraLite, do I still need my Aeon Labs Z-Stick 2 ? mControl & Vera
« Reply #28 on: August 15, 2012, 04:37:01 pm »
Can you do it again, but wait 30 seconds (or don't turn it off at all)?
Dezwaved at the moment...

Offline cw-kid

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1612
  • Karma: +18/-2
Re: New VeraLite, do I still need my Aeon Labs Z-Stick 2 ? mControl & Vera
« Reply #29 on: August 15, 2012, 04:45:38 pm »
OK I cleared log file then clicked On button then counted to 30 there is allot of other stuff in the log file not to do with the Vera Luup Driver:

Code: [Select]
2012-08-15 21:43:54.718 00:35:26.5716092 (019) X0 EACarrierInfinityHvac: Exception in socket operation.
2012-08-15 21:43:54.718 00:35:26.5716092 (019) X1 System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 10.100.100.55:49152
2012-08-15 21:43:54.718 00:35:26.5716092 (019) X2    at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
2012-08-15 21:43:54.718 00:35:26.5716092 (019) X3    at System.Net.Sockets.Socket.Connect(EndPoint remoteEP)
2012-08-15 21:43:54.718 00:35:26.5716092 (019) X4    at System.Net.Sockets.TcpClient.Connect(IPEndPoint remoteEP)
2012-08-15 21:43:54.718 00:35:26.5716092 (019) X5    at EmbeddedAutomation.mServer.CommLib.ClientSocket.Connect()
2012-08-15 21:43:54.718 00:35:26.5716092 (019) X6    at EmbeddedAutomation.mServer.CommLib.TcpIpSocket.Open()
2012-08-15 21:43:54.718 00:35:26.5716271 (019) D0 EACarrierInfinityHvac: using port [10.100.100.55:49152]
2012-08-15 21:43:54.718 00:35:26.5716313 (019) D0 EACarrierInfinityHvac can not open port [10.100.100.55:49152]
2012-08-15 21:43:55.421 00:35:27.2756221 (017) X0 EAWmcControllerAdapter - EAWmcController: Exception in socket operation.
2012-08-15 21:43:55.421 00:35:27.2756221 (017) X1 System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 192.168.0.5:40500
2012-08-15 21:43:55.421 00:35:27.2756221 (017) X2    at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
2012-08-15 21:43:55.421 00:35:27.2756221 (017) X3    at System.Net.Sockets.Socket.Connect(EndPoint remoteEP)
2012-08-15 21:43:55.421 00:35:27.2756221 (017) X4    at System.Net.Sockets.TcpClient.Connect(IPEndPoint remoteEP)
2012-08-15 21:43:55.421 00:35:27.2756221 (017) X5    at EmbeddedAutomation.mServer.CommLib.ClientSocket.Connect()
2012-08-15 21:43:55.421 00:35:27.2756221 (017) X6    at EmbeddedAutomation.mServer.CommLib.TcpIpSocket.Open()
2012-08-15 21:43:55.421 00:35:27.2756381 (017) D0 EAWmcControllerAdapter - EAWmcController: using port [192.168.0.5:40500]
2012-08-15 21:43:55.421 00:35:27.2756425 (017) D0 EAWmcControllerAdapter - EAWmcController can not open port [192.168.0.5:40500]
2012-08-15 21:43:57.203 00:35:29.0479443 (020) I0 Automation command [13, "17", "On", 0, "EAVeraLuup", 1]
2012-08-15 21:43:57.203 00:35:29.0536640 (003) D0 EAVeraLuup: message sent (W) through [[b]http://192.168.0.11:3480/]: data_request?id=lu_action&output_format=xml&DeviceNum=17&serviceId=urn:upnp-org:serviceId:SwitchPower1&action=SetTarget&newTargetValue=1?[/b]<cr>
2012-08-15 21:43:57.203 00:35:29.0540658 (019) D0 EAVeraLuup: received message from device through [http://192.168.0.11:3480/]: <?xml version="1.0"?><u:SetTargetResponse xmlns:u="urn:schemas-upnp-org:service:SwitchPower:1"><JobID>405</JobID></u:SetTargetResponse>
2012-08-15 21:44:01.453 00:35:33.3006602 (019) D0 EAVeraLuup: message sent (W) through [http://192.168.0.11:3480/]: data_request?id=lu_status2&output_format=xml&DataVersion=54551118&LoadTime=1345054549?<cr>
2012-08-15 21:44:01.453 00:35:33.3010407 (003) D0 EAVeraLuup: received message from device through [http://192.168.0.11:3480/]: <?xml version="1.0"?><root LoadTime="1345054549" DataVersion="54551125" UserData_DataVersion="54549005" TimeStamp="1345063445" ZWaveStatus="1" LocalTime="2012-08-15 21:44:05 N"><startup><tasks></tasks></startup><devices><device id="3" status="-1"><tooltip display="0"></tooltip></device><device id="17" status="4"><Jobs><Job id="405" name="job#405 :OFF node 7 (0x828790) N:7 P:35 S:4" icon="OFF" comments="Transmit was ok" status="4"></Job></Jobs><tooltip display="1" tag2="Transmit was ok"></tooltip></device><device id="18" status="2"><tooltip display="1" tag2="Unable to get any information on node"></tooltip></device></devices></root>
2012-08-15 21:44:31.531 00:36:03.3857643 (003) X0 Error opening port COM1
2012-08-15 21:44:31.531 00:36:03.3857643 (003) X1 System.UnauthorizedAccessException: Access to the port 'COM1' is denied.
2012-08-15 21:44:31.531 00:36:03.3857643 (003) X2    at System.IO.Ports.InternalResources.WinIOError(Int32 errorCode, String str)
2012-08-15 21:44:31.531 00:36:03.3857643 (003) X3    at System.IO.Ports.SerialStream..ctor(String portName, Int32 baudRate, Parity parity, Int32 dataBits, StopBits stopBits, Int32 readTimeout, Int32 writeTimeout, Handshake handshake, Boolean dtrEnable, Boolean rtsEnable, Boolean discardNull, Byte parityReplace)
2012-08-15 21:44:31.531 00:36:03.3857643 (003) X4    at System.IO.Ports.SerialPort.Open()
2012-08-15 21:44:31.531 00:36:03.3857643 (003) X5    at EmbeddedAutomation.mServer.CommLib.BufferedSerialPort.Open()
2012-08-15 21:44:31.531 00:36:03.3857906 (003) D0 EALiteTouch: using port [COM1]
2012-08-15 21:44:31.531 00:36:03.3857973 (003) D0 EALiteTouch can not open port [COM1]
2012-08-15 21:44:31.546 00:36:03.3961145 (003) D0 EAVeraLuup: message sent (W) through [http://192.168.0.11:3480/]: data_request?id=lu_status2&output_format=xml&DataVersion=54551125&LoadTime=1345054549?<cr>
2012-08-15 21:44:31.828 00:36:03.6748447 (019) X0 Error opening port COM1
2012-08-15 21:44:31.828 00:36:03.6748447 (019) X1 System.UnauthorizedAccessException: Access to the port 'COM1' is denied.
2012-08-15 21:44:31.828 00:36:03.6748447 (019) X2    at System.IO.Ports.InternalResources.WinIOError(Int32 errorCode, String str)
2012-08-15 21:44:31.828 00:36:03.6748447 (019) X3    at System.IO.Ports.SerialStream..ctor(String portName, Int32 baudRate, Parity parity, Int32 dataBits, StopBits stopBits, Int32 readTimeout, Int32 writeTimeout, Handshake handshake, Boolean dtrEnable, Boolean rtsEnable, Boolean discardNull, Byte parityReplace)
2012-08-15 21:44:31.828 00:36:03.6748447 (019) X4    at System.IO.Ports.SerialPort.Open()
2012-08-15 21:44:31.828 00:36:03.6748447 (019) X5    at EmbeddedAutomation.mServer.CommLib.BufferedSerialPort.Open()
2012-08-15 21:44:31.828 00:36:03.6748651 (019) D0 EASomfyRs485RtsTransmitter: using port [COM1]
2012-08-15 21:44:31.828 00:36:03.6748723 (019) D0 EASomfyRs485RtsTransmitter can not open port [COM1]
2012-08-15 21:44:31.828 00:36:03.6752310 (019) D0 EAVeraLuup: received message from device through [http://192.168.0.11:3480/]: <?xml version="1.0"?><root LoadTime="1345054549" DataVersion="54551127" UserData_DataVersion="54549005" TimeStamp="1345063475" ZWaveStatus="1" LocalTime="2012-08-15 21:44:35 N"><startup><tasks></tasks></startup><devices><device id="3" status="-1"><tooltip display="0"></tooltip></device><device id="17" status="-1"><Jobs></Jobs><tooltip display="0"></tooltip></device><device id="18" status="2"><tooltip display="1" tag2="Unable to get any information on node"></tooltip></device></devices></root>
2012-08-15 21:44:32.093 00:36:03.9392369 (005) X0 Error opening port COM1
2012-08-15 21:44:32.093 00:36:03.9392369 (005) X1 System.UnauthorizedAccessException: Access to the port 'COM1' is denied.
2012-08-15 21:44:32.093 00:36:03.9392369 (005) X2    at System.IO.Ports.InternalResources.WinIOError(Int32 errorCode, String str)
2012-08-15 21:44:32.093 00:36:03.9392369 (005) X3    at System.IO.Ports.SerialStream..ctor(String portName, Int32 baudRate, Parity parity, Int32 dataBits, StopBits stopBits, Int32 readTimeout, Int32 writeTimeout, Handshake handshake, Boolean dtrEnable, Boolean rtsEnable, Boolean discardNull, Byte parityReplace)
2012-08-15 21:44:32.093 00:36:03.9392369 (005) X4    at System.IO.Ports.SerialPort.Open()
2012-08-15 21:44:32.093 00:36:03.9392369 (005) X5    at EmbeddedAutomation.mServer.CommLib.BufferedSerialPort.Open()
2012-08-15 21:44:32.093 00:36:03.9392573 (005) D0 EANuVo: using port [COM1]
2012-08-15 21:44:32.093 00:36:03.9392646 (005) D0 EANuVo can not open port [COM1]
2012-08-15 21:44:32.812 00:36:04.6629473 (003) X0 Error opening port COM1
2012-08-15 21:44:32.812 00:36:04.6629473 (003) X1 System.UnauthorizedAccessException: Access to the port 'COM1' is denied.
2012-08-15 21:44:32.812 00:36:04.6629473 (003) X2    at System.IO.Ports.InternalResources.WinIOError(Int32 errorCode, String str)
2012-08-15 21:44:32.812 00:36:04.6629473 (003) X3    at System.IO.Ports.SerialStream..ctor(String portName, Int32 baudRate, Parity parity, Int32 dataBits, StopBits stopBits, Int32 readTimeout, Int32 writeTimeout, Handshake handshake, Boolean dtrEnable, Boolean rtsEnable, Boolean discardNull, Byte parityReplace)
2012-08-15 21:44:32.812 00:36:04.6629473 (003) X4    at System.IO.Ports.SerialPort.Open()
2012-08-15 21:44:32.812 00:36:04.6629473 (003) X5    at EmbeddedAutomation.mServer.CommLib.BufferedSerialPort.Open()
2012-08-15 21:44:32.812 00:36:04.6629675 (003) D0 JetStream: using port [COM1]
2012-08-15 21:44:32.812 00:36:04.6629814 (003) D0 JetStream can not open port [COM1]
2012-08-15 21:44:33.234 00:36:05.0896865 (005) X0 Error opening port COM1
2012-08-15 21:44:33.234 00:36:05.0896865 (005) X1 System.UnauthorizedAccessException: Access to the port 'COM1' is denied.
2012-08-15 21:44:33.234 00:36:05.0896865 (005) X2    at System.IO.Ports.InternalResources.WinIOError(Int32 errorCode, String str)
2012-08-15 21:44:33.234 00:36:05.0896865 (005) X3    at System.IO.Ports.SerialStream..ctor(String portName, Int32 baudRate, Parity parity, Int32 dataBits, StopBits stopBits, Int32 readTimeout, Int32 writeTimeout, Handshake handshake, Boolean dtrEnable, Boolean rtsEnable, Boolean discardNull, Byte parityReplace)
2012-08-15 21:44:33.234 00:36:05.0896865 (005) X4    at System.IO.Ports.SerialPort.Open()
2012-08-15 21:44:33.234 00:36:05.0896865 (005) X5    at EmbeddedAutomation.mServer.CommLib.BufferedSerialPort.Open()
2012-08-15 21:44:33.234 00:36:05.0897063 (005) D0 RadioRA: using port [COM1]
2012-08-15 21:44:33.234 00:36:05.0897133 (005) D0 RadioRA can not open port [COM1]
2012-08-15 21:44:37.375 00:36:09.2234225 (017) X0 EAWmcControllerAdapter - EAWmcController: Exception in socket operation.
2012-08-15 21:44:37.375 00:36:09.2234225 (017) X1 System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 192.168.0.5:40400
2012-08-15 21:44:37.375 00:36:09.2234225 (017) X2    at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
2012-08-15 21:44:37.375 00:36:09.2234225 (017) X3    at System.Net.Sockets.Socket.Connect(EndPoint remoteEP)
2012-08-15 21:44:37.375 00:36:09.2234225 (017) X4    at System.Net.Sockets.TcpClient.Connect(IPEndPoint remoteEP)
2012-08-15 21:44:37.375 00:36:09.2234225 (017) X5    at EmbeddedAutomation.mServer.CommLib.ClientSocket.Connect()
2012-08-15 21:44:37.375 00:36:09.2234225 (017) X6    at EmbeddedAutomation.mServer.CommLib.TcpIpSocket.Open()
2012-08-15 21:44:37.375 00:36:09.2234811 (017) D0 EAWmcControllerAdapter - EAWmcController: using port [192.168.0.5:40400]
2012-08-15 21:44:37.375 00:36:09.2234881 (017) D0 EAWmcControllerAdapter - EAWmcController can not open port [192.168.0.5:40400]

I still dont know who wrote the mControl Vera Luup Driver ? mControl or Vera people ? Still waiting to hear from mControl support but nothing from them yet.
« Last Edit: August 16, 2012, 07:45:39 am by oTi@ »