Author Topic: Getting Started - best place for info  (Read 274 times)

Offline nathanwinters

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
Getting Started - best place for info
« on: December 19, 2018, 04:28:54 pm »
Hi,
I've just come back to my Vera and smart home stuff after a while of having it all disconnected.
I've factory reset my Vera and reloaded with latest firmware.
I've also just updated the RFXtrx433E to the latest Pro1 firmware.
I've found that Tinman is updating the RFX firmware and have uploaded the latest 1.61 files to the Vera.

I'm just wondering whether there is a guide to what to do next? I know there are old ones, but keen to make sure I'm following the latest guidance.

If there isn't one, then I'm happy to write one if people can help point me in the correct direction.

Cheers
Nathan

Offline nathanwinters

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
Re: Getting Started - best place for info
« Reply #1 on: December 19, 2018, 04:38:11 pm »
Just for reference, this is what I was trying to follow:
https://www.vesternet.com/resources/application-notes/apnt-116

But I'm not getting the device to create properly.

Once I go and manually create the device, it shows up in Devices, but with no name.

Offline tinman

  • Full Member
  • ***
  • Posts: 212
  • Karma: +13/-0
Re: Getting Started - best place for info
« Reply #2 on: December 19, 2018, 05:45:58 pm »
If you have the RFXtrx communicating with Vera you're halfway finished. It's important to know what devices you'd like to have communicating with the transceiver and then refer to the RFXtrx User Guide which you can download from the RFXcom web site on the downloads page. Look for your devices in the user guide and enable the indicated receiver protocols for your devices that transmit (mostly sensors but other devices as well). For device that only receive, they have to be added manually using the New Device tab of the RFXtrx device in Vera. You give the device a name when you create it manually - along with some ID parameters. The user guide includes information about how to discover device ID information.

Also, for transmitting devices to be added automatically you need to enable Automatic creation in the RFXtrx Managed Devices tab. Once you have all the transmitting devices appear you'll want to turn this option off. You may see devices appear that are not really valid. If so you can later delete them.
« Last Edit: December 19, 2018, 05:50:46 pm by tinman »

Offline nathanwinters

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
Re: Getting Started - best place for info
« Reply #3 on: December 20, 2018, 04:07:59 am »
Hi,
Thanks for the reply.
I'm not sure I fully have the RFX communicating properly.
What's the best way to test that? A while back it worked and loaded devices with a name, but since the reset, although there is a device that i create manually, it doesn't have a name and doesn't seem to fully stay connected.
Thanks
Nathan

Offline tinman

  • Full Member
  • ***
  • Posts: 212
  • Karma: +13/-0
Re: Getting Started - best place for info
« Reply #4 on: December 20, 2018, 09:52:15 am »
If the RFXtrx is showing up in the list of devices in Vera, select it and then click on the Protocol Settings tab. If that page is filled out with the Firmware Type, Firmware Version and you can enable or disable protocols then I believe it is communicating.
If you have any sensors that send messages to the RFXtrx, you'll see the Last Received Message being updated.
If you go to the Vera Apps tab - then Develop Apps - Serial port configuration, you should see a serial port configured and assigned to you RFXtrx.

Offline nathanwinters

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
Re: Getting Started - best place for info
« Reply #5 on: December 21, 2018, 04:35:51 pm »
Thanks for your help, in the end I removed everything again, and re-did the setup with reboots in the middle. That seems to have worked and the device is now setup and I'm able to configure the protocols.

Next step to get it to actually talk to one of the plugs as a controlled device. :)