Author Topic: Harmony Hub installation fails  (Read 175 times)

Offline RHCPNG

  • Full Member
  • ***
  • Posts: 191
  • Karma: +6/-0
Harmony Hub installation fails
« on: December 24, 2018, 05:43:30 am »
Hi Rene,

I'm still struggling with the plugin. I've uninstalled the plugin and removed all plugin files manually from openluup. Then I reinstalled the plugin, but now I don't get the settings tab at the device page. I also tried to create the harmony device manually, but this had the same result.

I don't know if this is a plugin issue or openluup, but maybe you can help me debug this issue.

See my log files attached:
One for the installation of the plugin and one for creating the harmony device manually

The only thing that stands out for me is the error:
openLuup.chdev:: [string "L_Harmony.lua"]:122: module 'bit' not found:

I hope you can get me one step further.

Offline martynwendon

  • Full Member
  • ***
  • Posts: 116
  • Karma: +15/-1
Re: Harmony Hub installation fails
« Reply #1 on: December 24, 2018, 06:04:55 am »
openLuup will need the LUA "bit" library installing.

If you're on a Linux install then something like this should do it:

Code: [Select]
apt-get install lua-bitop

Offline RHCPNG

  • Full Member
  • ***
  • Posts: 191
  • Karma: +6/-0
Re: Harmony Hub installation fails
« Reply #2 on: December 24, 2018, 07:05:06 am »
openLuup will need the LUA "bit" library installing.

If you're on a Linux install then something like this should do it:

Code: [Select]
apt-get install lua-bitop

Thanks, martynwendon. This resolves the error.

But the issue of the settings tab is still there. I don't see any errors anymore. It seems to install fine, but still no settings tab!

Offline RHCPNG

  • Full Member
  • ***
  • Posts: 191
  • Karma: +6/-0
Re: Harmony Hub installation fails
« Reply #3 on: January 01, 2019, 10:07:10 am »
Ok, my issue of the tab is also resolved after I updated AltUI to version 2.38b.2488.