We have moved at community.getvera.com

Author Topic: Z-Wave.Me 4 Button Key Fob / Vera compatible ? RESOLVED  (Read 63631 times)

Offline cw-kid

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1612
  • Karma: +18/-2
Re: Z-Wave.Me 4 Button Key Fob / Vera compatible ?
« Reply #30 on: September 18, 2012, 06:02:48 pm »
Ideally what I want to be able to do with the key fob is be able to arm / disarm an Everspring HSM02 Door contact sensor, so I can get in and out of my garage.

And also to be able to run a scene or two, I had the idea of having a "Leaving House" scene I can just push a button on the key fob when leaving and all the lights are turned off etc.


Offline cw-kid

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1612
  • Karma: +18/-2
Re: Z-Wave.Me 4 Button Key Fob / Vera compatible ?
« Reply #31 on: September 18, 2012, 06:14:23 pm »
I've not tried the work around yet, but tried proximity, if I press button 1 near a device nothing happens it doesn't turn it on.

The battery level is now showing in Vera at 44%, battery gets hammered whilst trying to set it up! Also all the capabilities are now showing: 83,156,0,4,18,2,R,B,RS,|45,112,114,117,119,128,132:2,133,134,142, and its set to poll every 60 secs, this poll field was blank initially as were the capabilities.

This is how the Scenes tab currently looks like:
« Last Edit: September 18, 2012, 06:20:43 pm by cw-kid »

Offline cw-kid

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1612
  • Karma: +18/-2
Re: Z-Wave.Me 4 Button Key Fob / Vera compatible ?
« Reply #32 on: September 18, 2012, 06:40:08 pm »
OK so trying to follow the work around to get the scenes working.

I have set Variable 11 to 1 byte Dec with a value of 4
I have created an association group 1
I added the ZWAVE device
I edited the Leaving House scene and added a new trigger - "A scene is activated" - Scene Number 11

I am now stuck on this part:

5. Wake up the FOB

I woke the fob, by pressing the four buttons and then button 3.

It then says: Failed at: Setting special association

Is that the correct way to wake the fob? For Vera to send the configuration to it.

EDIT: Just tried deleting the Association Group 1 in the hope of it adding back in correctly, but when saving / waking the fob after removing the Group 1 it still says: Failed at: Setting special association
« Last Edit: September 18, 2012, 07:06:27 pm by cw-kid »

Offline cw-kid

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1612
  • Karma: +18/-2
Re: Z-Wave.Me 4 Button Key Fob / Vera compatible ?
« Reply #33 on: September 19, 2012, 02:44:36 am »
Reply from the Distributor:

"Dont bother the status comments on VERA. VERA tries t osend the commands but the device is sleeping. it says then "failed" but in fact its waiting for the wakeup of the device (button 2 in management mode)"

If I go in to management mode by holding the four buttons and then press button 2 nothing happened in Vera and it still says waiting for wakeup to configure device.

I then pressed the four buttons and number 2 several times and it did then start to update in Vera however at the end it still says:

Failed at: Setting special association



Offline cw-kid

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1612
  • Karma: +18/-2
Re: Z-Wave.Me 4 Button Key Fob / Vera compatible ?
« Reply #34 on: September 19, 2012, 02:53:23 am »
The device currently selected in the Association Group is called _SceneController see screen shot, this should be set to ZWAVE.

I am not sure what _SceneController actually is? As I have renamed the Key Fob and the Mini Mote so I now shouldn't have any devices called _SceneController.

In fact you can see my only two scene controllers at the top of the screen shot, MiniMote Remote Control and Key Fob.
« Last Edit: September 19, 2012, 03:03:26 am by cw-kid »

Offline cw-kid

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1612
  • Karma: +18/-2
Re: Z-Wave.Me 4 Button Key Fob / Vera compatible ?
« Reply #35 on: September 19, 2012, 03:46:54 am »
I deleted the key fob from vera and re-added the device again and then setup the configuration and association group etc. I now see two _SceneController devices under unassigned devices, see screen shot:

I am still getting the Failed at: Setting special association message.

When I press button 1 its meant to run the scene to turn the lights off, but nothing happens.
Proximity is also not working. Think I will have to send this fob back as its just not working and I think I am doing it correctly?

Thanks
« Last Edit: September 19, 2012, 03:50:44 am by cw-kid »

Offline intveltr

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1741
  • Karma: +102/-5
Re: Z-Wave.Me 4 Button Key Fob / Vera compatible ?
« Reply #36 on: September 19, 2012, 05:34:04 am »
It's probably working correctly. You need to associate the keyfob on group 1 with device #2 called _scene controller. For now, remove the trigger on your scene. Then try and configure the keyfob, it should go through. When it does, go back to your scene and add a trigger for scene activation #11.

By the way, this stuff is why z-wave isn't ready for prime time yet :)
HomeWave is available in the App Store!  Turn your iPhone/iPad into an easy-to-use remote control for Vera.

Offline cw-kid

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1612
  • Karma: +18/-2
Re: Z-Wave.Me 4 Button Key Fob / Vera compatible ?
« Reply #37 on: September 19, 2012, 06:40:02 am »
It's probably working correctly. You need to associate the keyfob on group 1 with device #2 called _scene controller. For now, remove the trigger on your scene. Then try and configure the keyfob, it should go through. When it does, go back to your scene and add a trigger for scene activation #11.

By the way, this stuff is why z-wave isn't ready for prime time yet :)

This works and does not error when I wake up the fob. If you look at the screen shot I have two _SceneController entries now since deleting and re-adding the fob to Vera. I selected the top one. I also removed the trigger from the scene. I then held the four buttons and pressed number 2. The Fob in Vera seemed to send the config and it did not error.

So now do I add the trigger back in?

And you need to select _SceneController and not ZWAVE in the Association group ? As per the instructions.

Thanks

EDIT: More from the distributor:

"if you can include the device into very its is very unlikely that there is something wrong with the device. The problem is certainly the setup of VERA. The "Failed at: Setting special association" is an annoying error message because this is actually no error but a designed function. For battery  powered devices communication will always fail until the device wakes up. You can see if the fob is sending something. It you receive a triple blink, there is no association group valid, if its a single blink, the packet went out."

When I just pressed the four buttons and then button 2 I got a single red light on the fob not three.
« Last Edit: September 19, 2012, 06:43:44 am by cw-kid »

Offline cw-kid

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1612
  • Karma: +18/-2
Re: Z-Wave.Me 4 Button Key Fob / Vera compatible ?
« Reply #38 on: September 19, 2012, 06:45:54 am »
When adding the trigger back on the scene I can now see two _SceneControllers as options to select. #2 and #28 I will pick #2.

EDIT: Having just said the above, if I look at the _SceneController in the device tab in Vera it has a Device # of 28, maybe I need to use #28 in the trigger, getting more confusing now as I have two entries.

« Last Edit: September 19, 2012, 06:49:49 am by cw-kid »

Offline intveltr

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1741
  • Karma: +102/-5
Re: Z-Wave.Me 4 Button Key Fob / Vera compatible ?
« Reply #39 on: September 19, 2012, 06:59:22 am »
Your scene needs to trigger on the keyfob (#28 I suppose), "a scene is activated", scene nr 11. I recommend renaming it in the GUI
HomeWave is available in the App Store!  Turn your iPhone/iPad into an easy-to-use remote control for Vera.

Offline cw-kid

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1612
  • Karma: +18/-2
Re: Z-Wave.Me 4 Button Key Fob / Vera compatible ?
« Reply #40 on: September 19, 2012, 07:01:37 am »
Think its WORKING NOW ! Kinda...

If I press button 1 the lamps in my lounge are turning off !!

So the key is not selecting ZWAVE as Christian stated

"activate the association group dialog for group 1 and assign ZWAVE device (thats VERA itself) into this group [THIS
IS THE WORKAROUND STEP]"

And to select _SceneController instead in the Groups Association.

The key fob in Vera still says "waiting for wakeup to configure device" and if you wake the fob I get that error Failed at: Setting special association that Christian says " is an annoying error message because this is actually no error "

So does this sound like how your own key fob is functioning ??

Many thanks!

Offline cw-kid

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1612
  • Karma: +18/-2
Re: Z-Wave.Me 4 Button Key Fob / Vera compatible ?
« Reply #41 on: September 19, 2012, 07:06:40 am »
Now can I only program the other buttons to run other scenes ?

Or can I program the other buttons to directly control on / off other devices ? i.e. to Arm / Disarm this door sensor I want to setup.

Offline intveltr

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1741
  • Karma: +102/-5
Re: Z-Wave.Me 4 Button Key Fob / Vera compatible ?
« Reply #42 on: September 19, 2012, 07:08:49 am »
Yes, mine also says waiting for wake up, and (sometimes) gives this error.

Glad that you got it working :) I ran down the keyfob's battery as well as my patience getting this far. But now that it's working, it's great!


You can program other buttons to control scenes or control other buttons.  Check the manual, each button has a setting to control what it does
HomeWave is available in the App Store!  Turn your iPhone/iPad into an easy-to-use remote control for Vera.

Offline cw-kid

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1612
  • Karma: +18/-2
Re: Z-Wave.Me 4 Button Key Fob / Vera compatible ?
« Reply #43 on: September 19, 2012, 07:18:50 am »
So can you please confirm you have _SceneController selected in the Association group and not the ZWAVE device ?

I am no Z-wave expert but I usually know the basics to get by, but this key fob has been a nightmare to setup !

Thanks

Offline cw-kid

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1612
  • Karma: +18/-2
Re: Z-Wave.Me 4 Button Key Fob / Vera compatible ?
« Reply #44 on: September 19, 2012, 07:24:11 am »
I'd like to program button 3 to Arm the door sensor. I can see two possible ways.

1. Create a new scene that arms the sensor and run the scene on button 3 (This I can probably do as its the same as how I got button 1 working)

2. Somehow configure button 3 to directly send an arm command to the sensor device. (This I don't know how to do?)