We have moved at community.getvera.com

Author Topic: ALTUI icon  (Read 240 times)

Offline rafale77

  • Community Beta
  • Hero Member
  • ******
  • Posts: 1749
  • Karma: +101/-27
  • HA ≠ IoT as a blue sky is cloudless.
ALTUI icon
« on: January 13, 2019, 11:10:03 am »
amg0,

I just installed 2501 on both my vera and openLuup. I am loving the power meter update. Thank you.
The ALTUI icon though is not working. It is referring back to a github CDN site and somehow failing for me. I have had to make it local and read from my vera and ALTUI instance. Not sure if anyone else is seeing this?
openLuup (79 devices, 141 scenes, 19 apps) master to VeraPlus (142 zwave nodes, 8 Zigbee nodes, 221 devices,  20 scenes , 2 apps) +  Hubitat (15 Zigbee nodes) + Home-Assistant (API Integrations). Bridged to Siri and Alexa. Homewave. VeraPlus ExtRooted and mios server independent.

Offline amg0

  • Moderator
  • Master Member
  • *****
  • Posts: 3174
  • Karma: +209/-8
Re: ALTUI icon
« Reply #1 on: January 13, 2019, 12:08:30 pm »
amg0,

I just installed 2501 on both my vera and openLuup. I am loving the power meter update. Thank you.
The ALTUI icon though is not working. It is referring back to a github CDN site and somehow failing for me. I have had to make it local and read from my vera and ALTUI instance. Not sure if anyone else is seeing this?

https://raw.githubusercontent.com/amg0/ALTUI/c3393a3e/iconALTUI.png works for me, even after clearing the cache. can you confirm ?

I could use another relay maybe this one ?
https://rawcdn.githack.com/amg0/ALTUI/cedacf871988ce724fb2896f0f2fd4cb7aece217/iconALTUI.png
« Last Edit: January 13, 2019, 12:14:40 pm by amg0 »

Offline rafale77

  • Community Beta
  • Hero Member
  • ******
  • Posts: 1749
  • Karma: +101/-27
  • HA ≠ IoT as a blue sky is cloudless.
Re: ALTUI icon
« Reply #2 on: January 13, 2019, 04:16:44 pm »
The link itself works from outside but somehow neither openLuup nor the vera are getting to it. I am outside right now and will check when I get back. It may indeed be a browser cache issue but I tried on both Chrome and Safari and they were returning no icon.
openLuup (79 devices, 141 scenes, 19 apps) master to VeraPlus (142 zwave nodes, 8 Zigbee nodes, 221 devices,  20 scenes , 2 apps) +  Hubitat (15 Zigbee nodes) + Home-Assistant (API Integrations). Bridged to Siri and Alexa. Homewave. VeraPlus ExtRooted and mios server independent.

Offline rafale77

  • Community Beta
  • Hero Member
  • ******
  • Posts: 1749
  • Karma: +101/-27
  • HA ≠ IoT as a blue sky is cloudless.
Re: ALTUI icon
« Reply #3 on: January 14, 2019, 11:03:54 am »
I just tested both cdn icons and they both work from the direct link but not when used in by the D_ALTUI_UI7.json file. I am not quite sure as to why. In any case, I have modified the file to now pull the file locally so it is not an issue. If others don't have a problem, then you can probably ignore my ask. I also have a slight preference for locally hosted icon anyway.
openLuup (79 devices, 141 scenes, 19 apps) master to VeraPlus (142 zwave nodes, 8 Zigbee nodes, 221 devices,  20 scenes , 2 apps) +  Hubitat (15 Zigbee nodes) + Home-Assistant (API Integrations). Bridged to Siri and Alexa. Homewave. VeraPlus ExtRooted and mios server independent.

Offline amg0

  • Moderator
  • Master Member
  • *****
  • Posts: 3174
  • Karma: +209/-8
Re: ALTUI icon
« Reply #4 on: January 14, 2019, 09:03:59 pm »
I just tested both cdn icons and they both work from the direct link but not when used in by the D_ALTUI_UI7.json file. I am not quite sure as to why. In any case, I have modified the file to now pull the file locally so it is not an issue. If others don't have a problem, then you can probably ignore my ask. I also have a slight preference for locally hosted icon anyway.
Just in case, Are you sure you are not mixing https and http between the icon references and the way you open the AltUI page ?

Offline rafale77

  • Community Beta
  • Hero Member
  • ******
  • Posts: 1749
  • Karma: +101/-27
  • HA ≠ IoT as a blue sky is cloudless.
Re: ALTUI icon
« Reply #5 on: January 14, 2019, 10:25:39 pm »
It is all https from what I can tell. On a lot of my plugins I host my icons too and don't seem to have this problem without ssl.
openLuup (79 devices, 141 scenes, 19 apps) master to VeraPlus (142 zwave nodes, 8 Zigbee nodes, 221 devices,  20 scenes , 2 apps) +  Hubitat (15 Zigbee nodes) + Home-Assistant (API Integrations). Bridged to Siri and Alexa. Homewave. VeraPlus ExtRooted and mios server independent.