Author Topic: Need help associating FGS-213 S2 with Fibaro Plug  (Read 237 times)

Offline Loeschnix

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Need help associating FGS-213 S2 with Fibaro Plug
« on: January 26, 2019, 12:03:27 pm »
Hi guys,
I am failing to associate the S2 input of a Fibaro Single switch FGS-213 with a Fibaro wall plug.

In the device options, I added
Group ID: 4
Set to: 24 (also tried 24.2)

Parameter Settings:
20. Switch type: 0
35. S2 switch - associations sent to 4th and 5th association groups: 0

There is no reaction on a S2 press. Does anyone know what I am doing wrong?

Thanks Dirk

Offline Loeschnix

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Re: Need help associating FGS-213 S2 with Fibaro Plug
« Reply #1 on: January 26, 2019, 05:12:09 pm »
Hi,
in case the association FGS-213 S2 -> Plug is not possible, is there any other option to make use of this input?
There are 2 additional Appliance Modules added, but these do nothing.
In Open Z-Wave this input was added as a normal switch entity, and was accessible in my automations.

Thanks Dirk

Offline Angel

  • Support
  • Newbie
  • *****
  • Posts: 4
  • Karma: +0/-0
Re: Need help associating FGS-213 S2 with Fibaro Plug
« Reply #2 on: January 27, 2019, 12:16:55 am »
Hello,

We have created a support ticket so we can take a look at your FGS-213 device. Please have a look at your email inbox.

Offline shallowearth

  • Hero Member
  • *****
  • Posts: 993
  • Karma: +47/-9
Re: Need help associating FGS-213 S2 with Fibaro Plug
« Reply #3 on: January 27, 2019, 12:22:11 am »
Check your  wiring of the switch to terminal 2.
Remove and re-add your device to clear any bad associations.  On the FGs-213 add group 4 and set to the plug using the check box.

Verify it is not an interference problem by bringing the plug in closer to the switch.

If it is still not working you might have an older plug that is not z-wave plus.  If that is the case you need to change the setting of parameters 27.  Changing 27 to value 11 will turnoff secure messages to the plug and might fix the problem. 

Offline Loeschnix

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Re: Need help associating FGS-213 S2 with Fibaro Plug
« Reply #4 on: January 29, 2019, 06:56:47 am »
Hi,
Check your  wiring of the switch to terminal 2.
Remove and re-add your device to clear any bad associations.  On the FGs-213 add group 4 and set to the plug using the check box.

Verify it is not an interference problem by bringing the plug in closer to the switch.

If it is still not working you might have an older plug that is not z-wave plus.  If that is the case you need to change the setting of parameters 27.  Changing 27 to value 11 will turnoff secure messages to the plug and might fix the problem. 


thanks for your response.
The Plug is a Fibaro Gen5 Plug [FGWPF-102-5].
Until Saturday last week, my z-wave network was controlled by Domoticz. The topology did not change, and it was working robust.
So, it?s unlikely to be a wiring issue, or defective part.
There is occasionally an error message posted on the FGS-213 saying "Can't detect device", even though it's located quite close to Vera (~3m). The plug is another ~2m away from the switch. Both can be operated from the WebInterface without drop- outs.
I excluded and re-included both devices already, nothing helps.
I?m about to give up, and exchange the FGS-213 with a Fibaro Dimmer 2, that seems to work robust in regards to association- groups.

Thanks Dirk

Offline shallowearth

  • Hero Member
  • *****
  • Posts: 993
  • Karma: +47/-9
Re: Need help associating FGS-213 S2 with Fibaro Plug
« Reply #5 on: January 29, 2019, 03:37:32 pm »
I would still try changing parameter 27 to 11.  There is no way to tell in Vera if the plug was added as a secure device or not.  If creating the association succeeded and yet does nothing this is one of the likely culprits.  (Some of the devices that do associations always send unsecure to support basic devices, some you have to change to get working).  This is particularly suspiscous because if it was a interference problem you would likely at least get periodic success.

Changing to an unsecure message risks nothing and is ultimately a simpler protocol message to send to the plug and may fix your problem.

Also since you are getting frequent device detection errors on the Vera, that sounds like there is a weak radio signal to the FGS-213 or a lot of interference.
Again, I would put the plug on an extension cord and bring it right to the FGS-213, and see if that fixes the problem.  Direct Association communications do not go through the Vera, the Switch is going to send the message directly from the Switch to the Plug.  So even if the Plug feels close if your radio wire is jammed in the box in an awkward way or otherwise having interference the signal may just not be making it to the plug on its own.  The Vera is going to have the strongest radio of the 3 three so it not unusually that the commands from the Vera to the Switch or to the Plug work, but commands from the Switch to the Plug are un-reliable.

I usually use a scene as a backup in these cases to help re-enforce the signal (slight delay but helps if the connection is unreliable between the switch and plug), but I am not sure that the FGS-213 supports instance status so that is probably not helpful for your case.

I have been un-impressed with range of several of these behind the switch micro-controllers particularly if you have metal j-box, brick, plaster or other dense wall material.  Does Domoticz use a z-wave dongle for the radio?  was probably a stronger radio than what is in the Vera.