Author Topic: trane xr524 current temperature wrong  (Read 198 times)

Offline jon102034050

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
trane xr524 current temperature wrong
« on: February 04, 2019, 10:27:30 am »
hey all, i recently paired 2 different Trane XR524 thermostats with my Vera Plus and i'm having the same issue with both of them: the current temperature that is shown in the Vera ui is different than the temperature shown on the thermostat. It almost seems like its a conversion issue or something.... For example, if the temp is shown as 71 on the t-stat, it'll be 69.8 in the UI, if it's 67 on the t-stat, it'll show 64.4.

Thoughts? I've got a case open with support, but they haven't solved it yet.

Online rafale77

  • Community Beta
  • Hero Member
  • ******
  • Posts: 1690
  • Karma: +93/-27
  • HA ≠ IoT as a blue sky is cloudless.
Re: trane xr524 current temperature wrong
« Reply #1 on: February 06, 2019, 03:08:43 am »
I don't have this thermostat but just guessing here that the vera is actually reporting a setpoint (cool setpoint?) on the device rather than the current temperature value?
openLuup (78 devices, 141 scenes, 19 apps) master to VeraPlus (142 zwave nodes, 8 Zigbee nodes, 221 devices,  20 scenes , 2 apps) +  Hubitat (15 Zigbee nodes) + Home-Assistant (API Integrations). Bridged to Siri and Alexa. Homewave. VeraPlus ExtRooted and mios server independent.

Offline jon102034050

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Re: trane xr524 current temperature wrong
« Reply #2 on: February 06, 2019, 06:08:03 pm »
I don't have this thermostat but just guessing here that the vera is actually reporting a setpoint (cool setpoint?) on the device rather than the current temperature value?

do you know how I would confirm this? whats strange is that in my troubleshooting i've see it report the correct temperature momentarily, then switch to the (wrong) lower value.
Vera support thinks that the t-stat is rounding the value shown on the t-stat vs what is actually sent OR that there is some zwave parameter specific to this device that calibrates the zwave values sent. Personally, I don't buy either of those theories though...

Online rafale77

  • Community Beta
  • Hero Member
  • ******
  • Posts: 1690
  • Karma: +93/-27
  • HA ≠ IoT as a blue sky is cloudless.
Re: trane xr524 current temperature wrong
« Reply #3 on: February 06, 2019, 11:23:19 pm »
I would suggest to compare the display on the UI and your setpoint on the thermostat. This number has to come from somewhere and most likely is the Thermostat itself. It may just be the wrong variable.
openLuup (78 devices, 141 scenes, 19 apps) master to VeraPlus (142 zwave nodes, 8 Zigbee nodes, 221 devices,  20 scenes , 2 apps) +  Hubitat (15 Zigbee nodes) + Home-Assistant (API Integrations). Bridged to Siri and Alexa. Homewave. VeraPlus ExtRooted and mios server independent.

Offline jon102034050

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Re: trane xr524 current temperature wrong
« Reply #4 on: February 07, 2019, 02:28:50 pm »
Dont think its the setpoint, i've see the 'current temp' as far as 6 degrees off of the heating setpoint when the t-stat showed the setpoint and current temps as being exactly the same. Doesn't seem like a resolution is in sight for this, support hasn't been very helpful :(