Author Topic: Vera Plus interfering with DHCP  (Read 441 times)

Offline z-wav

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
Vera Plus interfering with DHCP
« on: February 09, 2019, 10:51:41 pm »
Have two Vera Plus units on two different networks.  Both networks have professional level routers.

Both Vera Plus units have their DHCP Server Turned Off

However, on one of networks, Vera Plus is sending out network signal that Vera Plus is the network's Router, which it is not.
Setting a computer to use DHCP with manual address on that network ends up with Vera Plus's IP address as Router IP Address.

Have not been able to find any networking differences between two Vera Plus.

Any ideas as to why Vera Plus on one network is advertising itself as network's router?
 


Offline ivx

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-2
Re: Vera Plus interfering with DHCP
« Reply #1 on: February 10, 2019, 01:25:28 am »
Hi,

I had similar troubles, Configured Vera Plus static IP, DHCP disabled. Randomily other DCHP enabled devices start going offline.
Same result happnened when i enabled wifi on Vera.

Currently i get over it by doing Net & Wi-fi->Reset to default network settings and configure it to static IP and wifi disabled.
(Do not touch other settings or you need to reset agian)

May be you got same problem, then it should work ...

Offline z-wav

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
Re: Vera Plus interfering with DHCP
« Reply #2 on: February 11, 2019, 05:35:17 pm »
Thanks, but it did not help.

I have tried another computer system that is Wired Ethernet (instead of WiFi attached), and when it is set to DHCP with manual IP; it also gets Vera Plus's IP address as LAN's router.

Tried moving Vera Plus's Wired Ethernet connection to where is connects directly to LAN's router, instead of going through a switch first.  Didn't help.

Powering off Vera Plus, then setting computer system to use DHCP with manual IP did set computer system to IP OF LAN's router.  However, after powering Vera Plus backup and changing computer system's IP to different (unused) IP; once again computer system got Vera Plus's IP address as LAN's router.

Definitely a problem with Vera Plus taking over LAN and proclaiming itself to be LAN's router.

Offline Catman

  • Sr. Member
  • ****
  • Posts: 253
  • Karma: +8/-0
Re: Vera Plus interfering with DHCP
« Reply #3 on: February 12, 2019, 02:27:27 am »
Are you able to ssh into the Vera?  It's not really that the plus is 'taking over the LAN' it (appears) to be responding to DHCP requests when your other devices are renewing their lease.

If you can use the command line:
ps aux | grep -i dhcp

Should let us know if the internal DHCP server is running (I'm guessing a bit that it's called dhcpd but got to start somewhere)

C

Offline HSD99

  • Sr. Member
  • ****
  • Posts: 340
  • Karma: +17/-0
Re: Vera Plus interfering with DHCP
« Reply #4 on: February 12, 2019, 12:45:54 pm »
Are you able to ssh into the Vera?  It's not really that the plus is 'taking over the LAN' it (appears) to be responding to DHCP requests when your other devices are renewing their lease.

If you can use the command line:
ps aux | grep -i dhcp

Should let us know if the internal DHCP server is running (I'm guessing a bit that it's called dhcpd but got to start somewhere)

C

A data point: on my VP, with the DHCP server turned off, the only thing running is the DHCP client. This is as it should be. I would suggest using Catman's command, ps aux | grep -i dhcp, as it will match to both the DHCP server and client.

Offline Catman

  • Sr. Member
  • ****
  • Posts: 253
  • Karma: +8/-0
Re: Vera Plus interfering with DHCP
« Reply #5 on: February 12, 2019, 05:24:51 pm »
Are you able to ssh into the Vera?  It's not really that the plus is 'taking over the LAN' it (appears) to be responding to DHCP requests when your other devices are renewing their lease.

If you can use the command line:
ps aux | grep -i dhcp

Should let us know if the internal DHCP server is running (I'm guessing a bit that it's called dhcpd but got to start somewhere)

C

A data point: on my VP, with the DHCP server turned off, the only thing running is the DHCP client. This is as it should be. I would suggest using Catman's command, ps aux | grep -i dhcp, as it will match to both the DHCP server and client.

Thanks for that. I don't have DHCP on my VP at all, so I get no return.

root@MiOS_50103066:~# ps aux | grep -i dhcp
root      3385  0.0  0.0   1788   112 pts/0    S+   22:23   0:00 grep -i dhcp

Well apart from the command itself ;)


C

Offline z-wav

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
Re: Vera Plus interfering with DHCP
« Reply #6 on: February 13, 2019, 11:19:06 am »
From what I understand, Vera Plus is using dnsmasq.  It does DNS, DHCP, & TFTP.

running - /usr/sbin/dnsmasq -C /var/etc/dnsmasq.conf -k
(-k, --keep-in-foreground)


file - /var/etc/dnsmasq.conf
------------------------------------------------------------------
# auto-generated config file from /etc/config/dhcp
conf-file=/etc/dnsmasq.conf
domain-needed
localise-queries
read-ethers
bogus-priv
expand-hosts
domain=lan
server=/lan/
dhcp-leasefile=/tmp/dhcp.leases
resolv-file=/tmp/resolv.conf.auto
addn-hosts=/tmp/hosts
conf-dir=/tmp/dnsmasq.d
stop-dns-rebind
rebind-localhost-ok
dhcp-broadcast=tag:needs-broadcast

dhcp-range=wan,192.168.2.100,static,255.255.255.0,12h
dhcp-option=wan,option:dns-server
------------------------------------------------------------------
(should "dhcp-broadcast=tag:needs-broadcast" be set?)

file /etc/config/dhcp (used to generate above)
(Whether above file is generated correctly, unknown)
------------------------------------------------------------------
config dnsmasq
   option domainneeded '1'
   option boguspriv '1'
   option filterwin2k '0'
   option localise_queries '1'
   option rebind_protection '1'
   option rebind_localhost '1'
   option local '/lan/'
   option domain 'lan'
   option expandhosts '1'
   option nonegcache '0'
   option authoritative '0'
   option readethers '1'
   option leasefile '/tmp/dhcp.leases'
   option resolvfile '/tmp/resolv.conf.auto'

config dhcp 'lan'
   option interface 'lan'
   option start '100'
   option limit '150'
   option ignore '0'
   option dynamicdhcp '0'
   option force '1'
   list dhcp_option 'option:dns-server'
   option leasetime '60m'

config dhcp 'wan'
   option interface 'wan'
   option ignore '0'
   option dynamicdhcp '0'
   option force '1'
   list dhcp_option 'option:dns-server'
------------------------------------------------------------------
« Last Edit: February 13, 2019, 11:25:59 am by z-wav »

Offline Catman

  • Sr. Member
  • ****
  • Posts: 253
  • Karma: +8/-0
Re: Vera Plus interfering with DHCP
« Reply #7 on: February 13, 2019, 12:46:39 pm »
Looks very different from mine:

# auto-generated config file from /etc/config/dhcp
conf-file=/etc/dnsmasq.conf
domain-needed
localise-queries
read-ethers
bogus-priv
expand-hosts
domain=lan
server=/lan/
dhcp-leasefile=/tmp/dhcp.leases
resolv-file=/tmp/resolv.conf.auto
addn-hosts=/tmp/hosts
conf-dir=/tmp/dnsmasq.d
stop-dns-rebind
rebind-localhost-ok
dhcp-broadcast=tag:needs-broadcast




dhcp-range=wan,192.168.70.100,static,255.255.255.0,12h
dhcp-option=wan,option:dns-server


I shall see if I can do some more digging.

C

Offline Catman

  • Sr. Member
  • ****
  • Posts: 253
  • Karma: +8/-0
Re: Vera Plus interfering with DHCP
« Reply #8 on: February 14, 2019, 11:08:41 am »
If you google Open WRT DHCP you might well find some more detail

This could be a good way to start

etc/init.d/odhcpd disable

I'm not sure what else I can do to help since my system is working (i.e. no DHCP serving taking place that I know of) and I can't see what you have in your config.

C

Offline z-wav

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
Re: Vera Plus interfering with DHCP
« Reply #9 on: February 14, 2019, 08:01:04 pm »
Thanks.  I will take a look.