We have moved at community.getvera.com

Author Topic: VeraBridge unable to connect to controller  (Read 169 times)

Offline Wingkeel

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
VeraBridge unable to connect to controller
« on: February 16, 2019, 11:23:29 pm »
Hi,

Prefacing this message with the fact that I am very new to all of this.

I have recently installed openLuup and AltUI on a Raspberry Pi 3 Model B+. The first part of the installation was ok and AltUI loads up fine via the web browser, however after inputting my Vera's IP into the VeraBridge attributes page, and reloading the Luup engine, I get the message "controller did not respond".

I am able to access the Vera through the dedicated web browser page, so I know that I am able to communicate with the Vera.

Also worth mentioning is the modem/router (Telstra cable CM-450) will not allow the reservation of IP addresses, so I have (rightly or wrongly) manually set a static IP from within the "net & Wi-fi" section of Vera.

If anyone has any advise on what I should try, or where I may have gone wrong it would be greatly appreciated.

I haven't provided any screen shots or log files in this initial post as I thought I would wait to see what is required to diagnose the problem.

Thank you

Offline akbooer

  • Moderator
  • Master Member
  • *****
  • Posts: 6387
  • Karma: +292/-70
  • "Less is more"
Re: VeraBridge unable to connect to controller
« Reply #1 on: February 19, 2019, 05:15:30 pm »
The "controller did not respond" is a local AltUI message which happens, momentarily, if you refresh the browser page, or reload Luup.  This is not your problem, I suspect.

How do you know it's not actually working?

It would be good to get a copy of the startup log (from openLuup's Console) pages, and also the main log for about a minute or so immediately after a reload.  What does the VeraBridge display on its panel on the Devices pages?

« Last Edit: February 20, 2019, 01:26:19 pm by akbooer »
3x Vera Lite-UI5/Edge-UI7, 25x Fibaro, 23x TKB, 9x MiniMote, 2x NorthQ Power, 2x Netatmo, 1x Foscam FI9831P, 9x Philips Hue,
Razberry, MySensors Arduino, HomeWave, AltUI, AltHue, DataYours, Grafana, openLuup, ZWay, ZeroBrane Studio.

Offline Wingkeel

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: VeraBridge unable to connect to controller
« Reply #2 on: February 21, 2019, 05:14:27 am »
I've managed to get it working. It was an issue with the IP assignment on the Vera end.

Thank you for your offer to help @akbooer, much appreciated.