We have moved at community.getvera.com

Author Topic: [Solved]: Do not update your Hamony Hub to version 4.15.250  (Read 1040 times)

Offline chasiu

  • Jr. Member
  • **
  • Posts: 67
  • Karma: +0/-0
Re: Do not update your Hamony Hub to version 4.15.250
« Reply #15 on: February 21, 2019, 10:47:05 am »
Hi,

The RemoteID is a variable on the plugin. If this is set you can install the V3.6 plugin lua and you will be back in business.

No other quick solution right now.

Cheers Rene

Thank you Rene.  I just got back in town and updated your app.  Works again!  ;D

Offline ronluna

  • Jr. Member
  • **
  • Posts: 96
  • Karma: +1/-3
Re: [Solved]: Do not update your Hamony Hub to version 4.15.250
« Reply #16 on: February 21, 2019, 02:04:24 pm »
Anyone getting this error running version 4.15.250 ?

Code: [Select]
Harmony Control_error: Failed to get new configuration from Hub. Error : 500, Error waiting for response..

Code: [Select]
2019-02-21 13:41:10.974   openLuup.context_switch::  ERROR: [string "[951] I_Harmony.xml"]:1326: attempt to index local 'resp' (a number value)stack traceback:
./openLuup/scheduler.lua:128: in function <./openLuup/scheduler.lua:125>
(tail call): ?
./openLuup/scheduler.lua:1015: in function <./openLuup/scheduler.lua:996>
[C]: in function 'pcall'
./openLuup/scheduler.lua:996: in function 'luup_callbacks'
./openLuup/scheduler.lua:1085: in function 'start'
openLuup/init.lua:323: in main chunk
[C]: ?
2019-02-21 13:41:10.974   luup.delay_callback:: function: 0x2918410 ERROR: [string "[951] I_Harmony.xml"]:1326: attempt to index local 'resp' (a number value)



Offline ronluna

  • Jr. Member
  • **
  • Posts: 96
  • Karma: +1/-3
Re: [Solved]: Do not update your Hamony Hub to version 4.15.250
« Reply #17 on: February 21, 2019, 03:10:32 pm »
Anyone getting this error running on the harmony firmware version 4.15.250 and plugin 3.6?
While the lua engine is starting
Code: [Select]
Harmony Control_error: Failed to get new configuration from Hub. Error : 500, Error waiting for response..

When a request is sent to the plugin:
Code: [Select]
2019-02-21 13:41:10.974   openLuup.context_switch::  ERROR: [string "[951] I_Harmony.xml"]:1326: attempt to index local 'resp' (a number value)stack traceback:
./openLuup/scheduler.lua:128: in function <./openLuup/scheduler.lua:125>
(tail call): ?
./openLuup/scheduler.lua:1015: in function <./openLuup/scheduler.lua:996>
[C]: in function 'pcall'
./openLuup/scheduler.lua:996: in function 'luup_callbacks'
./openLuup/scheduler.lua:1085: in function 'start'
openLuup/init.lua:323: in main chunk
[C]: ?
2019-02-21 13:41:10.974   luup.delay_callback:: function: 0x2918410 ERROR: [string "[951] I_Harmony.xml"]:1326: attempt to index local 'resp' (a number value)

When clicking on the "Devices" Tab:
Code: [Select]
Error in Harmony.Devices(): SyntaxError: Unexpected end of JSON input
« Last Edit: February 21, 2019, 03:19:03 pm by ronluna »

Offline ronluna

  • Jr. Member
  • **
  • Posts: 96
  • Karma: +1/-3
Re: [Solved]: Do not update your Hamony Hub to version 4.15.250
« Reply #18 on: February 21, 2019, 03:26:34 pm »
I've set the log level to 11 "ERROR" and seems like it connects to the hub correctly and is able to retrieve the devices one time but then it fails

Code: [Select]
2019-02-21 15:22:43.158   luup_log:50: Harmony Control_debug: Harmony_CreateChildren start
2019-02-21 15:22:43.158   luup_log:50: Harmony Control_debug: Child devices to create : 44252645,43749129,44252729,43750631,43409592,44252615,43751754.
2019-02-21 15:22:43.159   luup_log:50: Harmony Control_debug: Child device id HAM50_44252645 (HRM: Apple TV Gen 4 Bedroom), number 44252645
2019-02-21 15:22:43.159   luup.chdev.append:: [HAM50_44252645] HRM: Apple TV Gen 4 Bedroom
2019-02-21 15:22:43.159   luup_log:50: Harmony Control_debug: Child device id HAM50_43749129 (HRM: Onkyo AV Receiver LivingRoom), number 43749129
2019-02-21 15:22:43.159   luup.chdev.append:: [HAM50_43749129] HRM: Onkyo AV Receiver LivingRoom
2019-02-21 15:22:43.159   luup_log:50: Harmony Control_debug: Child device id HAM50_44252729 (HRM: Marantz AV Receiver Bedroom), number 44252729
2019-02-21 15:22:43.159   luup.chdev.append:: [HAM50_44252729] HRM: Marantz AV Receiver Bedroom
2019-02-21 15:22:43.160   luup_log:50: Harmony Control_debug: Child device id HAM50_43750631 (HRM: Epson Projector LivingRoom), number 43750631
2019-02-21 15:22:43.160   luup.chdev.append:: [HAM50_43750631] HRM: Epson Projector LivingRoom
2019-02-21 15:22:43.160   luup_log:50: Harmony Control_debug: Child device id HAM50_43409592 (HRM: XBR-55X850D LivingRoom), number 43409592
2019-02-21 15:22:43.160   luup.chdev.append:: [HAM50_43409592] HRM: XBR-55X850D LivingRoom
2019-02-21 15:22:43.160   luup_log:50: Harmony Control_debug: Child device id HAM50_44252615 (HRM: XBR-43X800D Bedroom), number 44252615
2019-02-21 15:22:43.160   luup.chdev.append:: [HAM50_44252615] HRM: XBR-43X800D Bedroom
2019-02-21 15:22:43.160   luup_log:50: Harmony Control_debug: Child device id HAM50_43751754 (HRM: Apple TV Gen 4 LivingRoom), number 43751754
2019-02-21 15:22:43.160   luup.chdev.append:: [HAM50_43751754] HRM: Apple TV Gen 4 LivingRoom
2019-02-21 15:22:43.160   luup_log:50: Harmony Control_info: No lamp devices to create.
2019-02-21 15:22:43.161   luup.chdev.sync:: [50] Harmony Hub 2, syncing children
2019-02-21 15:22:43.161   luup.variable_set:50: 50.urn:rboer-com:serviceId:Harmony1.IconSet was: 3 now: 2 #hooks:0
2019-02-21 15:22:43.161   luup_log:50: Harmony Control_debug: Retrieve the config from Hub.
2019-02-21 15:22:43.161   luup_log:50: Harmony Control_debug: ws_client.receive error true, 1000, timeout
2019-02-21 15:22:43.162   luup_log:50: Harmony Control_error: Failed to get new configuration from Hub. Error : 500, Error waiting for response..
2019-02-21 15:22:43.162   luup_log:50: Harmony Control_debug: Retrieve the automation config from Hub.
2019-02-21 15:22:43.162   luup_log:50: Harmony Control_debug: ws_client.receive error true, 1000, timeout
2019-02-21 15:22:43.162   luup_log:50: Harmony Control_error: Failed to get new automation configuration from Hub. Error : 500, Error waiting for response..
2019-02-21 15:22:43.162   luup.variable_set:50: 50.urn:rboer-com:serviceId:Harmony1.IconSet was: 2 now: 1 #hooks:0
2019-02-21 15:22:43.162   luup.variable_set:50: 50.urn:rboer-com:serviceId:Harmony1.LinkStatus was: Starting... now: Error #hooks:0

Offline reneboer

  • Moderator
  • Hero Member
  • *****
  • Posts: 1574
  • Karma: +110/-31
Re: [Solved]: Do not update your Hamony Hub to version 4.15.250
« Reply #19 on: February 21, 2019, 03:50:55 pm »
Hi ronluna,

Do you have a lot of devices configured on your Hub? It seems to timeout, but very fast. Can you do a test with this version? I increased the timeout from 10 to 30 seconds. However, this is not something changed for the Hub 4.15.250 version, so not 100% sure this is the solution.

Did you use the 3.5 version before or did you just switch from the older 2.2 version on XMPP?

Last option is to check your luasock library version. Make sure you have the latest packages loaded (as you are running on openLuup).

Cheers Rene
2xVeraLite, VeraEdge, openLuup, ALTUI, 20 switches, 10 dimmers, 20 sensors, 10 scene controllers, 1 Harmony Hub, many plug-ins. Not enough time.

Offline ronluna

  • Jr. Member
  • **
  • Posts: 96
  • Karma: +1/-3
Re: [Solved]: Do not update your Hamony Hub to version 4.15.250
« Reply #20 on: February 21, 2019, 10:03:19 pm »
the increment on the timeout from 10sec to 30sec has fixed the error.

I was on version 2.2 didn't get the chance to try version 3.5. Although on version 2.2 I did experience a few timeout.

lua-scoket installed:
Code: [Select]
sudo apt-cache policy lua-socket
lua-socket:
  Installed: 3.0~rc1-3
  Candidate: 3.0~rc1-3
  Version table:
 *** 3.0~rc1-3 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
        100 /var/lib/dpkg/status

Offline reneboer

  • Moderator
  • Hero Member
  • *****
  • Posts: 1574
  • Karma: +110/-31
Re: [Solved]: Do not update your Hamony Hub to version 4.15.250
« Reply #21 on: February 22, 2019, 05:06:38 am »
Thanks. Can you see in the log how many seconds it took to get the full response from your Hub? You can click the Update button next to Update Configuration to force that. On a reload it only retrieves it when there is data missing to run the plugin properly.

Cheers Rene
2xVeraLite, VeraEdge, openLuup, ALTUI, 20 switches, 10 dimmers, 20 sensors, 10 scene controllers, 1 Harmony Hub, many plug-ins. Not enough time.

Offline Cor

  • Hero Member
  • *****
  • Posts: 1249
  • Karma: +8/-4
Re: [Solved]: Do not update your Hamony Hub to version 4.15.250
« Reply #22 on: February 22, 2019, 08:34:43 am »
It seems I have a Problem now as well.

Untill 2 days ago all worked  fine. When it stopped working I updated the plugin with the link provided. Harmony startes working again.

But my morning scene, which includes starting sonos radio and group some sonos, gives a luup restart..... every time.

I removed the harmony part in that scene and no more luup restarts.

Of my way to work again and on my next week I will be home to look further...... but something not right,

Cor

Offline reneboer

  • Moderator
  • Hero Member
  • *****
  • Posts: 1574
  • Karma: +110/-31
Re: [Solved]: Do not update your Hamony Hub to version 4.15.250
« Reply #23 on: February 22, 2019, 08:41:10 am »
Hi Cor,

Please check that the startactivities commands are not overlapping. Since a few releases the plugin does not wait until the activity is completely started. It return immediately as some sequences take 20-30 seconds and it was just not a good idea to ty up you Vera for that long.

I am working on some enhancements that should avoid this situation by making use of the job mechanism but that is a bit new territory.

Cheers Rene
2xVeraLite, VeraEdge, openLuup, ALTUI, 20 switches, 10 dimmers, 20 sensors, 10 scene controllers, 1 Harmony Hub, many plug-ins. Not enough time.

Offline Cor

  • Hero Member
  • *****
  • Posts: 1249
  • Karma: +8/-4
Re: [Solved]: Do not update your Hamony Hub to version 4.15.250
« Reply #24 on: February 22, 2019, 12:37:44 pm »
Hello Rene,

I see your point , but I don't understand completely what you mean. 2 Screenshots are attached , can you be so kind to look at them?

What happends in the morning , when I "wake up my house".
-It is done by a virtual switch. which triggers some PLEG action:
-Unlocks frontdoor.
-switch on some lights
-runs scene : play music.
-switches on - off some in house- outside cameras ( blue iris http request.)
-autovera: set the volume to loud on some android phones.

The scene to play the music has some items in in:
-Switch on the amplifier.
-set a volume 5 seconds later.
-use the Harmony to start the music: switch on the amplifier ( again) , start sonos , go to the right amplfifier chanel etc.
-set the volume again.

The reason I switch on the amplifier twice and the volume is due to the (initial)  volume. Before , when I only started the Harmony activity , and the volume was ( from the night before watching a movie for example) way too loud it took the harmony too long to set the right volume. Now I start with setting the right volume , before Harmony starts it thing.

Looking at the attached screenshots , anything I need to change there , anything you suspect what is causing the luup restart- commands overlapping?

Many thanks,
Cor



Offline reneboer

  • Moderator
  • Hero Member
  • *****
  • Posts: 1574
  • Karma: +110/-31
Re: [Solved]: Do not update your Hamony Hub to version 4.15.250
« Reply #25 on: February 22, 2019, 03:01:19 pm »
Hi Cor,

Sorry, really cannot tell like this. Can you set the log level at debug and share a bit of the LuaUPnP.log showing the bits before the reload?

Cheers Rene
2xVeraLite, VeraEdge, openLuup, ALTUI, 20 switches, 10 dimmers, 20 sensors, 10 scene controllers, 1 Harmony Hub, many plug-ins. Not enough time.

Offline Cor

  • Hero Member
  • *****
  • Posts: 1249
  • Karma: +8/-4
Re: [Solved]: Do not update your Hamony Hub to version 4.15.250
« Reply #26 on: February 22, 2019, 03:56:08 pm »
OK , I will do that next week when I am home again.

What do you mean exactly with :"startactivities commands are not overlapping" . can you give a short example?

Thanks,
Cor

Offline reneboer

  • Moderator
  • Hero Member
  • *****
  • Posts: 1574
  • Karma: +110/-31
Re: [Solved]: Do not update your Hamony Hub to version 4.15.250
« Reply #27 on: February 23, 2019, 05:11:16 am »
Hi Cor,

For example the activity to start my TV takes about 25-35 seconds. In all version V3.x versions you can send a second command while that is still running. I just put out V3.7 that does not allow this. It will fail the call_action if an command is still busy. Note that only starting an activity can take that long. All other commands are basically instant.

I hope V3.7 will be in the Mios app store Monday. It is already available on the ALTUI App store.

Cheers Rene
2xVeraLite, VeraEdge, openLuup, ALTUI, 20 switches, 10 dimmers, 20 sensors, 10 scene controllers, 1 Harmony Hub, many plug-ins. Not enough time.

Offline jepjr

  • Sr. Newbie
  • *
  • Posts: 38
  • Karma: +0/-0
Re: [Solved]: Do not update your Hamony Hub to version 4.15.250
« Reply #28 on: February 24, 2019, 01:02:42 pm »
My hub automatically updated to 4.15.250.  My plug-in is 3.5, downloaded from MiOS app store.  Any idea when the plug-in might be updated on the MiOS app store to 3.6 or 3.7?


Offline jepjr

  • Sr. Newbie
  • *
  • Posts: 38
  • Karma: +0/-0
Re: [Solved]: Do not update your Hamony Hub to version 4.15.250
« Reply #29 on: February 24, 2019, 01:10:55 pm »
Sorry for the extra noise in the tread, I was able to update to 3.7 using the ALTUI app store and the integration is working again.

Thanks so much for repairing this so quickly!