We have moved at community.getvera.com

Author Topic: Controlling Pool Scene with Alexa Routine  (Read 375 times)

Offline Sammy2

  • Hero Member
  • *****
  • Posts: 904
  • Karma: +5/-5
Controlling Pool Scene with Alexa Routine
« on: February 28, 2019, 02:23:13 pm »
I use Pool Control Plugin with an Autelis to control my Jandy Pool Equipment Controller.

I have scenes to perform certain actions. I'm working on putting these scenes into Alexa using Alexa Routines.

One scene (the first one I'm trying to set up in Alexa) turns on the spa by setting pump speed, turning the JVA's (Jandy Valve Actuator) to redirect water flow to the spa jets and spa return and then turning on the Spa Heater to a set temperature. This scene works with an Alexa Routine to turn on the spa when I say, "Alexa, turn on the spa". I have the routine set to turn the Spa On scene "on" when I say this.

Turning the spa off is another thing altogether. I have an opposing scene in Vera to reverse the above things. The scene works fine in Vera as well as using the Macros built into the Pool Control Plugin. I've tried setting up the Alexa Routine for when I say, "Alexa, turn off the spa" to no avail. I've tried both having that phrase turn the Spa Off scene to both "on" and "off" in the Alexa Routine editor.

I haven't tried any other pool scenes such as turning the pool heat on or off or any of the party scenes I have set up that set the mood about the pool based on the type of pool activity planned but I suspect the result will be the same for turning it "off".

Any assistance would be awesome!

Thanks!
« Last Edit: March 01, 2019, 10:21:17 am by Sammy2 »

Offline Sammy2

  • Hero Member
  • *****
  • Posts: 904
  • Karma: +5/-5
Re: Controlling Pool Scene with Alexa Routine
« Reply #1 on: March 01, 2019, 06:20:09 am »
Anyone?

Sent from my SM-G960U1 using Tapatalk


Offline Catman

  • Sr. Member
  • ****
  • Posts: 338
  • Karma: +10/-0
Re: Controlling Pool Scene with Alexa Routine
« Reply #2 on: March 01, 2019, 09:01:59 am »
Anyone?

Sent from my SM-G960U1 using Tapatalk

I'm no expert but is this because you're not really turning the spa *off* you're turning *on* another scene.

I maybe misreading how you're setting this up, though, and I might also be totally wrong.

C

Offline Sammy2

  • Hero Member
  • *****
  • Posts: 904
  • Karma: +5/-5
Re: Controlling Pool Scene with Alexa Routine
« Reply #3 on: March 01, 2019, 10:19:44 am »
Thank you for your response.

To clarify.. I have the following Scenes in Vera:

Spa On

  • Turn off all pump speeds (there's 4 speeds)
  • Turn on high speed pump (maximum speed)
  • Turn on Spa "Device" (turns the two JVA's mentioned above to redirect flow to the spa jets and spa return, instead of normal flow to the pool)
  • Wait one minute then turn on Spa Heater preset to 100o

Spa Off

  • Turn off Spa Heat
  • Turn off Spa "Device" (turns the two JVA's mentioned above to redirect flow from the spa jets and spa return, back to normal flow to the pool)
  • Wait 15 minutes (to cool down the heat exchanger in the Spa Heater, then turn all pumps off

Notes:

  • All pumps are controlled via Z-Wave and FortrezZ MIMO relays
  • All pool devices (JVA's and heater) are controlled via the Jandy Pool Control Plugin / http commands via Autelis to the pool control panel

In Alexa I have two Routines:

"Alexa, turn on the spa" runs the first Vera Scene (Scene Spa On set to "on"). This works.

"Alexa, turn off the spa" runs the second Vera Scene (Scene Spa Off set to "on", but I've tried setting it to "off" too). This does not work.

All that said, I've found that Alexa Routines now have the ability to "wait" so I will experiment with creating a different Routine that controls the individual devices in the same manner as my current Spa Off Scene. I will see how that works but I hate having to re-create things when they should just work!

Offline Sammy2

  • Hero Member
  • *****
  • Posts: 904
  • Karma: +5/-5
Re: Controlling Pool Scene with Alexa Routine
« Reply #4 on: March 01, 2019, 11:12:44 am »
Thank you for your response.

To clarify.. I have the following Scenes in Vera:

Spa On

  • Turn off all pump speeds (there's 4 speeds)
  • Turn on high speed pump (maximum speed)
  • Turn on Spa "Device" (turns the two JVA's mentioned above to redirect flow to the spa jets and spa return, instead of normal flow to the pool)
  • Wait one minute then turn on Spa Heater preset to 100o

Spa Off

  • Turn off Spa Heat
  • Turn off Spa "Device" (turns the two JVA's mentioned above to redirect flow from the spa jets and spa return, back to normal flow to the pool)
  • Wait 15 minutes (to cool down the heat exchanger in the Spa Heater, then turn all pumps off

Notes:

  • All pumps are controlled via Z-Wave and FortrezZ MIMO relays
  • All pool devices (JVA's and heater) are controlled via the Jandy Pool Control Plugin / http commands via Autelis to the pool control panel

In Alexa I have two Routines:

"Alexa, turn on the spa" runs the first Vera Scene (Scene Spa On set to "on"). This works.

"Alexa, turn off the spa" runs the second Vera Scene (Scene Spa Off set to "on", but I've tried setting it to "off" too). This does not work.

All that said, I've found that Alexa Routines now have the ability to "wait" so I will experiment with creating a different Routine that controls the individual devices in the same manner as my current Spa Off Scene. I will see how that works but I hate having to re-create things when they should just work!

Well that doesn't work.. Alexa doesn't recognize directly the pool thermostats so I cannot set them in part of a routine.

Offline therealdb

  • Sr. Member
  • ****
  • Posts: 258
  • Karma: +6/-0
  • Automate all the things!
Re: Controlling Pool Scene with Alexa Routine
« Reply #5 on: March 01, 2019, 11:49:23 am »
Well that doesn't work.. Alexa doesn't recognize directly the pool thermostats so I cannot set them in part of a routine.

thermostats and temperature sensors are not supported by the Vera Skill at the moment.

I have a couple of routines with fancy keyboard (ie: "privacy", "bed mode", "pool time", "no more pool") because turn on/off are reserved to devices.
Vera Edge EU, Fibaro FGRM 222 (14), Fibaro FGS 223 (26), Fibaro FGS 222 (6), Fibaro UBS (2), Fibaro+N Plug (3), NeoCoolCam Door Sensor (3), PIR (2) & Plugs (2), Nest (3), Home Server running my own integrations, Harmony Hub, OpenSprinkler, Personal Weather Station, Sonoff TH & more

Offline Catman

  • Sr. Member
  • ****
  • Posts: 338
  • Karma: +10/-0
Re: Controlling Pool Scene with Alexa Routine
« Reply #6 on: March 01, 2019, 11:50:26 am »
This is a bit of a guess as I had a similar issue that I never got around to putting in the effort to fix (not with a spa) but have you tried calling the 'Spa Off' scene something totally different like 'no bathing' and then using

Alexa, turn no bathing on?

C

Offline Sammy2

  • Hero Member
  • *****
  • Posts: 904
  • Karma: +5/-5
Re: Controlling Pool Scene with Alexa Routine
« Reply #7 on: March 01, 2019, 12:27:23 pm »


Well that doesn't work.. Alexa doesn't recognize directly the pool thermostats so I cannot set them in part of a routine.

thermostats and temperature sensors are not supported by the Vera Skill at the moment.

I have a couple of routines with fancy keyboard (ie: "privacy", "bed mode", "pool time", "no more pool") because turn on/off are reserved to devices.

Can you elaborate on this a bit more? Thanks.

In the meantime I will try a simple scene in Vera to just turn the spa heat off then incorporate that into an Alexa Routine.



Sent from my SM-G960U1 using Tapatalk


Offline Sammy2

  • Hero Member
  • *****
  • Posts: 904
  • Karma: +5/-5
Re: Controlling Pool Scene with Alexa Routine
« Reply #8 on: March 01, 2019, 12:28:21 pm »


This is a bit of a guess as I had a similar issue that I never got around to putting in the effort to fix (not with a spa) but have you tried calling the 'Spa Off' scene something totally different like 'no bathing' and then using

Alexa, turn no bathing on?

C

Worth a shot.

Sent from my SM-G960U1 using Tapatalk


Offline Sammy2

  • Hero Member
  • *****
  • Posts: 904
  • Karma: +5/-5
Re: Controlling Pool Scene with Alexa Routine
« Reply #9 on: March 01, 2019, 05:58:12 pm »


This is a bit of a guess as I had a similar issue that I never got around to putting in the effort to fix (not with a spa) but have you tried calling the 'Spa Off' scene something totally different like 'no bathing' and then using

Alexa, turn no bathing on?

C

Worth a shot.

Sent from my SM-G960U1 using Tapatalk

Just re-posting from the Jandy Pool Control Thread..

So I change my scenes "Spa On" and "Spa Off" to "Yes Spa" and "No Spa" respectively and redid my Alexa Routines. It worked using my phone and pressing the play button in the Alexa App. I'll try it with voice commands but I think this is the issue.

Now I need to re-program my "Spa Mode" Macro In Pool Control because it will no longer know what to do..

JEEZ. What B.S. but it is what it is.

Offline therealdb

  • Sr. Member
  • ****
  • Posts: 258
  • Karma: +6/-0
  • Automate all the things!
Re: Controlling Pool Scene with Alexa Routine
« Reply #10 on: March 02, 2019, 01:37:13 am »
You can associate an alexa routine to a phrase. That's what I did.

https://www.smarthomefocus.com/custom-voice-commands-alexa-routine/#tab-con-5
Vera Edge EU, Fibaro FGRM 222 (14), Fibaro FGS 223 (26), Fibaro FGS 222 (6), Fibaro UBS (2), Fibaro+N Plug (3), NeoCoolCam Door Sensor (3), PIR (2) & Plugs (2), Nest (3), Home Server running my own integrations, Harmony Hub, OpenSprinkler, Personal Weather Station, Sonoff TH & more

Offline Catman

  • Sr. Member
  • ****
  • Posts: 338
  • Karma: +10/-0
Re: Controlling Pool Scene with Alexa Routine
« Reply #11 on: March 02, 2019, 02:51:03 am »

Just re-posting from the Jandy Pool Control Thread..

So I change my scenes "Spa On" and "Spa Off" to "Yes Spa" and "No Spa" respectively and redid my Alexa Routines. It worked using my phone and pressing the play button in the Alexa App. I'll try it with voice commands but I think this is the issue.

Now I need to re-program my "Spa Mode" Macro In Pool Control because it will no longer know what to do..

JEEZ. What B.S. but it is what it is.

Yeah, it's cos 'on' and 'off' are 'reserved' . Glad it's (probably) sorted :)

C