Author Topic: Any way to edit the files for VeraAlerts to disable "Vera Startup" message?  (Read 3824 times)

Offline signal15

  • Sr. Member
  • ****
  • Posts: 322
  • Karma: +1/-0
I can't work on anything when the kids are sleeping unless I go downstairs, unlock my security cabinet, and unplug the android phone.  If it says "Vera Startup", then I get an earful from the wife.

I was looking at the files for this, but I really couldn't see exactly where to disable this.

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +764/-142
It's in I_VeraAlert.xml
Remove the line:
Code: [Select]
send_alert("Vera Startup", "")
I have already fixed this ... but I am not ready to release.

Offline signal15

  • Sr. Member
  • ****
  • Posts: 322
  • Karma: +1/-0
Doh.  Guess it helps to view the XML file in an actual XML editor instead of in Chrome.  Chrome doesn't honor the line breaks and it looks like a jumbled mess.

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +764/-142
Done in version 2.1
Did not make the top 5 features list.

Offline S-F

  • Hero Member
  • *****
  • Posts: 1248
  • Karma: +62/-12
  • Clueless N00b
It's in I_VeraAlert.xml
Remove the line:
Code: [Select]
send_alert("Vera Startup", "")
I have already fixed this ... but I am not ready to release.

I don't have this in my I_VeraAlert.xml but I still get the notification. How is this?
My forum account was apparently hacked by a leprechaun. And he's drunk all of the time. If a post of mine seems a little off kilter, it's probably because he made it.

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +764/-142
UI4 or UI5 ? If UI5 what version ?
If it's the latest there is an option in Settings that can be used to disable it.

Offline S-F

  • Hero Member
  • *****
  • Posts: 1248
  • Karma: +62/-12
  • Clueless N00b
Yeah, I'm on UI5 now..... That setting is unchecked.
My forum account was apparently hacked by a leprechaun. And he's drunk all of the time. If a post of mine seems a little off kilter, it's probably because he made it.

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +764/-142
Check it than un-check it.
I might have a bug initializing the variable.


Offline jmedemar

  • Full Member
  • ***
  • Posts: 105
  • Karma: +2/-0
  • Vera 3
Yes. There was a snafu for me as well. I had to check it, then send an test alert. Then reload UI5 and uncheck it. Then I reloaded UI5 again and it was working.

Now I am trying to get the Vera alerts working for built in UI5 notifications but unchecking and checking the box doesn't make it start working. I still only get emails and texts, not Vera Alerts.   

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +764/-142
Have you ever had a Vera Alerts Message on the Phone ?
i.e. can you send one from the "Control Tab" of the Vera Alerts Device ?
If YES than to get Notifications  to work:
  • Create a notification on a device any device
  • Click the recipient for the device
  • Goto the Vera Alerts Device and click on the wrench
  • Goto the Addition Configuration Tab
  • If you Did NOT set a Default Recipients for Vera Alerts than you must specify one for the user that you selected for the notification.
  • Exit the settings and SAVE

As the Additional Configuration Tab Warning message states: YOU must open the that tab when you make ANY changes to notifications. It does some work in the background when you open this. If it changes anything you will see the standard SAVE button in the upper right ... even if you did not enter anything!
« Last Edit: December 04, 2012, 11:53:44 pm by RichardTSchaefer »

Offline S-F

  • Hero Member
  • *****
  • Posts: 1248
  • Karma: +62/-12
  • Clueless N00b
Re: Any way to edit the files for VeraAlerts to disable "Vera Startup" message?
« Reply #10 on: December 06, 2012, 06:39:11 am »
Check it than un-check it.
I might have a bug initializing the variable.

This seemed to do the trick.
My forum account was apparently hacked by a leprechaun. And he's drunk all of the time. If a post of mine seems a little off kilter, it's probably because he made it.