We have moved at community.getvera.com

Author Topic: VeraAlerts Version 3.0  (Read 12250 times)

Offline snovvman

  • Full Member
  • ***
  • Posts: 205
  • Karma: +2/-1
Re: VeraAlerts Version 3.0
« Reply #30 on: March 05, 2013, 08:52:01 am »
They get cleared out when they are up uploaded.

If they are still on your server ... them that means there was a connection problem.
I do know of an issue that I need to fix ... that causes connection problems. I will get to it soon.

Thanks.  I have not been able to get it to work.  But through testing, many video events have been generated.  Is there a way for me to clear those videos on Vera manually?

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +764/-143
Re: VeraAlerts Version 3.0
« Reply #31 on: March 05, 2013, 09:24:20 am »
Just delete them .. they are in the  /tmp/log/cmh area.

Offline baxy_AU

  • Sr. Member
  • ****
  • Posts: 269
  • Karma: +5/-0
Re: VeraAlerts Version 3.0
« Reply #32 on: March 09, 2013, 02:31:19 am »
Hi Richard
Do you have an idea when the timestamp fix will be posted?
Btw I am curious to know why the default timestamp is the time the notification is received rather than Vera's time that the notification was triggered? I would have thought the latter would be more meaningful....it is for me anyway as I have a number of issues that prevent me from receiving them instantly.

Offline baxy_AU

  • Sr. Member
  • ****
  • Posts: 269
  • Karma: +5/-0
Re: VeraAlerts Version 3.0
« Reply #33 on: March 09, 2013, 03:18:23 am »
Go to the Vera Alerts device on the Vera Control Panel.
Then go to the Notification Configuration Tab. You will change the message for
the appropriate Notification to something like:

XBMC is now playing: {device(DeviceID].service[ServiceID].VariableName)}

You get the values for DeviceID, ServiceID and VariableName from the Advanced tab for the XBMC device. To get the ServiceID for a variable, let  the mouse hover over the variable name in the advanced tab.
Can you please give me an example of this syntax as I'm unsure which brackets are required as there seems to me that maybe it should be an extra [  around the device ID ?
« Last Edit: March 09, 2013, 03:23:50 am by baxy_AU »

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +764/-143
Re: VeraAlerts Version 3.0
« Reply #34 on: March 09, 2013, 08:24:37 am »
I fixed the example!

The documentations is at:
http://rts-services.com/VeraTemplates/
It is referened from the VeraAlert plugin documentation.

I also included my test file: veraTemplateTest.lua onto Vera during the plugin install.
So you can download it and look at the examples. Apps -> Develop Appps -> Download veraTemplateTest.lua

 

Offline baxy_AU

  • Sr. Member
  • ****
  • Posts: 269
  • Karma: +5/-0
Re: VeraAlerts Version 3.0
« Reply #35 on: March 15, 2013, 03:48:09 am »
Hi Richard
Do you have an idea when the timestamp fix will be posted?
Btw I am curious to know why the default timestamp is the time the notification is received rather than Vera's time that the notification was triggered? I would have thought the latter would be more meaningful....it is for me anyway as I have a number of issues that prevent me from receiving them instantly.
Hi Richard
Any update on this?

Offline baxy_AU

  • Sr. Member
  • ****
  • Posts: 269
  • Karma: +5/-0
Re: VeraAlerts Version 3.0
« Reply #36 on: March 26, 2013, 07:23:05 pm »
Go to the Vera Alerts device on the Vera Control Panel.
Then go to the Notification Configuration Tab. You will change the message for
the appropriate Notification to something like:

XBMC is now playing: {device([DeviceID].service[ServiceID].VariableName)}

You get the values for DeviceID, ServiceID and VariableName from the Advanced tab for the XBMC device. To get the ServiceID for a variable, let  the mouse hover over the variable name in the advanced tab.
I still can't get this to work....my xbmc device is 52 and the serviceId is urn:upnp-org:serviceId:XBMCState1 and I have tried the variables IdleTime and PlayerStatus but all I ever get is 0 for the result...any clue what i am doing wrong
so this it the actual string "XBMC is now playing: {device([52].service[XBMCState1].IdleTime)}"
does this look correct?
« Last Edit: March 26, 2013, 07:32:12 pm by baxy_AU »

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +764/-143
Re: VeraAlerts Version 3.0
« Reply #37 on: March 26, 2013, 09:36:17 pm »
That does not look like a legit service ID ... but It could just be that the XBMC does not follow typical naming conventions.

Offline baxy_AU

  • Sr. Member
  • ****
  • Posts: 269
  • Karma: +5/-0
Re: VeraAlerts Version 3.0
« Reply #38 on: March 27, 2013, 12:57:42 am »
This is a screenshot of the XBMCState device ... does this help at all?

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +764/-143
Re: VeraAlerts Version 3.0
« Reply #39 on: March 27, 2013, 07:16:01 am »
The Service ID is that whole string ... not just a part of it:

      urn:upnp-org:serviceId:XBMCState1

Offline baxy_AU

  • Sr. Member
  • ****
  • Posts: 269
  • Karma: +5/-0
Re: VeraAlerts Version 3.0
« Reply #40 on: March 27, 2013, 10:24:15 am »
I have tried that string too...the result is the same

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +764/-143
Re: VeraAlerts Version 3.0
« Reply #41 on: March 27, 2013, 11:26:04 am »
What are you getting in the Vera log when you send the following from the
Vera Alerts device Send Alert tab:

XBMC is now playing: {device([52].service[urn:upnp-org:serviceId:XBMCState1].IdleTime)}

Offline baxy_AU

  • Sr. Member
  • ****
  • Posts: 269
  • Karma: +5/-0
Re: VeraAlerts Version 3.0
« Reply #42 on: March 27, 2013, 09:25:38 pm »
What are you getting in the Vera log when you send the following from the
Vera Alerts device Send Alert tab:

XBMC is now playing: {device([52].service[urn:upnp-org:serviceId:XBMCState1].IdleTime)}
How do I check the log?

Offline baxy_AU

  • Sr. Member
  • ****
  • Posts: 269
  • Karma: +5/-0
Re: VeraAlerts Version 3.0
« Reply #43 on: March 28, 2013, 10:39:48 am »
OK I tried your suggestion and it seems that the variable is not populated when the event is triggered? When the event is triggered the result is 0 but when I send the same alert a few seconds later manually the result is the video title.

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +764/-143
Re: VeraAlerts Version 3.0
« Reply #44 on: March 28, 2013, 11:52:21 am »
What event are you triggering on ?