We have moved at community.getvera.com

Author Topic: Delay Zwave command  (Read 433 times)

Offline spilote

  • Sr. Newbie
  • *
  • Posts: 38
  • Karma: +0/-0
Delay Zwave command
« on: November 13, 2018, 09:57:15 pm »
Hey Guys

I need advice, I have a large Zwave network with around 150 device; various IP device; total around 250-300 devices

I have developped all (almost) my scene with Lua. On various scene, I send signal to 50-60 devices and vera takes few minutes to fully execute my scene.

for exemple, in the morning, when motion is detected, I change the house status from night to home; open all the lights. The open all the lights may take up to 4 minutes to fully execute. It's pitch black for 4 minutes, then! boom! all on.

I call support and they suggest I delay my command and I'm looking at options on how to proceed.

I was looking at the call_delay; call_timer but needed advice.

Please let me know,


Offline kigmatzomat

  • Sr. Member
  • ****
  • Posts: 377
  • Karma: +23/-0
Re: Delay Zwave command
« Reply #1 on: November 14, 2018, 11:41:59 pm »
You are running a pretty big network and vera is not exactly a superstar of efficient design.

Have you considered having a couple of different lighting scenes with the same trigger? I.e. bedroom, living room, kitchen, etc?  In theory they would all happen simultaneously but the reality is the scenes  cascade through the luup engine to the zwave controller. I think from outside the house you could see the difference but probably not from inside the house.

I would make the room scenes you are most likely to be in first, so they are more likely to fire first. I don't know that scenes with lower id numbers run before scenes with higher numbers if they share a trigger event, but it's a decent guess.

Offline rafale77

  • Community Beta
  • Hero Member
  • ******
  • Posts: 1749
  • Karma: +101/-27
  • HA ≠ IoT as a blue sky is cloudless.
Re: Delay Zwave command
« Reply #2 on: November 15, 2018, 12:09:03 pm »
I will try to give you more details with code when I get back home. I am dealing with the exact same issue and yeah having scenes with the same trigger actually does not help since it is not the luup engine which is stuck, it is the local zwave API queuing commands to wazooas it waits for ack signals back from the device before lauching another command to the radio.

The way I would suggest to handle this is with cascading scenes:
One mother scene with the trigger which will run daughter scenes in sequence and with delay +
aserie of manually triggered daughter scenes containing the zwave actions you desire.
openLuup (79 devices, 141 scenes, 19 apps) master to VeraPlus (142 zwave nodes, 8 Zigbee nodes, 221 devices,  20 scenes , 2 apps) +  Hubitat (15 Zigbee nodes) + Home-Assistant (API Integrations). Bridged to Siri and Alexa. Homewave. VeraPlus ExtRooted and mios server independent.