We have moved at community.getvera.com

Author Topic: NX-584e Connection to NX-8 using WF2SL  (Read 15002 times)

Offline ke2nny

  • Sr. Newbie
  • *
  • Posts: 20
  • Karma: +1/-0
NX-584e Connection to NX-8 using WF2SL
« on: May 05, 2013, 04:04:27 pm »
I am a newbie to this forum and the world of home automation.   I have an NX-8 for which I purchased a NX-584e.  I installed the card without issue and think I have configured my keypad correctly.   I have a Veralite with a couple of light switches programmed.  My Veralite is not in the same room as my alarm controller, so I purchased a WF2SL.  I connected a DB9 Null Modem cable between the NX-584e and the WF2SL.  I connected the WF2SL to my wireless network and was able to login to it and check its settings. I now have the follow lights on my NX-584e:

DS1 - continuously flashes

DS6  - Stays on continually

DS4  - Flashes about every 4 seconds.

I plan to take the WF2SL out of the picture and connect a laptop in its place to see if there is any communication (using putty).  If I have a laptop with a serial interface?  When I look in the Veralite where I loaded the NX-8 module, I get a Lua startup error.  I have worked on this all weekend and any suggestions on how I can get this to work will be appreciated. 



Offline futzle

  • Moderator
  • Master Member
  • *****
  • Posts: 3260
  • Karma: +192/-9
Re: NX-584e Connection to NX-8 using WF2SL
« Reply #1 on: May 05, 2013, 05:37:55 pm »
Hi ke2nny,

If you really have connected a null modem cable, then you need to move the four jumpers on the NX-584 board to their opposite positions.  This is the most common installation mistake and it's the easiest to fix.

The next most common mistake is to be using the wrong serial speed (baud rate).  There will be configuration on both the NX-584 and on the WF2SL, and they have to match.  I use 38400, but speeds down to 9600 will still be fine.

If finding a laptop with an RS-232 connection is hard, you might be able to get the laptop to talk to the NX-584 through the WF2SL; PuTTY has a "telnet" mode where you can connect to any IP address and port.

If you connect and just sit and watch you'll see binary output like this, repeating every 1.5 seconds:
Code: [Select]
~ ? ?yj(the ~ will always be there but the remaining text varies; trip a sensor by walking in front of it to ensure that the interface sends something).

Offline ke2nny

  • Sr. Newbie
  • *
  • Posts: 20
  • Karma: +1/-0
Re: NX-584e Connection to NX-8 using WF2SL
« Reply #2 on: May 05, 2013, 06:46:18 pm »
I switched the jumpers, but still no luck.  I have the baud rate set to 9600 both on the WF2SL and the Keypad. I get a blank screen when using Putty's Telnet option

Offline futzle

  • Moderator
  • Master Member
  • *****
  • Posts: 3260
  • Karma: +192/-9
Re: NX-584e Connection to NX-8 using WF2SL
« Reply #3 on: May 05, 2013, 07:55:25 pm »
Then it looks like the problem is downstream. I have no personal experience with the Global Cach? products so I can't guess if it is configured properly. Try and connect your computer directly to the NX-584, perhaps with a USB-to-serial adapter, and see what you get.

Offline ke2nny

  • Sr. Newbie
  • *
  • Posts: 20
  • Karma: +1/-0
Re: NX-584e Connection to NX-8 using WF2SL
« Reply #4 on: May 05, 2013, 08:28:28 pm »
I will have to buy a cable tomorrow, but thanks for your help.

Offline ke2nny

  • Sr. Newbie
  • *
  • Posts: 20
  • Karma: +1/-0
Re: NX-584e Connection to NX-8 using WF2SL
« Reply #5 on: May 12, 2013, 11:34:37 am »
I had to order a cable because the prices locally just were too high.  I connected the serial to USB cable to my laptop and opened a Putty session with the following results:

0986040000000000048018BD
0986040000000000048018BD
0986040000000000048018BD
0986040000000000048018BD
0986040000000000048018BD
0986040000000000048018BD
0986040000000000048018BD
0986040000000000048018BD
0986040000000000048018BD
0986040000000000048018BD
0986040000000000048018BD
0986040000000000048018BD
0986040000000000048018BD
0986040000000000048018BD
0986040000000000048018BD
0986040000000000048018BD
0986040000000000048018BD
0986040000000000048018BD


These were the results with the jumper settings in the normal position, which I can't understand because I have a null modem cable.  When I switch the jumpers, I get nothing.

Offline futzle

  • Moderator
  • Master Member
  • *****
  • Posts: 3260
  • Karma: +192/-9
Re: NX-584e Connection to NX-8 using WF2SL
« Reply #6 on: May 12, 2013, 04:20:13 pm »
ke2nny, you've got ASCII mode turned on. You need to change the panel interface to use Binary mode.

Offline ke2nny

  • Sr. Newbie
  • *
  • Posts: 20
  • Karma: +1/-0
Re: NX-584e Connection to NX-8 using WF2SL
« Reply #7 on: May 12, 2013, 10:29:39 pm »

Okay, I changed to the Binary mode with he following results:

098606000000000004821CCF
098606000000000004821CCF
098606000000000004821CCF
~9860600?~000000?~821CCF?~      ?~      ?~      ?~      ?~      ?~      ?~     ?~       ?~      ?~      ?~      ?~      ?~      ?~      ?~      ?~      ?~     ?~       ?~      ?~      ?~      ?~      ?~      ?~      ?~      ?~      ?~     ?~       ?~      ?~      ?~      ?~      ?~      ?~      ?~      ?~      ?~     ?~       ?~      ?~      ?~      ?~      ?~      ?~      ?~      ?~      ?~     ?~       ?~      ?~      ?~      ?~      ?~      ?~      ?~      ?


Does this mean everything is functioning properly?

Offline futzle

  • Moderator
  • Master Member
  • *****
  • Posts: 3260
  • Karma: +192/-9
Re: NX-584e Connection to NX-8 using WF2SL
« Reply #8 on: May 12, 2013, 10:33:56 pm »
That's better. Now you have to get the same results through your serial-to-wireless gateway. When you can do that it's ready to reconnect Vera.

Offline ke2nny

  • Sr. Newbie
  • *
  • Posts: 20
  • Karma: +1/-0
Re: NX-584e Connection to NX-8 using WF2SL
« Reply #9 on: May 13, 2013, 08:58:00 pm »
It's still not working my settings in the Vera Lite may not be correct.  These are my settings:


Serial port on another machine 


  XXX.XXX.XX.XXX     ( I have the IP Address of my WF2SL)

 TCP Port   4999

Offline ke2nny

  • Sr. Newbie
  • *
  • Posts: 20
  • Karma: +1/-0
Re: NX-584e Connection to NX-8 using WF2SL
« Reply #10 on: May 13, 2013, 10:11:58 pm »
I think I got it. I downloaded the GC100 app and then it allowed me to specify the GC100 device inside of the Caddx/GE/NetworX device

Offline crsherman

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: NX-584e Connection to NX-8 using WF2SL
« Reply #11 on: September 29, 2013, 03:20:35 pm »
Ke2nny,
I am in the process of setting up my system very similar to your approach.  Can you tell me where you found the GC100 app you referenced?


Offline BoffinGus

  • Newbie
  • *
  • Posts: 10
  • Karma: +1/-0
Re: NX-584e Connection to NX-8 using WF2SL
« Reply #12 on: October 08, 2013, 07:36:52 am »
Hi All,

I too am trying to get a similar configuration working with the Global Cache IP2SL PoE unit. So hence the reply within this thread.

When setup I am getting the following error with the Vera2 unit:

"Caddx NX584 Security System[11] : Failed to set up interface"

I am using the GC-100 plugin available within Vera GUI and setup the serial port within that device and used that as the serial port within the Caddx device.

I have check the cable (null) & connection (38400 baud) with an old laptop with a physical serial port using PuTTY with the NX584e in ASCII mode and also with the IP2SL unit with PuTTY using telnet & port 4999, both connections produced the same output repeated approximately every 2 seconds in  ASCII being:

0C880000000000000000020100970B
0C880000000000000000020100970B
0C880000000000000000020100970B

The Vera is reconnected and address 72# location 0# option 1 is deselected to return to Binary saved with * and exit of programming.

Additional to the fitting of the NX584e, the system was re-installed post a major renovation of the house. This meant that the system was reset to factory defaults to by-pass unknown installer code, and an additional keypad was also added.

So the system is:
1 x NX4 Main unit with Zone doubling with dual end of line option on.
2 x NX1508 LED code pads
1 x NX584e Home Automation Module.

The NX584e was added last after testing of the system without it.

Do I need to change any main panel programming from factory, other than operational items such as entry/exit delays for correct communication/format exchange to the 584e?

Cheers
Gus..

Offline futzle

  • Moderator
  • Master Member
  • *****
  • Posts: 3260
  • Karma: +192/-9
Re: NX-584e Connection to NX-8 using WF2SL
« Reply #13 on: October 08, 2013, 05:45:38 pm »
"Caddx NX584 Security System[11] : Failed to set up interface"

That error message is generated by the plugin if the NX-584 is missing one of the essential message types in its enabled-message-type list.  The list of message types that you have to enable is listed on the plugin's documentation page. Edit: on further reading of the code, I'm not sure that my previous claim is true.  You may only get that error message when the plugin can't speak to the NX-584.  But try the action in the next paragraph first, just to make sure.

If you can enable "Debug to Luup Log" on the Configure tab and capture a Luup log then we can probably zero in on the cause quite quickly.

The same message might be generated in other circumstances, but you've already debugged the physical connection, so let's look at the software first.
« Last Edit: October 08, 2013, 05:55:55 pm by futzle »

Offline BoffinGus

  • Newbie
  • *
  • Posts: 10
  • Karma: +1/-0
Re: NX-584e Connection to NX-8 using WF2SL
« Reply #14 on: October 09, 2013, 08:47:50 am »
Hi futzle,

Thanks for the quick response.

Quote
If you can enable "Debug to Luup Log" on the Configure tab and capture a Luup log then we can probably zero in on the cause quite quickly.

Unfortunately I can't access the Configure tab, it just stays at "Getting configuration..."

Any pointers other than a verbose log of everything?

Cheers
Gus..