Author Topic: Vera and an ISY994i  (Read 97054 times)

Offline sprex

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
Re: Vera and an ISY994i
« Reply #390 on: November 21, 2015, 11:54:59 pm »
It does (Evolve LRM-AS).

That's a good idea - i'll try a scene with 'If ANY device is switched off' as a trigger.

However, if a light is just dimmed slightly - i'm assuming this won't cause a trigger. Would PLEG be able to handle this? I don't use it (yet).

Thank you

Offline 93732

  • Jr. Member
  • **
  • Posts: 87
  • Karma: +2/-0
Re: Vera and an ISY994i
« Reply #391 on: November 22, 2015, 01:15:54 am »
Regarding PLEG detecting if a light is dimmed slightly, I would ask over at the PLEG subform (http://forum.micasaverde.com/index.php/board,48.0.html).  Good luck! I have one of my KPL LED lights turn on and off based on the open/close status of my garage doors.  Handy way to make sure my garage doors are closed.

Offline sprex

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
Re: Vera and an ISY994i
« Reply #392 on: November 23, 2015, 01:00:45 am »
Thanks - i will do.

Yes i've had lots of luck so far with Vera/ISY - stable and also having KPL's respond to people turning on/off sonos via the sonos app or homewave seems to breed confidence in the whole setup.

Offline scyto

  • Jr. Member
  • **
  • Posts: 87
  • Karma: +1/-0
Re: Vera and an ISY994i
« Reply #393 on: February 29, 2016, 03:35:46 am »
I am coming back to this after some time away. Anyone manage to get the ISY controller device status to report correctly (connected, started, whatever) on UI7?

Offline Scoutmedic

  • Jr. Member
  • **
  • Posts: 74
  • Karma: +2/-1
Re: Vera and an ISY994i
« Reply #394 on: May 11, 2016, 09:07:00 pm »
Scyto, not sure about that. I just set mine up after failed attempts to use other interfaces and just got it working. Now I'm fighting the red "can't detect device" banner, but I can see my Insteon device. Only have one so far, but more to come.

Garrettwp, PurdueGuy, and others, thanks for your hard work!

Offline Scoutmedic

  • Jr. Member
  • **
  • Posts: 74
  • Karma: +2/-1
Re: Vera and an ISY994i
« Reply #395 on: July 22, 2016, 02:09:12 pm »
Has anyone running UI7 successfully been able to remove the red banner for the ISY device stating "Can't Detect Device"? I'm trying to get Vera to run programs in ISY and for some reason it's not working. All ISY devices appear and respond in Vera.

Offline Aaron

  • Hero Member
  • *****
  • Posts: 1984
  • Karma: +61/-193
Re: Vera and an ISY994i
« Reply #396 on: August 03, 2016, 09:49:33 pm »
I am coming back to this after some time away. Anyone manage to get the ISY controller device status to report correctly (connected, started, whatever) on UI7?

I loaded the last full released LUA file, and your modified on... not getting proper status. Also shows 'Stopped' & 'Disconnected'

Has anyone running UI7 successfully been able to remove the red banner for the ISY device stating "Can't Detect Device"? I'm trying to get Vera to run programs in ISY and for some reason it's not working. All ISY devices appear and respond in Vera.

After loading scyto's version of the LUA it stopped showing "Can't Detect Device" on the ISY device,  for a few minutes but then it returned

BUT I'm having a huge problem... All my ISY devices are showing OFF even when on. Anyone else having a problem?
« Last Edit: August 03, 2016, 11:33:54 pm by Aaron »

Offline Scoutmedic

  • Jr. Member
  • **
  • Posts: 74
  • Karma: +2/-1
Re: Vera and an ISY994i
« Reply #397 on: August 07, 2016, 07:09:45 pm »
I am coming back to this after some time away. Anyone manage to get the ISY controller device status to report correctly (connected, started, whatever) on UI7?

I loaded the last full released LUA file, and your modified on... not getting proper status. Also shows 'Stopped' & 'Disconnected'

Has anyone running UI7 successfully been able to remove the red banner for the ISY device stating "Can't Detect Device"? I'm trying to get Vera to run programs in ISY and for some reason it's not working. All ISY devices appear and respond in Vera.

After loading scyto's version of the LUA it stopped showing "Can't Detect Device" on the ISY device,  for a few minutes but then it returned

BUT I'm having a huge problem... All my ISY devices are showing OFF even when on. Anyone else having a problem?

Aaron, PurdueGuy provided the following help and it got it fixed for me...

I did resolved the "Can't Detect Device" by adding the following line in "Main/I_ISYController1.xml"

Original:
Code:
         function initialize(lul_device)

             -- Put the /etc/cmh-ludl and /etc/cmh-lu directories into the Lua include path.

New
Code:
         function initialize(lul_device)
             -- UI7 mod to prevent "Can't detect device"
             luup.set_failure(false)

             -- Put the /etc/cmh-ludl and /etc/cmh-lu directories into the Lua include path.

As far as status updates from ISY to Vera, there was a post somewhere about writing a scene in Vera (or something to that effect) to poll the ISY for the status of devices. I'll see if I can find it since I need to perform it myself.

Offline PurdueGuy

  • Hero Member
  • *****
  • Posts: 1170
  • Karma: +21/-0
Re: Vera and an ISY994i
« Reply #398 on: August 07, 2016, 11:21:02 pm »
Just to give everyone a quick notice -

I've updated the plugin to add the following:
- get rid of "Cannot detect device" on UI7 (done)
  - NOTE: I do not use UI7 (tried it and hated it) so beyond that one mod, it's untested
- Insteon Thermostat support (mostly done)
- Insteon Hidden Door Sensor (HDS) support (not yet started)

The code isn't quite ready for checkin, but I hope in the next few days.
Vera3, Leviton, Intermatic, SQ Blaster, HomeWave, DSC 1832, Insteon/Altsteon

Offline Scoutmedic

  • Jr. Member
  • **
  • Posts: 74
  • Karma: +2/-1
Re: Vera and an ISY994i
« Reply #399 on: August 11, 2016, 05:36:29 pm »
Thanks PurdueGuy. Things are trucking along pretty well now. Still trying to figure out why the Mini Remote is not being passed through to the Vera though.

Offline boojew

  • Jr. Member
  • **
  • Posts: 75
  • Karma: +0/-0
Re: Vera and an ISY994i
« Reply #400 on: August 15, 2016, 12:57:56 pm »
Lots of info in this thread - can anyone confirm if the isy99i is also supported by this?

Offline gduprey

  • Full Member
  • ***
  • Posts: 122
  • Karma: +6/-1
Re: Vera and an ISY994i
« Reply #401 on: August 15, 2016, 01:00:51 pm »
Lots of info in this thread - can anyone confirm if the isy99i is also supported by this?
Yep -- and it's not likely to change.  UDI (isy994i makers) are really good about not breaking external API access.

Offline PurdueGuy

  • Hero Member
  • *****
  • Posts: 1170
  • Karma: +21/-0
Re: Vera and an ISY994i
« Reply #402 on: August 16, 2016, 12:34:26 am »
Well, I just commited/pushed changes for the following:

- Fixed UI7 "Cannot detect device" error
- Added Insteon Thermostat support
- Added Hidden Door Sensor (HDS) support

If you can't get the changed from git, I will be updating the first post momentarily.

WARNING: This changes one of the variable names for calling ISY scenes.   See the post here:
http://forum.micasaverde.com/index.php/topic,17309.msg224364.html#msg224364
I don't know what the old code had, so I wanted everyone to be made aware now.
Vera3, Leviton, Intermatic, SQ Blaster, HomeWave, DSC 1832, Insteon/Altsteon

Offline PurdueGuy

  • Hero Member
  • *****
  • Posts: 1170
  • Karma: +21/-0
Re: Vera and an ISY994i
« Reply #403 on: August 16, 2016, 02:21:17 am »
Thanks PurdueGuy. Things are trucking along pretty well now. Still trying to figure out why the Mini Remote is not being passed through to the Vera though.
Per the file CatSubcat.txt, the following should be included (but some aren't) towards the top of L_ISYController1.lua:
Code: [Select]
local insteonDeviceCategory0 = {
    ['0'] = true,
    remoteLinc = {
        ['16'] = true,
        ['17'] = true,
        ['18'] = true,
        ['20'] = true,
        ['21'] = true,
        ['22'] = true,
        ['23'] = true,
        ['24'] = true,
        ['25'] = true,
        ['26'] = true,
        ['27'] = true,
        ['28'] = true
    }
}

I updated the code, and updated the first post.   Try the new code, if it still doesn't work, continue reading!

Which version of the Mini Remote?
In the log, look for something similar to:
Code: [Select]
ISYController: debug: Parsing node AA BB CC 1; family = 1; devCat = 0; subCat = 27 AA BB CC will be the Insteon ID of your Mini Remote.  Would need to know what the subCat is.
« Last Edit: August 16, 2016, 02:24:58 am by PurdueGuy »
Vera3, Leviton, Intermatic, SQ Blaster, HomeWave, DSC 1832, Insteon/Altsteon

Offline Scoutmedic

  • Jr. Member
  • **
  • Posts: 74
  • Karma: +2/-1
Re: Vera and an ISY994i
« Reply #404 on: August 16, 2016, 09:18:03 am »
Thanks PurdueGuy. Things are trucking along pretty well now. Still trying to figure out why the Mini Remote is not being passed through to the Vera though.
Per the file CatSubcat.txt, the following should be included (but some aren't) towards the top of L_ISYController1.lua:
Code: [Select]
local insteonDeviceCategory0 = {
    ['0'] = true,
    remoteLinc = {
        ['16'] = true,
        ['17'] = true,
        ['18'] = true,
        ['20'] = true,
        ['21'] = true,
        ['22'] = true,
        ['23'] = true,
        ['24'] = true,
        ['25'] = true,
        ['26'] = true,
        ['27'] = true,
        ['28'] = true
    }
}

I updated the code, and updated the first post.   Try the new code, if it still doesn't work, continue reading!

Which version of the Mini Remote?
In the log, look for something similar to:
Code: [Select]
ISYController: debug: Parsing node AA BB CC 1; family = 1; devCat = 0; subCat = 27 AA BB CC will be the Insteon ID of your Mini Remote.  Would need to know what the subCat is.

That fixed it. I'm using the model 2342-2. I linked it with the ISY using the RemoteLinc 2 option under Link Management. Now it shows up.

I'll let you know if any scene issues come up.