Author Topic: AD2USB suddenly started showing "Connection Down"  (Read 11048 times)

Offline pentium

  • Full Member
  • ***
  • Posts: 196
  • Karma: +9/-0
Re: AD2USB suddenly started showing "Connection Down"
« Reply #15 on: April 22, 2014, 02:18:51 pm »
Just in case, I sometimes get disconnected and fail to choose the correct ademco device.  It shows two in the selection list and I can never remember which one is right. 

Offline roquej

  • Sr. Newbie
  • *
  • Posts: 35
  • Karma: +0/-0
Re: AD2USB suddenly started showing "Connection Down"
« Reply #16 on: April 22, 2014, 02:22:49 pm »
Yes, it can get confusing, as it shows both the panel device and the partition device.  However, I have always gotten it to work by picking the panel device.  Therefore, I don't think that is the issue.  Thank you

Offline roquej

  • Sr. Newbie
  • *
  • Posts: 35
  • Karma: +0/-0
Re: AD2USB suddenly started showing "Connection Down"
« Reply #17 on: April 22, 2014, 03:56:24 pm »
Fixed it. The how: uninstalled the plugin, rebooted, and then reinstalled it. Of course, had to redo all the configurations and parameters. Wonder what happened...

Offline roquej

  • Sr. Newbie
  • *
  • Posts: 35
  • Karma: +0/-0
Re: AD2USB suddenly started showing "Connection Down"
« Reply #18 on: April 23, 2014, 04:32:19 pm »
Well, spoke too soon...it worked for 24 hours and it died again.  Any suggestions?

JR

Offline tb001

  • Sr. Member
  • ****
  • Posts: 385
  • Karma: +5/-2
Re: AD2USB suddenly started showing "Connection Down"
« Reply #19 on: May 18, 2014, 07:01:02 pm »
Would love any other suggestions here as well. All was working fine and then I used battery pack to add a device and now am seeing a connection down error. So frustrating--this is one of the plug ins I use the most. I've re-entered all the serial port info, since this was lost on the system, but still not working

Offline thewizardofoz

  • Full Member
  • ***
  • Posts: 123
  • Karma: +4/-2
  • Vera 3
Re: AD2USB suddenly started showing "Connection Down"
« Reply #20 on: May 19, 2014, 01:10:43 am »
Did you reboot Vera after you entered all the serial port info?
Vera 3 UI5  with 2 slave Vera 3s and 1 slave VeraLite all connected by CAT6.  Running about 130 devices and 8 Plug-ins including PLEG

Offline tb001

  • Sr. Member
  • ****
  • Posts: 385
  • Karma: +5/-2
Re: AD2USB suddenly started showing "Connection Down"
« Reply #21 on: May 19, 2014, 11:06:25 am »
Good question. I think I rebooted, but not positive. Got up this morning and seems to be working again--hopefully it stays that way!

Offline SteveZ

  • Sr. Member
  • ****
  • Posts: 328
  • Karma: +4/-1
Re: AD2USB suddenly started showing "Connection Down"
« Reply #22 on: May 19, 2014, 03:23:18 pm »
Anytime the vera powers up and does not see the ad2usb the serial port settings will be lost, like when you unplug it to add a sensor and power it up off the battery. This is one reason why I have my vera on a ups and try to always add devices using full power inclusion and leave the vera where it's at. I haven't had to re enter my serial port settings for well over a year

Offline triangledave

  • Jr. Member
  • **
  • Posts: 92
  • Karma: +0/-0
Re: AD2USB suddenly started showing "Connection Down"
« Reply #23 on: August 23, 2014, 12:26:39 pm »
I set my alarm last night via the AD2USB connection.  This morning I get connection down. I first tried to save PIN, no luck.  Then I went in and checked the serial config and the baud rate had defaulted back to 115k.  I changed it back to 9600 and reloaded, no joy.  Power cycled Vera, no joy.  Checked my AD2USB device and have green blinking light.  My alarm panel device still shows armed status even though I have disarmed it manually.

I have not touched Vera for months and have been using the AD2USB device multiple times daily without fault.  The only things I have ever had to do is resave the PIN after I've added devices or rebooted Vera and even rarer I've had to occasionally reset the Baud rate.  Otherwise I have been running the AD2USB connection without issue for years and now it is randomly gone.

Reading the responses in this thread, I am concerned that others have run into this issue and there does not seem to be a clear resolution.

Does anyone have any additional info or suggestions?

Thank you

Offline pentium

  • Full Member
  • ***
  • Posts: 196
  • Karma: +9/-0
Re: AD2USB suddenly started showing "Connection Down"
« Reply #24 on: August 23, 2014, 05:27:21 pm »
Actually, the 115k baud rate was correct.  You will want to change it back to that rate.

For me, the blinking green light usually leads to the lack of internet connectivity.  I had that problem the other morning, for unexplained reasons, and i simply unplugged the vera and plugged it back in and the green light went solid and vera was once again talking to the ad2usb.  I am hoping to replace my internet connectivity with a raspberry pi this week, hoping to get a more dependable alarm connection than the ethernet port on the back of my uverse receiver.

But since you mentioned it, just in the past few weeks I have looked at the ui5 screen and it says the connection is down about once or twice a week.  I hit the reload button and do not get the message.  This also follows my lightning strike which burned out my ad2usb and required me to get a new one. 

I would think that if you are getting a green blinking light that you are having a lot of other issues as well, so for me I would be tracking back the internet connection. 

Offline triangledave

  • Jr. Member
  • **
  • Posts: 92
  • Karma: +0/-0
Re: AD2USB suddenly started showing "Connection Down"
« Reply #25 on: August 24, 2014, 02:12:43 am »
reset baud to 115k and it works again.  Thank you!  I hope it stays up.  Vera is connected to network via unmanaged gigabit switch.

Never had this happen before.  We did have a thunderstorm last night.  If power blinked, it did not blink enough to reset any clocks in the house.  Vera is connected to a UPS as is the alarm panel.

Not sure what is going on.  I guess I'll just keep an eye on it.  I use the plugin twice daily, so I'll know pretty quickly if it is not working again.

David

Offline Fred S

  • Sr. Newbie
  • *
  • Posts: 48
  • Karma: +0/-0
Re: AD2USB suddenly started showing "Connection Down"
« Reply #26 on: October 01, 2014, 06:13:08 pm »
I'm having the same issue. I got a new AD2USB but it does not show up in the serial port Serial Port configuration section. Any ideas? I've connected to my PC so I know its working.

Offline ErikinSC

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Re: AD2USB suddenly started showing "Connection Down"
« Reply #27 on: January 08, 2017, 10:57:49 pm »
Wondering how any of you fixed this previously.    I am uninstalling the plugin, refreshed, and then power cycle (reboot) the VeraLite.

I could not get the plugin to work.    Any ideas on how to troubleshoot ?

Offline amizon

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Re: AD2USB suddenly started showing "Connection Down"
« Reply #28 on: January 19, 2017, 03:21:23 pm »
My AD2USB device has worked perfectly for several years (except for the occasional vera serial port config reset).
I'm now experiencing the same 'connection down' error - it started a week ago.

I've noticed that the green 'heartbeat' light on the AD2USB device will turn off completely when the connection down error occurs (no more flashing).
Troubleshooting so far:
 - replaced the vera to AD2USB USB cable        (problem still occurs)
 - I've upgraded the AD2USB firmware             (problem still occurs)

To temporarily fix the error (for a day or two), I simply disconnect the 4 alarm wires from AD2USB, wait a few seconds, and plug them back in.
The green heartbeat light starts flashing again and I reboot veraplus and everything works fine again.

I will keep troubleshooting.

Offline kevinnutech

  • Jr. Member
  • **
  • Posts: 55
  • Karma: +2/-0
Re: AD2USB suddenly started showing "Connection Down"
« Reply #29 on: February 01, 2017, 06:48:03 pm »
Does this behavior repeat itself when you have it hooked to a PC?