We have moved at community.getvera.com

Author Topic: Setting up NTP time sync with Vera and a Windows server Time service  (Read 1530 times)

Offline Armedmetallica

  • Jr. Member
  • **
  • Posts: 78
  • Karma: +2/-1
My Vera is internal only (no internet access, prevented by Firewall). Anytime I disconnect Vera (say to pair with a z-wave device), I lose the time/date (since it can't connect to get time from the internet).

So - I followed the steps in the wiki here: http://wiki.micasaverde.com/index.php/Time_Syncronization

After that, I edited /etc/config/ntpclient to add my Domain Controller (Windows Server 2008R2 that's running a Time Service).

Starting the client failed - because of a lack of trust between the two machines.

The NTP client has a -t option switch that lets you "trust" the connection (not really recommended, from what I understand). After much digging, I found that if I edit the file: /etc/hotplug.d/iface/20-ntpclient
and put a -t option on the two command lines, the start works fine.

Putting this here - in case anyone else with an internal only Vera has the same issue/setup.

Offline Armedmetallica

  • Jr. Member
  • **
  • Posts: 78
  • Karma: +2/-1
EDIT:

FAIL that didn't work.

So i guess this turns into a question... how the heck can I get Vera to get NTP from a windows domain controller?

Offline Armedmetallica

  • Jr. Member
  • **
  • Posts: 78
  • Karma: +2/-1
Update - my initial post still stands - the update did work, and the NTP daemon is running.

the -t option, when specified in the 20-ntpclient file does the trick.

Code: [Select]
2205 root      1068 S    /usr/sbin/ntpclient -t -i 600 -s -l -D -p 123 -h 192.168.1.9
 3329 root      1676 S    rdate -s ntp.xs4all.nl
 3339 root      1672 S    grep ntp

I'd love to get that rdate to stop all together - it seems to only run for a short period, so not horrible to keep.