Author Topic: Vera Blue Iris Unofficial Plugin  (Read 136369 times)

Offline Mgsmith75

  • Jr. Member
  • **
  • Posts: 84
  • Karma: +0/-1
Re: Vera Blue Iris Unofficial Plugin
« Reply #30 on: July 06, 2014, 05:44:18 pm »
Overall this is awesome, just what I have been waiting for! I am having one minor issue with the motion sensors on vera. They will not allow me to switch to bypass without manually setting the variable in the advanced tab. The buttons on the dashboard do not work. Says not implemented.


Sent from my iPhone using Tapatalk

Offline undertoe

  • Full Member
  • ***
  • Posts: 220
  • Karma: +14/-2
    • GitHub for My Vera Plugins
Re: Vera Blue Iris Unofficial Plugin
« Reply #31 on: July 06, 2014, 07:14:09 pm »
Overall this is awesome, just what I have been waiting for! I am having one minor issue with the motion sensors on vera. They will not allow me to switch to bypass without manually setting the variable in the advanced tab. The buttons on the dashboard do not work. Says not implemented.

Good catch, i haven't tried to bypass yet but i will fix that in the next revision.
Check out my vera plugins: Roomba Plugin, Roomba Thinking Cleaner Plugin, Blue Iris Cam Plugin

Offline undertoe

  • Full Member
  • ***
  • Posts: 220
  • Karma: +14/-2
    • GitHub for My Vera Plugins
Re: Vera Blue Iris Unofficial Plugin
« Reply #32 on: July 06, 2014, 07:44:09 pm »
Released version 0.4

- Option to Switch Motion Controls to Preset
- Option to Switch Zoom to Preset
- Option to for Horizontal Control Reverse
- Option to for Vertical Control Reverse

How-to Upgrade from a previous version
https://github.com/undert03/vera-blueiris#upgrade

Read about the new config options
https://github.com/undert03/vera-blueiris#configuration-options

Download Here
https://github.com/undert03/vera-blueiris/releases/latest
« Last Edit: July 07, 2014, 07:54:18 am by undertoe »
Check out my vera plugins: Roomba Plugin, Roomba Thinking Cleaner Plugin, Blue Iris Cam Plugin

Offline tb001

  • Sr. Member
  • ****
  • Posts: 382
  • Karma: +5/-2
Re: Vera Blue Iris Unofficial Plugin
« Reply #33 on: July 06, 2014, 07:56:53 pm »
TB you get everything setup? Have you watched my install video, should be nothing more than just copying your lan ip and port and pasting it during the setup. You can PM me if you are still having an issue.

Thanks undertoe! All set up and working well. Great app--thanks for your work on this! Now I just need to start investing in better cameras!

Offline Mgsmith75

  • Jr. Member
  • **
  • Posts: 84
  • Karma: +0/-1
Vera Blue Iris Unofficial Plugin
« Reply #34 on: July 06, 2014, 08:10:57 pm »
Released version 0.4

- Option to Switch Motion Controls to Preset
- Option to Switch Zoom to Preset
- Option to for Horizontal Control Reverse
- Option to for Vertical Control Reverse

Read about the new config options
https://github.com/undert03/vera-blueiris#configuration-options

Download Here
https://github.com/undert03/vera-blueiris/releases/latest

Thanks undertoe,

When updating from a pervious version do we need to start fresh or if I am updating from .3 to .4 do I just need to load the newest I_BlueIris.xml?


Sent from my iPad using Tapatalk

Offline undertoe

  • Full Member
  • ***
  • Posts: 220
  • Karma: +14/-2
    • GitHub for My Vera Plugins
Re: Vera Blue Iris Unofficial Plugin
« Reply #35 on: July 06, 2014, 08:17:09 pm »
Yes, I should probably add that to the read me. Just upload the 0.4 I_Blueiris.xml and check the restart luup. After it reloads all configured cameras should have the updated config options.

How-to Upgrade from a previous version
https://github.com/undert03/vera-blueiris#upgrade


« Last Edit: July 07, 2014, 07:54:27 am by undertoe »
Check out my vera plugins: Roomba Plugin, Roomba Thinking Cleaner Plugin, Blue Iris Cam Plugin

Offline CoreDex

  • Newbie
  • *
  • Posts: 15
  • Karma: +1/-0
Re: Vera Blue Iris Unofficial Plugin
« Reply #36 on: July 08, 2014, 12:19:06 am »
undertoe,
Thanks for creating this fantastic plug-in, I really appreciate your effort here.   I have been testing this for a few days, and I can't seem to get it to work with the LAN security enabled.  It works fine with LAN security disabled in BlueIris, but once I enable it, I can no longer connect to any cameras.   I know i'm using the correct credentials (from the BlueIris Web console settings admin account).  Any idea what may be the issue here?

Have others utilized with the LAN security enabled successfully?

Thanks very much

Offline LightsOn

  • Hero Member
  • *****
  • Posts: 751
  • Karma: +4/-3
Re: Vera Blue Iris Unofficial Plugin
« Reply #37 on: July 08, 2014, 02:57:04 am »
Yep working for me here. Have you ticked administrator under the account in blue iris? That may be it?

Offline undertoe

  • Full Member
  • ***
  • Posts: 220
  • Karma: +14/-2
    • GitHub for My Vera Plugins
Re: Vera Blue Iris Unofficial Plugin
« Reply #38 on: July 08, 2014, 06:58:39 am »
CoreDex, yes I have tested it with a alphanumeric username and password. If your username or password contains non-alphanumeric maybe try to remove them just for the test. If that works it might be an encoding issues.
Check out my vera plugins: Roomba Plugin, Roomba Thinking Cleaner Plugin, Blue Iris Cam Plugin

Offline undertoe

  • Full Member
  • ***
  • Posts: 220
  • Karma: +14/-2
    • GitHub for My Vera Plugins
Re: Vera Blue Iris Unofficial Plugin
« Reply #39 on: July 08, 2014, 08:18:07 am »
Just released version 0.5 which addresses two bug fixes

  • Motion Sensor can now be set to Armed or Bypass
  • If you disable motion detection the motion sensor would still be available in Vera now if you set "EnableMotionSensor" back to 0 it will delete the associated Motion sensor on reload.

Download Here
https://github.com/undert03/vera-blueiris/releases/latest

How to upgrade from a previous version
https://github.com/undert03/vera-blueiris#upgrade

Pushing this version to the MIOS market place
« Last Edit: July 08, 2014, 01:20:26 pm by undertoe »
Check out my vera plugins: Roomba Plugin, Roomba Thinking Cleaner Plugin, Blue Iris Cam Plugin

Offline undertoe

  • Full Member
  • ***
  • Posts: 220
  • Karma: +14/-2
    • GitHub for My Vera Plugins
Re: Vera Blue Iris Unofficial Plugin
« Reply #40 on: July 09, 2014, 02:37:53 pm »
In the MIOS Market Place for easy install

http://apps.mios.com/plugin.php?id=6916

Rate and Review please :)
Check out my vera plugins: Roomba Plugin, Roomba Thinking Cleaner Plugin, Blue Iris Cam Plugin

Offline BOFH

  • Sr. Hero Member
  • ******
  • Posts: 2391
  • Karma: +111/-138
Re: Vera Blue Iris Unofficial Plugin
« Reply #41 on: July 09, 2014, 06:16:05 pm »
gladly left! camera name 'index' is a great bonus. I've added one with that name just for overview purposes so I can see all my cams in one go.
Vera3 UI5 UI7 Edge Plus
Trane TZEMT400AB32 | Schlage BE369 FE599 | GE 45601 45602 45603 45604 45606 45609 45631 | Intermatic HA01C HA03C HA05C HA07C CA600 CA3000 | Aeon DSC06106 | Telguard GDC1 | Foscam FI8910W FI8905W FI9821W | D-Link 930L | Wanscam JW0011 | ZModo ZPIBH13W

Offline undertoe

  • Full Member
  • ***
  • Posts: 220
  • Karma: +14/-2
    • GitHub for My Vera Plugins
Re: Vera Blue Iris Unofficial Plugin
« Reply #42 on: July 09, 2014, 06:34:39 pm »
That's great :) How is the motion sensor setup going for everyone anything i can do to make it easier?
Check out my vera plugins: Roomba Plugin, Roomba Thinking Cleaner Plugin, Blue Iris Cam Plugin

Offline Mike

  • Jr. Member
  • **
  • Posts: 53
  • Karma: +1/-0
  • Gadget guru with a Z-wave addiction
    • IP Cam Talk
Re: Vera Blue Iris Unofficial Plugin
« Reply #43 on: July 14, 2014, 12:07:41 pm »
Installed and working great with my Blue Iris integration. I did have to adjust the Webserver -> Authentication setting to "Non-Lan only" to get it to work.
[ VeraLite ] [ Evolve LRM-AS ] [ GE 45605 Receptacle ] [ Digital Loggers Web Switch ] [ Wemo ] [ LiftMaster MyQ ] [ Everspring Flood Sensor, Temp. / Humidity Sensor ] [ Lots of Hikvision cameras ]

Offline cfnardone

  • Sr. Newbie
  • *
  • Posts: 41
  • Karma: +2/-0
Re: Vera Blue Iris Unofficial Plugin
« Reply #44 on: July 14, 2014, 12:53:00 pm »
I NEED HELP....
 I can't get the cams working in UI5 however they work great in blue iris.  When I go to create device after loading the .xml, do I enter the local ip address of the blue iris server or the WAN address?
That may be my problem...??
« Last Edit: July 14, 2014, 01:30:30 pm by cfnardone »