We have moved at community.getvera.com

Author Topic: AutoVera updates sometimes delayed up to a few minutes  (Read 9642 times)

Offline garrettwp

  • Master Member
  • *******
  • Posts: 6371
  • Karma: +227/-128
  • Vera 3, Lite, ISY994
Re: turning updates on/off in a scene
« Reply #15 on: July 11, 2014, 01:07:32 pm »
Make sure you are on the latest virtual switch version. Chixxi added the power switch service within the last 6 months.

- Garrett


Offline mikee123

  • Hero Member
  • *****
  • Posts: 1521
  • Karma: +18/-11
Re: turning updates on/off in a scene
« Reply #16 on: July 11, 2014, 03:45:15 pm »

As for your tablet and its slow wake, is this consistently slow? Or is it just slow in its first wake after a while?

GCM messages, like those pushed from AutoVera, should have no problem waking your Android devices. In your Android Settings>WiFi>Advanced, you should see a setting to keep WiFi on during sleep, make sure this is enabled. There are a couple more things to try, in case you still have trouble. So let me know how it goes.

Thanks.

I just checked my tablet, and my wifi is on during sleep, so that is not causing the delay in waking up or reacting to the autovera action. You said you have a couple more things to try...

Offline dkc

  • Moderator
  • Jr. Member
  • *****
  • Posts: 97
  • Karma: +6/-0
Re: turning updates on/off in a scene
« Reply #17 on: July 11, 2014, 03:54:05 pm »
You said you have a couple more things to try...

Indeed. The first thing to try would be a free app called Push Notification Fixer: https://play.google.com/store/apps/details?id=com.andqlimax.pushfixer.noroot&hl=en

There is also a version for rooted devices: https://play.google.com/store/apps/details?id=com.andqlimax.pushfixer&hl=en

It adjusts the "heartbeat" of the comms between GCM and your Android device, preventing the connection from timing out.  Your router may responsible for dropping the "stream", and this app should fix it, if that is in fact the problem.

If your tablet does not respond, or responds slowly to a push message, but then is able to keep up with subsequent pushes, this should be a solid solution to your issue.  If the pushes are always slow, this probably won't help.

Report back with your findings, when you get a chance, thanks!

Offline mikee123

  • Hero Member
  • *****
  • Posts: 1521
  • Karma: +18/-11
Re: turning updates on/off in a scene
« Reply #18 on: July 11, 2014, 04:58:56 pm »
Installed the push notification fixer, but unfortunately that did not fix the problem.

Next I updated my autovera devices on my phone, and the virtual switch still only has vswitch as a service. I was on Virtual switch 1.32, just did a manual update of the plugin, i am now on 1.34, but still only shows vswitch as a service.
I just tried another of my virtual switches, and on that one i have power as a service. Deleting the old one now and reinstalling the virtual switch. Hope that solves this problem.
« Last Edit: July 11, 2014, 05:12:18 pm by mikee123 »

Offline dkc

  • Moderator
  • Jr. Member
  • *****
  • Posts: 97
  • Karma: +6/-0
Re: turning updates on/off in a scene
« Reply #19 on: July 11, 2014, 05:07:50 pm »
Thanks for the quick response.

Did you see Garrett's note about updating the Virtual Switch plugin itself? He is probably correct, be sure to refresh devices after updating the plugin.

As for the PNF, I suppose then that all Status Updates sent to that device are slow? Not just the first after an amount of time has passed?  If enabled, try disabling System Logs within the AutoVera app. That may speed things up slightly.  Just so I have all of the info, what actions are included in the Task that runs with the Status Update? Would you mind listing them in order?

Offline mikee123

  • Hero Member
  • *****
  • Posts: 1521
  • Karma: +18/-11
Re: turning updates on/off in a scene
« Reply #20 on: July 11, 2014, 05:29:55 pm »
How do i refresh devices ? I have deleted and reinstalled that particular Vswitch, that solved the problem (at least with the power service, something still not working yet

My tablet is a Hudl, which is a reasonably fast tablet, nothing special but should be fast enough for what i want. I have only bought it for this last week for this one task, i want it as a security monitor. Autovera and tasker are installed. System logs in autovera are disabled (they were never enabled)
I have only 1 device enabled for updates at the moment, my front door motion sensor.
In tasker i only have one profile
Autovera status update: Vera 3
Device: Front door motion sensor
Service: Security sensor
Variable: tripped
New value: 1

this is linked to this task:
Say: Front door visitor
Secure settings Configuration Screen & keyboard Lights On 1 minute
Launch app Tinycam monitor free
Wait 1 minute
System lock

This profile/task combo is the same running on my phone, wheer it works fine, but on my phone tasker is a lot busier with lots of tasks, and autovera is monitoring a few more devices too
« Last Edit: July 11, 2014, 05:33:18 pm by mikee123 »

Offline dkc

  • Moderator
  • Jr. Member
  • *****
  • Posts: 97
  • Karma: +6/-0
Re: turning updates on/off in a scene
« Reply #21 on: July 11, 2014, 05:39:56 pm »
To refresh, you'd just go to Your Veras>Devices and then refresh with the icon at the top of the screen.

As for your tablet, is the order of Tasks the same on your phone? I would suggest moving the Say action down in the task, as it can take a second to launch, and the task typically wont continue until the Say action is complete. To test the response, try including an Alert>Beep as your first action. This should be almost instantaneous. Perhaps you could compare the two devices with identical profile/tasks? Use the AutoVera Status Update action and just a single Beep action. 

How much of a difference between the two? 1 second? 5? 20?

I really appreciate your willingness troubleshoot, thank you.

Offline mikee123

  • Hero Member
  • *****
  • Posts: 1521
  • Karma: +18/-11
Re: turning updates on/off in a scene
« Reply #22 on: July 13, 2014, 11:30:46 am »
I have moved the say action, and that did make it a little quicker. Not sure what i did but my tablet was working as quick as my phone for a day or so, but occasionally it is still very slow (slower than the phone) responding to the motion sensor trigger, so there is still something strange going on. The delay can be anything from a few seconds to a few minutes.



« Last Edit: July 13, 2014, 11:48:55 am by mikee123 »

Offline dkc

  • Moderator
  • Jr. Member
  • *****
  • Posts: 97
  • Karma: +6/-0
Re: turning updates on/off in a scene
« Reply #23 on: July 13, 2014, 11:59:34 am »
In the push notification fixer app, what did you set the heartbeat to? Try lowering it further.

For your relay switch, check the AutoVera logs after letting the action run on Vera. Confirm that you are getting the log and that all values align. I think I understand what you explained about the sensor to the relay switch, and it should be working as stated. You can always try passing the duty to a virtual switch or multiswitch.

Offline mikee123

  • Hero Member
  • *****
  • Posts: 1521
  • Karma: +18/-11
Re: turning updates on/off in a scene
« Reply #24 on: July 13, 2014, 12:47:27 pm »
I have got the relay switch working, you must have read it before i deleted that part of my post, I had to enable disable updates a few times, a few refreshes and it was working, so i deleted that part of my last post.

In the push notification fixer app, what did you set the heartbeat to? Try lowering it further.

I have not touched this, what values should i change, and to what values would you suggest ?

Offline dkc

  • Moderator
  • Jr. Member
  • *****
  • Posts: 97
  • Karma: +6/-0
Re: turning updates on/off in a scene
« Reply #25 on: July 13, 2014, 07:10:50 pm »
The app itself makes recommendations, I believe 5 minutes is good, but you can always try lower.  Be sure to toggle off/on your internet connection after enabling to ensure the new values are pushed. I haven't had the need to use this app as of late, but older devices(<4.3) with GCM issues are generally fixed entirely by PNF.

Offline mikee123

  • Hero Member
  • *****
  • Posts: 1521
  • Karma: +18/-11
Re: turning updates on/off in a scene
« Reply #26 on: July 14, 2014, 03:16:07 am »
Just an idea, is it possible that somehow the communication from my Vera is slow at times, and that being the cause sometimes ? I have not had the camera come up on my phone any more, something has gone wrong and I have not had a chance to look into it so I don't know if the phone is still quicker to respond to changes on Vera.

Offline mikee123

  • Hero Member
  • *****
  • Posts: 1521
  • Karma: +18/-11
Re: turning updates on/off in a scene
« Reply #27 on: July 21, 2014, 05:39:18 am »
I still have a problem with autovera updates taking a very long time to get to my tablet. Today it took 15 mins ! for a motion sensor alert to come through on my tablet. I have installed the push notification fixer app and set the heartbeat to 3 mins (5 mins was recommended but that did not really help)Any more suggestions of what I can do please? It does not really help to have my screen come on with the front door 15 mins after someone has been at the door... so I need to find a solution if you can see my predicament...

Offline dkc

  • Moderator
  • Jr. Member
  • *****
  • Posts: 97
  • Karma: +6/-0
Re: turning updates on/off in a scene
« Reply #28 on: July 21, 2014, 12:24:57 pm »
I can certainly understand your predicament, AutoVera Status Updates are supposed to be instant and in the case of your tablet, they are obviously not.  If Status Updates are sent to your phone without issue, that means the issue must lie with tablet, and it probably isn't related to AutoVera.  Do you have any sort of battery-saving mode enabled? Anything that sets your tablet in to a deep sleep to conserve battery? Is the tablet always powered? If so, do you keep the screen on at all times? Have you tried sending Status Updates to the device while it is "awake"? All GCM messages work the same way, so if you aren't receiving AutoVera Staus Updates in a timely manner, you probably aren't receiving any GCM messages on time. I did some research on your Tab, is there any 3rd-party software settings software with power-profiles? I couldn't find anything indicating issues with that particular model, so I'm kind of at a loss.

Offline mikee123

  • Hero Member
  • *****
  • Posts: 1521
  • Karma: +18/-11
Re: turning updates on/off in a scene
« Reply #29 on: July 21, 2014, 02:06:44 pm »
I dont think there are any power saving modes enabled. I have only had it for a few days, so i will have a look if i can see anything. As far as i am aware its a fairly standard Android, without much alterations to the OS. It is WiFi only. The screen is normally locked, and autovera sensing the front door motion sensor wakes up the tablet, and displays the camera. Same setup on my phone, i just copied the tasker profile as it was working well on the phone. The tablet runs in battery mode. I am at loss why this is happening. But saying that, it is not the first time Vera (or Vera related) surprises me... Are there any logs or is there a possibility to enable logs to maybe see in more detail of wheer the problem could be ?

I just checked, there are no power saving modes. WiFi is on permanent, without any power saving mode either.
« Last Edit: July 21, 2014, 02:36:39 pm by mikee123 »