We have moved at community.getvera.com

Author Topic: NX-590E  (Read 3429 times)

Offline ChrisFSB

  • Sr. Newbie
  • *
  • Posts: 33
  • Karma: +1/-0
NX-590E
« on: September 11, 2012, 01:01:05 pm »
Hi,

I'm using an NX-590E TCP/IP interface with port 9997 setup to enable home automation protocol.  The plugin connects and detects Partition 1, but subsequent polls (e.g. Zone name) time out.  How can I enable debug at the protocol level to troubleshoot?  This in on a NX-8e panel.

Thanks, Chris.
« Last Edit: March 30, 2013, 02:50:40 am by futzle »

Offline futzle

  • Moderator
  • Master Member
  • *****
  • Posts: 3260
  • Karma: +192/-9
Re: Re: Plugin for Caddx/GE/Networx NX-584/NX-8E security system
« Reply #1 on: September 14, 2012, 11:54:44 pm »
I'm using an NX-590E TCP/IP interface with port 9997 setup to enable home automation protocol.  The plugin connects and detects Partition 1, but subsequent polls (e.g. Zone name) time out.  How can I enable debug at the protocol level to troubleshoot?

Chris, I've never heard of the NX-590E, so this'll be interesting.  I suggest that you enable logging as I showed alexk to do a few posts ago, and capture the Luup log over SSH while you do a Luup restart, and capture another log while you do a zone scan from the Zones tab, and post the results.

at some point you told me to enable logging and then use the following SSH command.
tail -f /var/log/cmh/LuaUPnP.log
what do i need to disable what we started? just the logging check box in the alarm device or does the tail command also start something?

Alex, the tail command stopped as soon as you pressed Ctrl-C. No long-term effects.  So just disable the logging checkbox and you're good to go.

having major problems keeping my GE alarm panel connected to my Vera.

Let's see how far we get here on the public forum first.  Please describe your system, how it's connected to the Vera, what the issue is, and capture logs if you can.  Solving your problem may help other users too.
« Last Edit: September 14, 2012, 11:56:51 pm by futzle »

Offline okokok

  • Newbie
  • *
  • Posts: 2
  • Karma: +1/-0
Re: NX-590E
« Reply #2 on: December 26, 2013, 12:34:35 pm »
I am very interested in getting the 590e I have in my Caddx system to work with the vera3. I have failed in having the 590e send me emails directly using gmail and would like to integrate it into the vera 3 to do what I have failed to do plus a whole lot more. I would prefer not to spend more money on a 584 module and use the vera 3 with the 590. It would be great if I didn't have to use serial interface on the 590 as well. I would love to get the logs sent to the vera as well. If you could help I would appreciate it

Offline brandonharville

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
Re: NX-590E
« Reply #3 on: July 19, 2014, 07:53:15 am »
I have gotten the NX-590E to send me emails directly; The trick was to use a SMTP server without security. I found that this is support by my local cable operators server if the messages are sent from within my network (behind the cable modem associated with my user account).

Switching gears; Just setup a NX-590E for use with the Veralite... thus far the results look promising. I have been able to connect to arm and stay.

I have not been able to get the other function working yet. However, I'm thinking this may be due to the Vera's firmware. I am not currently using UI6.

Does the plug in work with UI5 any longer? I cant get the zones, users, or log scanner working.

Offline futzle

  • Moderator
  • Master Member
  • *****
  • Posts: 3260
  • Karma: +192/-9
Re: NX-590E
« Reply #4 on: July 19, 2014, 06:53:36 pm »
Does the plug in work with UI5 any longer? I cant get the zones, users, or log scanner working.

It should still work on UI5 but I don't have any way to test it. If you can report the JavaScript error then I can try to tweak it.

Otherwise you can install an older revision from code.mios.com (revision 72 here); there haven't been any significant changes to the base code so you shouldn't be missing out on anything.
« Last Edit: July 19, 2014, 08:11:50 pm by futzle »

Offline brandonharville

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
Re: NX-590E
« Reply #5 on: October 11, 2014, 08:28:39 am »
I've come to the realization that there is a slight difference in the 590 and 548 protocol. I have information on the 548 protocol. Does anyone have info on the 590 protocol?