We have moved at community.getvera.com

Author Topic: Trouble getting plugin to work at all  (Read 1930 times)

Offline tyarmas

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Trouble getting plugin to work at all
« on: September 09, 2014, 12:59:22 am »
Just got the Verlite and am trying to hook up the AD2USB. I have used the AD2USB app on my Mac to ue the AD2USB with my alarm panel, so I know it works. My Ademco panel needs all of the keypads set to address 31.

I have firmware 1.7.318 on my Veralite. I install the plugin and it says ver 3.1

It ceates a single partition when I install the plug-in, but I cannot set the baud rate on the device. When I go to develop Apps and click on serial port configuration, I cannot see a port. It lists "Not Available" and clicking on the reload Luup does not help. When I click the reload Luup, I get a status of "Please wait" in blue across the top of the web page, but I can never getany serial port configuration screen.

Any help is appreciated. I have tried this numerous times, uninstalling and re-installing the plug-in to no avail.

Thanks.

Offline golfer305

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: Trouble getting plugin to work at all
« Reply #1 on: September 09, 2014, 05:59:40 pm »
I'm having the same problem too.  My 10se works on my Mac but not when I hook it up to my Vera.  I have given mysel a headache search for a solution.

Very new to this.  So far I have done 3 light switches, a garage door controller with tilt sensor, and my Nest.

My setup is iMac running OSX Mavricks
Vera 3 w/UI5
Vista 10se alarm panel

Offline SteveZ

  • Sr. Member
  • ****
  • Posts: 328
  • Karma: +4/-1
Re: Trouble getting plugin to work at all
« Reply #2 on: September 09, 2014, 06:47:06 pm »
The only thing I can suggest is to contact support and tell them you want to downgrade to UI5 firmware.

Offline tyarmas

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Re: Trouble getting plugin to work at all
« Reply #3 on: September 09, 2014, 11:14:51 pm »
Thanks. I have been trying to do that all day. Not impressed with Vera support AT ALL. Numerous emails and tried calling a dozen times. I am starting to think support is non-existent with this company. I have read some posts where people saying to use chat, but have not seen anyplace to do that.

Offline kevinnutech

  • Jr. Member
  • **
  • Posts: 55
  • Karma: +2/-0
Re: Trouble getting plugin to work at all
« Reply #4 on: September 23, 2014, 03:36:27 pm »
Since we have changed the USB chip in the AD2USB, there are a few steps needed to produce a selectable "serial port" in the plugin as pointed out by other users on the forum:

Quote
1. type: lsusb <enter>
- this will list all the vendor and product id for usb ports and adapters on your vera
- the AD2USB will show up as 0403:6015, 0403:6010 or 0403:60xx. Write this down as it is your "vendor id:product id"
- if you're not sure which your AD2USB is, unplug your AD2USB and type "lsusb". Plug it in and type "lsusb". See which line was added. That is your adapter's info.
2. type: rmmod -f ftdi_sio <enter>
- we are removing the existing ftdi driver for the AD2USB. We will add one specifically for the AD2USB adapter next
3. type: insmod vendor=0x403 product=0x6015 <enter> (replace those with what you wrote down earlier)
- this loads the driver specifically for your AD2USB adapter
4. type: echo "ftdi_sio vendor=0x403 product=0x6015" > /etc/modules.d/65-usb-serial-ftdi <enter>
- this allows your vera to autoload drivers for the AD2USB even after reboot or power cycles. the original file just has "ftdi_sio"
5. type: echo "vendor:0403 product:6015" > /etc/cmh/serproxy.ports <enter>
- this allows vera 3 to see the new adapter as a serial adapter and adds it to the UI.

Once you reboot your Vera, you should be able to configure the plugin

Thanks,
Kevin @ Nu Tech/AlarmDecoder
« Last Edit: September 24, 2014, 12:09:30 am by kevinnutech »