We have moved at community.getvera.com

Author Topic: Ad2usb Cant detect device after ui7 upgrade  (Read 14282 times)

Offline kjp

  • Sr. Newbie
  • *
  • Posts: 22
  • Karma: +0/-0
Ad2usb Cant detect device after ui7 upgrade
« on: October 06, 2014, 12:58:35 pm »
i recently upgraded my veralite to ui7.
After this, i have been noticing a "cant detect device" on the ademco vista panel that comes and goes.
The ademco partition is working fine
i am able to arm and disarm the panel perfectly fine in Vera.
im attaching my current settings

any suggestions?
KJ

Offline pentium

  • Full Member
  • ***
  • Posts: 198
  • Karma: +11/-0
Re: Ad2usb Cant detect device after ui7 upgrade
« Reply #1 on: October 06, 2014, 01:06:30 pm »
If it makes you feel any better, I am still using ui5 and my ad2usb connection down will appear every day or so.  Sometime more than once in a day.  As in your situation, it doesn't seem to impact my connectivity to the alarm or at least not when I finally notice it.  Perhaps it actually lost connectivity for a while and now it has returned.  Mostly mentioning it because of the ui5 vs ui7 environment.

Offline andrewgarfield

  • Full Member
  • ***
  • Posts: 108
  • Karma: +11/-1
Re: Ad2usb Cant detect device after ui7 upgrade
« Reply #2 on: October 06, 2014, 01:54:23 pm »
Just wanted to chime in that this is happening to me as well.

Everything seems to be 100% functional with the plugin.  I can disarm, arm, etc, and get proper sensor statuses.  It even works over reboots and reloads.

However that error remains there all the time.  I haven't cared much cause it's functionally working, but I would obviously love to have it go away too.

Offline kevinnutech

  • Jr. Member
  • **
  • Posts: 55
  • Karma: +2/-0
Re: Ad2usb Cant detect device after ui7 upgrade
« Reply #3 on: October 06, 2014, 03:05:05 pm »
Kevin from Nu Tech/AlarmDecoder here:

To get the device to detect as a serial port please follow these instructions:  http://www.alarmdecoder.com/forums/viewtopic.php?f=3&t=122&sid=23dc943d3ed2cbab4aaabde91033ab7f

Offline Stefam

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
Re: Ad2usb Cant detect device after ui7 upgrade
« Reply #4 on: October 11, 2014, 12:24:23 pm »
Hi Thanks for the reply, but I am lost.  Where do we type in those commands?  Do I open a terminal session into the Veralite?  Sorry if I'm missing something obvious...

Offline kevinnutech

  • Jr. Member
  • **
  • Posts: 55
  • Karma: +2/-0
Re: Ad2usb Cant detect device after ui7 upgrade
« Reply #5 on: October 12, 2014, 02:56:11 am »
ssh to your vera and enter them at the command line as root - tools such at putty can help

Offline Stefam

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
Re: Ad2usb Cant detect device after ui7 upgrade
« Reply #6 on: October 12, 2014, 03:26:44 pm »
Thanks, That's what I thought.  Made the changes suggested (on my Veralite) and I still have the error. It all worked on UI5, but UI7 give me the error.  Unlike one of the above posters, I am non-functional since I cannot add zones to my partisans. 

Suggestions? 





Offline Stefam

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
Re: Ad2usb Cant detect device after ui7 upgrade
« Reply #7 on: October 12, 2014, 03:29:28 pm »
Also, after some more research, found that these steps will work in UI5 and NOT UI7.  Must have missed that...

Offline jssea

  • Newbie
  • *
  • Posts: 7
  • Karma: +1/-0
Re: Ad2usb Cant detect device after ui7 upgrade
« Reply #8 on: October 14, 2014, 12:52:10 pm »
Hi all,
I'm new to Vera and just got my AD2USB working on UI7 using the instruction sent my Kevin - initially the USB port was not detecting the AD2USB. Thanks! It required a little bit of research to find the password to SSH into the VeraLite.
However I have the same problem mentioned in this thread: partition is fine, but the plugin says it "Can't Detect Device"  for the panel. I think that happened just after I added my first zone in the cheat sheet.
If anyway has an idea to fix I, let me know:)
Also when I added a zone, it didn't appear immediately, I had to reboot the VeraLite to see it.
Thanks!


Offline kjp

  • Sr. Newbie
  • *
  • Posts: 22
  • Karma: +0/-0
Re: Ad2usb Cant detect device after ui7 upgrade
« Reply #9 on: October 14, 2014, 08:19:25 pm »
1.Kevin, will your instructions work for a older ad2usb that was working fine on a ui5?

2. It seems that the cheat sheet zones do not work when connection is down.
i have some scenes based on ademco motion sensors that are not running due to the connection being down.
im assuming the sensors are not communicating with vera. i could be wrong.

thanks
KJ

Offline kevinnutech

  • Jr. Member
  • **
  • Posts: 55
  • Karma: +2/-0
Re: Ad2usb Cant detect device after ui7 upgrade
« Reply #10 on: October 15, 2014, 01:44:56 am »
It should work, but shouldn't need to be done with an older ad2usb - though if it works on a PC and you are having trouble with the Vera it can't hurt.

Offline franksisic2010

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: Ad2usb Cant detect device after ui7 upgrade
« Reply #11 on: October 22, 2014, 05:07:07 pm »
Hello,  I am having the same trouble with my Vera3, using UI7.  I cannot assign zones in the cheat sheet due to the Can't Detect Device error message.  Is there a resolution or work around to this yet?  Frank Sisic
« Last Edit: October 22, 2014, 05:08:48 pm by franksisic2010 »

Offline sgray

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: Ad2usb Cant detect device after ui7 upgrade
« Reply #12 on: November 24, 2014, 05:25:53 pm »
Any resolution on the "Can't Detect Device" for the Panel. I have the same issue as previous posters on a new install. The partition is fine, but the plugin says it "Can't Detect Device"  for the Panel. I can Arm/Disarm the system via the partition but the Panel device doesn't work. I can still Add Zones to the Panel but it shows as disconnected?

Offline kevinnutech

  • Jr. Member
  • **
  • Posts: 55
  • Karma: +2/-0
Re: Ad2usb Cant detect device after ui7 upgrade
« Reply #13 on: November 26, 2014, 03:21:14 pm »
Just seems to be how the plugin was written - you control from the partition rather than the "panel" itself... partition detects device.. strange but at least it works for arming/disarming.  I've been digging through the driver code a bit here over at Nu Tech, hopefully have something to submit to mcv to address some of these issues.

Offline dlb

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
Re: Ad2usb Cant detect device after ui7 upgrade
« Reply #14 on: December 05, 2014, 04:46:17 pm »
I'm having similar problems with AD2USB after the UI7 upgrade from UI5.  I get "Can't Detect Device" messages about the alarm panel but the Alarm Panel Partition still seems to work, i.e I can arm/disarm and still get notifications about those events.

I've noticed that the Plugin Version is at 2.45 and the current app is at 3.10.  Don't know if that is part of my problem.

I've tried turning on auto-update for the plugin but that doesn't seem to work and the setting doesn't stick.  Its there anyway to update aside from uninstalling the AD2USB app and all of it's devices and reinstalling the new version and setting everything up again.

Thanks - David