We have moved at community.getvera.com

Author Topic: Imperihome crashes on startup after update this morning  (Read 1995 times)

Offline Andy

  • Sr. Newbie
  • *
  • Posts: 42
  • Karma: +1/-0
Imperihome crashes on startup after update this morning
« on: November 09, 2014, 06:16:20 pm »
Both my S4 and my Tab 3 8" auto updated to the latest Imperihome this morning, and since then the app has crashed a second or two after startup every time.

I get 'Loading devices' and then an Android error (An unexpected error has...), quickly overlaid with "Unfortunately Imperihome Lite has stopped".

I was about to update to Pro anyway, so did so via the Play Store, but it made no difference.

I'm using Vera UI7 (as that is what the box came with sadly, and it just about works well enough, though I'm a hair away from downgrading and starting over). I tried uninstalling and reinstalling at which point the demo seemed to work OK, but I them reconfigured my setup and disabled the demo and ended up with the crushing again.

Anyone have any ideas how to proceed? Has this happened to others?

Thanks in advance...

Offline integlikewhoa

  • Master Member
  • *******
  • Posts: 5630
  • Karma: +157/-382
Re: Imperihome crashes on startup after update this morning
« Reply #1 on: November 09, 2014, 06:31:07 pm »
Did you post this on their bata testing forum? I saw someone on their with similar problems but didnt look into it as i haven't  had the problem on my note 4.

Offline Andy

  • Sr. Newbie
  • *
  • Posts: 42
  • Karma: +1/-0
Re: Imperihome crashes on startup after update this morning
« Reply #2 on: November 09, 2014, 06:43:40 pm »
Nope not me, wasn't aware there was a beta?

I did report it via the Android crash reporting. but no idea what happens to that, so thought i t best to post here...

Offline integlikewhoa

  • Master Member
  • *******
  • Posts: 5630
  • Karma: +157/-382
Re: Imperihome crashes on startup after update this morning
« Reply #3 on: November 09, 2014, 07:11:08 pm »
Yup on google plus there is a whole imperihome  beta forum you can join and also beta software to use before it is released. Info is posted by me in the multiswitch thread of imperihome  on here or google it.

Offline Andy

  • Sr. Newbie
  • *
  • Posts: 42
  • Karma: +1/-0
Re: Imperihome crashes on startup after update this morning
« Reply #4 on: November 09, 2014, 07:15:22 pm »
I just googled it and asked to join - thanks for letting me know!

I assume that as my problem stems from an official non-beta release, it is unlikely to help me with this issue, but you never know...

Offline integlikewhoa

  • Master Member
  • *******
  • Posts: 5630
  • Karma: +157/-382
Re: Imperihome crashes on startup after update this morning
« Reply #5 on: November 10, 2014, 12:40:41 am »
I just googled it and asked to join - thanks for letting me know!

I assume that as my problem stems from an official non-beta release, it is unlikely to help me with this issue, but you never know...

More important the creators watch that forum and you'll likely get help faster their for this problem.

Offline integlikewhoa

  • Master Member
  • *******
  • Posts: 5630
  • Karma: +157/-382
Re: Imperihome crashes on startup after update this morning
« Reply #6 on: November 10, 2014, 10:09:58 am »
I see they got back to you. Dont forget to post your results on the temp fix to help any others here.

Offline Tank

  • Sr. Member
  • ****
  • Posts: 322
  • Karma: +11/-7
Re: Imperihome crashes on startup after update this morning
« Reply #7 on: November 10, 2014, 11:05:42 am »
FYI Looks like it was caused by the MultiSwitch plugin.  "In the meantime, you probably can fix the crash by setting your multiswitch's button names in the vera web ui."


Offline Andy

  • Sr. Newbie
  • *
  • Posts: 42
  • Karma: +1/-0
Re: Imperihome crashes on startup after update this morning
« Reply #8 on: November 10, 2014, 11:35:44 am »
Yep just about to reply to that in the beta group.

The multi switch seems to have a bug where I could not assign a name to the 8th button (I already had names for the first 7), so I uninstalled it as I am not using it I anmger yet. Does seem to have fixed the problem, but only after unstalling and reinstalling Imperihome.

Offline integlikewhoa

  • Master Member
  • *******
  • Posts: 5630
  • Karma: +157/-382
Re: Imperihome crashes on startup after update this morning
« Reply #9 on: November 10, 2014, 02:05:02 pm »
I saw that and have two different Multiswitches both working in Imperihome. Most of my buttons are named but not all of them. Both My switch plugins are still defualt name or MultiSwitch.

I'm using a note 4

Offline Tank

  • Sr. Member
  • ****
  • Posts: 322
  • Karma: +11/-7
Re: Imperihome crashes on startup after update this morning
« Reply #10 on: November 10, 2014, 05:03:31 pm »
Looks like they already pushed an update (2.4.1) to fix this and some other bugs.