We have moved at community.getvera.com

Author Topic: UI7 and HSM02 - ERROR:Scene running every wakeup and not only on tripped changed  (Read 1401 times)

Offline geminium

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
Hello,

I just go in UI7 and I encounter problems on trigger with HSM02.

Here is what is configured:
If a detector is armed and opened or closed then sends a notification via a piece of Lua code.

It works perfectly well when I open or close the door, except that every 30 minutes, I get a notification as if there was a trigger.

If I look a little the module configuration, there is the wakeup interval to 1800 seconds (30 minutes), so I feel that once the module wakes up, it triggers the scene.

Do you have an idea or behavior to solve my problem?

Thank you for your help.

Sample from my logs: The scene 14 is launched but the door was not closed, it's only a wakeup of the 35 device (HSM02)...

Code: [Select]
02      11/10/14 20:55:31.101   ^[[33;1mLOG_CHECK_MEMORY_LEAK pMem start 0xb0f000 now 0xb2e000 last 0xaf0000 leaked 126976^[[0m <0x2c1da680>
06      11/10/14 21:08:40.999   Device_Variable::m_szValue_set device: 35 service: urn:micasaverde-com:serviceId:ZWaveDevice1 variable: ^[[35;1mLastWakeup^[[0m was: 1415637511 now: 1415639320 #hooks: 0 upnp: 0 skip: 0 v:(nil)/NONE duplicate:0 <0x2c1da680>
06      11/10/14 21:08:41.149   Device_Variable::m_szValue_set device: 35 service: urn:micasaverde-com:serviceId:SecuritySensor1 variable: ^[[35;1mTripped^[[0m was: 0 now: 0 #hooks: 2 upnp: 0 skip: 0 v:0x9258a8/NONE duplicate:0 <0x2c1da680>
07      11/10/14 21:08:41.150   Event::Evaluate 2  scene Alarme Salon - Ouverture is false repeat 0/-1 <0x2c1da680>
07      11/10/14 21:08:41.150   Event::Evaluate 5  scene Alarme Salon - Fermeture is true users:1114645 allow:1 <0x2c1da680>
08      11/10/14 21:08:41.150   Scene::RunScene running 14 Alarme Salon - Fermeture <0x2c1da680>
06      11/10/14 21:08:41.522   Device_Variable::m_szValue_set device: 35 service: urn:micasaverde-com:serviceId:SecuritySensor1 variable: ^[[35;1mArmedTripped^[[0m was: 0 now: 0 #hooks: 0 upnp: 0 skip: 0 v:0x934b30/DL_ARMEDTRIPPED duplicate:1 <0x2c1da680>
06      11/10/14 21:08:41.523   Device_Variable::m_szValue_set device: 35 service: urn:micasaverde-com:serviceId:SecuritySensor1 variable: ^[[35;1mLastTrip^[[0m was: 1415637511 now: 1415639321 #hooks: 0 upnp: 0 skip: 0 v:0x92ccb8/NONE duplicate:0 <0x2c1da680>
04      11/10/14 21:08:41.524   <Job ID="12" Name="pollnode_wake #5 1 cmds" Device="35" Created="2014-11-10 21:08:40" Started="2014-11-10 21:08:41" Completed="2014-11-10 21:08:41" Duration="0.523849000" Runtime="0.521593000" Status="Successful" LastNote="" Node="5" NodeType="ZWaveBinarySensor" NodeDescription="D..tecteur Sal
04      11/10/14 21:08:41.620   <Job ID="13" Name="Wakeup done 5" Device="35" Created="2014-11-10 21:08:41" Started="2014-11-10 21:08:41" Completed="2014-11-10 21:08:41" Duration="0.618581000" Runtime="0.93923000" Status="Successful" LastNote="SUCCESS! Transmit was OK" Node="5" NodeType="ZWaveBinarySensor" NodeDescription="D

Offline edgebinary

  • Jr. Member
  • **
  • Posts: 72
  • Karma: +0/-0
Geminium,

I have the same issue since I upgrade to UI7 with VeraAlerts. I only get "zone/door closed messages," based on the wakeup interval setting. It definitely has to do with that. I was wondering if you made any progress with finding a solution to your issue?

Offline RexBeckett

  • Beta Testers
  • Master Member
  • *****
  • Posts: 3891
  • Karma: +483/-12
It sounds like another UI7 bug although I have seen the same behavior with some security devices under UI5.

Maybe the fastest solution is to change your Lua to ignore repeated triggers. Something like:

Code: [Select]
local status = luup.variable_get("urn:micasaverde-com:serviceId:SecuritySensor1", "Tripped", 123)
if status ~= last_status_123 then
   ... send alert
   last_status_123 = status
end

As global variables are lost during a Vera restart, this code would allow an alert from the first repeated trigger after that. You could prevent that by checking if last_status_123 was nil and sending a different message - like "Motion detected following Vera restart" or whatever helps.
« Last Edit: November 18, 2014, 08:09:19 pm by RexBeckett »

Offline edgebinary

  • Jr. Member
  • **
  • Posts: 72
  • Karma: +0/-0
Thanks for the response, Rex.

As I'm a complete Lua newbie, I have no idea what variables to even sub into your script. I'll try to play around with this and figure it out, but I'll be back with questions most likely.  :P