We have moved at community.getvera.com

Author Topic: UI7 Can't Clear Alerts in Dashboard  (Read 11956 times)

Offline HansE

  • Sr. Newbie
  • *
  • Posts: 49
  • Karma: +1/-0
UI7 Can't Clear Alerts in Dashboard
« on: November 17, 2014, 02:05:36 am »
In UI7, I have Alerts on the dashboard, but I have cleared out all of them on the Alerts page. I have cleared every Alert since I got the unit but this banner still shows up on the dashboard. How do I fix this?

Offline lolodomo

  • Beta Testers
  • Master Member
  • *****
  • Posts: 3484
  • Karma: +74/-10
Re: UI7 Can't Clear Alerts in Dashboard
« Reply #1 on: November 17, 2014, 02:56:37 am »
Yes, that is a known bug.

Offline desperado

  • Sr. Newbie
  • *
  • Posts: 29
  • Karma: +1/-0
Re: UI7 Can't Clear Alerts in Dashboard
« Reply #2 on: January 07, 2015, 03:31:45 am »
Is this still an issue ?

I added a foscam camera.  It was working fine but for some reason the dashboard displayed "Device NOT responding".  I found the cause was the added camera.

So I deleted my alerts but the message is still on my dashboard and on my android app. 

Since this was annoying I just deleted the foscam and the alert is STILL there...

Please tell me there is some way to remove this alert !


Offline rstrouse

  • Hero Member
  • *****
  • Posts: 842
  • Karma: +30/-9
Re: UI7 Can't Clear Alerts in Dashboard
« Reply #3 on: January 07, 2015, 01:37:02 pm »
These alerts are located in the /cmh/alerts.json file.  I managed to remove them once by performing surgery on this file.  It was a PITA.  It is only mildly annoying so I haven't done it again.
1xVera3 1.7.619, 4xLinear WT00Z, 3xLinear WS15Z, 1xLeviton VRCZ4, 10xCooper RF9540, 1xLeviton VRFI10, 1xLeviton VP00R, 2xLinear GD00Z-4, 1xGE/Jasco 45612, 1xGE/Jasco 45610,  4xGE/Jasco 45605, 2xYale YRD220-ZW-619, 1xCaddx NX584, Autelis Intellitouch Pool Control, OpenSprinkler

Offline desperado

  • Sr. Newbie
  • *
  • Posts: 29
  • Karma: +1/-0
Re: UI7 Can't Clear Alerts in Dashboard
« Reply #4 on: January 07, 2015, 01:43:39 pm »
I logged into my veralite yesterday as root and found that file using a find command
find . -type f -print0 | xargs -0 grep "Device NOT responding"

But it only had 2 alerts and my veralite is showing 5.  I was afraid to hack the file though.  I will try it now to see if it helps.

Thanks!!

Offline rstrouse

  • Hero Member
  • *****
  • Posts: 842
  • Karma: +30/-9
Re: UI7 Can't Clear Alerts in Dashboard
« Reply #5 on: January 07, 2015, 01:50:40 pm »
Unless this was coincidental (I may have been in scorch and burn mode) clearing them from this file removed them from my dashboard.
1xVera3 1.7.619, 4xLinear WT00Z, 3xLinear WS15Z, 1xLeviton VRCZ4, 10xCooper RF9540, 1xLeviton VRFI10, 1xLeviton VP00R, 2xLinear GD00Z-4, 1xGE/Jasco 45612, 1xGE/Jasco 45610,  4xGE/Jasco 45605, 2xYale YRD220-ZW-619, 1xCaddx NX584, Autelis Intellitouch Pool Control, OpenSprinkler

Offline hmspain

  • Hero Member
  • *****
  • Posts: 528
  • Karma: +16/-8
Re: UI7 Can't Clear Alerts in Dashboard
« Reply #6 on: January 07, 2015, 05:12:31 pm »
Is this still an issue ?

I added a foscam camera.  It was working fine but for some reason the dashboard displayed "Device NOT responding".  I found the cause was the added camera.

So I deleted my alerts but the message is still on my dashboard and on my android app. 

Since this was annoying I just deleted the foscam and the alert is STILL there...

Please tell me there is some way to remove this alert !

Dumb answer, but I didn't see it mentioned; have you tried setting "CommFailure" to "0",  do a "Poll", then "Configure", backup a screen, then "Save", then login to the web site again (at least those are my steps).  The error goes away for me.
VeraPlus, Nest Cameras (6), Siren, Hue Bulbs/Strips/Blooms (65), Fan Dimmer (6), Aeon 4-in-1s (10), Water Sensors (3), Z-Wave Switches (20), Nest Smoke/CO Protects (5), Ecobee 3, HEM Gen2s (2)

Offline jprafter

  • Sr. Newbie
  • *
  • Posts: 23
  • Karma: +0/-1
Re: UI7 Can't Clear Alerts in Dashboard
« Reply #7 on: January 07, 2015, 07:00:03 pm »
OK Now you got me, I don't see "Poll" or "Configure" anymore in UI7 on my Vera Edge, I'm in Settings, then Advanced settings, but I don't have these buttons like I had in UI5. Is there something I can do to get them back? Maybe be a stupid question, but I appreciate an answer.

Offline hmspain

  • Hero Member
  • *****
  • Posts: 528
  • Karma: +16/-8
Re: UI7 Can't Clear Alerts in Dashboard
« Reply #8 on: January 07, 2015, 07:31:12 pm »
OK Now you got me, I don't see "Poll" or "Configure" anymore in UI7 on my Vera Edge, I'm in Settings, then Advanced settings, but I don't have these buttons like I had in UI5. Is there something I can do to get them back? Maybe be a stupid question, but I appreciate an answer.

That's what I get for going from memory and not checking first; sorry.  My motion detectors (the infamous 4-in-1s) have the "Poll now" and "Configure node right now" buttons, but the Foscams do not.

The trick DOES work with Foscam cameras, just ignore the Poll and Configure steps.
VeraPlus, Nest Cameras (6), Siren, Hue Bulbs/Strips/Blooms (65), Fan Dimmer (6), Aeon 4-in-1s (10), Water Sensors (3), Z-Wave Switches (20), Nest Smoke/CO Protects (5), Ecobee 3, HEM Gen2s (2)

Offline desperado

  • Sr. Newbie
  • *
  • Posts: 29
  • Karma: +1/-0
Re: UI7 Can't Clear Alerts in Dashboard
« Reply #9 on: January 09, 2015, 01:35:45 am »
It would be nice to be able to do this through the interface.

So trying to ignore Poll and Configure but that only leaves set "CommFailure" to 0 and then save.
I don't see any CommFailure (assuming in Advanced Settings)

So not clear on what to do for UI7.

I see all the options and settings you mention on my aeon 4-in-1 but nothing for my foscam.

On a side note, does support ever reply to questions.  I have submitted 3 now with no replies for any of them.  Should I bother submitting support requests anymore ?   Starting to wish I bought the SmartThings now :(


Offline desperado

  • Sr. Newbie
  • *
  • Posts: 29
  • Karma: +1/-0
Re: UI7 Can't Clear Alerts in Dashboard
« Reply #10 on: January 09, 2015, 01:49:54 am »
When I checked my dashboard tonight there were 8 instead of 4 messages the strange part is they ALL said 2 days ago.   So how did 4 more happen 2 days ago.

So I ran my find command again and found the following two jason files.
/etc/cmh/alerts.json
/overlay/etc/cmh/alerts.json

I backed up the /etc/cmh/alerts.json file just in case and hacked it to the following text
{ "alerts": [ ] }

The overlay file changed as well when I did this.

This made 4 of the 8 messages disappear but 4 remained.

I decided I wanted to reboot the device but I found no way to do this.  Google search returned method to reboot for UI4 and UI5 but not UI7.

I looked for a button on the device and realized I had no idea what the +, - and battery image buttons did on the device.

So I yanked the plug expecting it not to work since batteries were installed but it shut off.  Then when I plugged it back in it rebooted.   Is this how you reboot?  What are the batteries for ?

Anyway reboot worked.

So hack process is
- change  /etc/cmh/alerts.json to read only  { "alerts": [ ] }
- yank plug
 be happy....

I went on step further and just created an alias to do this in root .profile
alias clearalerts='echo "{ \"alerts\": [ ] }" > /etc/cmh/alerts.json;reboot'


But I really want a software way to do this :(
« Last Edit: January 09, 2015, 02:12:51 am by desperado »

Offline hmspain

  • Hero Member
  • *****
  • Posts: 528
  • Karma: +16/-8
Re: UI7 Can't Clear Alerts in Dashboard
« Reply #11 on: January 09, 2015, 10:49:09 am »
I went on step further and just created an alias to do this in root .profile
alias clearalerts='echo "{ \"alerts\": [ ] }" > /etc/cmh/alerts.json;reboot'

Kudos for the heavy handed work around, impressive!
VeraPlus, Nest Cameras (6), Siren, Hue Bulbs/Strips/Blooms (65), Fan Dimmer (6), Aeon 4-in-1s (10), Water Sensors (3), Z-Wave Switches (20), Nest Smoke/CO Protects (5), Ecobee 3, HEM Gen2s (2)

Offline desperado

  • Sr. Newbie
  • *
  • Posts: 29
  • Karma: +1/-0
Re: UI7 Can't Clear Alerts in Dashboard
« Reply #12 on: January 09, 2015, 11:33:47 am »
LOL, thanks.  Not sure it is worth it.  I have a stack of alerts from my 4in1 again this morning.  It seems to fail to respond every hour.   I think I should just ignore alerts and perhaps return the 4in1.

Offline rstrouse

  • Hero Member
  • *****
  • Posts: 842
  • Karma: +30/-9
Re: UI7 Can't Clear Alerts in Dashboard
« Reply #13 on: January 09, 2015, 12:06:12 pm »
LOL, thanks.  Not sure it is worth it.  I have a stack of alerts from my 4in1 again this morning.  It seems to fail to respond every hour.   I think I should just ignore alerts and perhaps return the 4in1.

Yeah I finally came to that conclusion as well.  I do believe that the uncommitted errors do clear after luup is reloaded though.
1xVera3 1.7.619, 4xLinear WT00Z, 3xLinear WS15Z, 1xLeviton VRCZ4, 10xCooper RF9540, 1xLeviton VRFI10, 1xLeviton VP00R, 2xLinear GD00Z-4, 1xGE/Jasco 45612, 1xGE/Jasco 45610,  4xGE/Jasco 45605, 2xYale YRD220-ZW-619, 1xCaddx NX584, Autelis Intellitouch Pool Control, OpenSprinkler

Offline desperado

  • Sr. Newbie
  • *
  • Posts: 29
  • Karma: +1/-0
Re: UI7 Can't Clear Alerts in Dashboard
« Reply #14 on: January 09, 2015, 01:48:13 pm »
Dumb answer, but I didn't see it mentioned; have you tried setting "CommFailure" to "0",  do a "Poll", then "Configure", backup a screen, then "Save", then login to the web site again (at least those are my steps).  The error goes away for me.

I found that most of my newer messages are actually coming from the aeon 4-in-1.  So I tried these steps.  They clear the error on the device but the dashboard still displays all the alert messages.  There is apparently no way to clear these alerts.  Which in essence makes them useless because the only option is to learn to always ignore the stack of alerts.   I guess nobody at mios read the fable of the boy who cried wolf :)