Author Topic: DLNA Media Controller plugin - version 1.3 released  (Read 4475 times)

Offline lolodomo

  • Moderator
  • Master Member
  • *****
  • Posts: 3484
  • Karma: +74/-10
DLNA Media Controller plugin - version 1.3 released
« on: December 27, 2014, 05:06:09 pm »
Version 1.3 is released.

You can download it here (ZIP archive at the bottom of this page): http://code.mios.com/trac/mios_dlna-cntroller/browser/tags/1.3

This version will be available in the MiOS app store in few days.


What's new in version 1.3:

  • New setting to update the Google TTS URL
  • TTS tab: add Dutch, German and Portugese as predefined languages
  • TTS fix: text with "+" instead of space when TTS was called by a third-party tool
  • return added for actions that run in a job
  • UPnP discovery: filter unexpected devices
« Last Edit: December 28, 2014, 04:21:49 am by lolodomo »

Offline lolodomo

  • Moderator
  • Master Member
  • *****
  • Posts: 3484
  • Karma: +74/-10
Re: DLNA Media Controller plugin - version 1.3 released
« Reply #1 on: December 27, 2014, 06:10:33 pm »
This version is now in state "pending approval" in the marletplace.

Offline lolodomo

  • Moderator
  • Master Member
  • *****
  • Posts: 3484
  • Karma: +74/-10
Re: DLNA Media Controller plugin - version 1.3 released
« Reply #2 on: January 06, 2015, 12:49:38 am »
Version now available in the marketplace.

Offline rvendrame

  • Sr. Newbie
  • *
  • Posts: 37
  • Karma: +1/-0
Re: DLNA Media Controller plugin - version 1.3 released
« Reply #3 on: February 25, 2015, 08:56:29 am »
Hello lolodomo,

Despite many tries, I still not able to control my Denon receiver AVR-300 (DLNA 1.5 certified) --- only Mute function works from DLNA (perfectly, by the way).  Everything else (PLAY, TTS, etc) don't.  I don't see any error message, just simply it ignores my commands.  Your plug works fine with other DLNA devices that I have (thank you BTW!), so it must be something at the Denon side.

 Is there anything that I can do to troubleshot it?  Below is the contents of the 'Help' tab of my DLNA instance, having the Denon selected as player.  I have already tried delete and re-install,  disabled 'secure my vera' ,  no lucky.


Thanks!
rvendrame

Plugin version:
1.3
DMS description URL:
http://192.168.1.160:32469/DeviceDescription.xml
Last server media played:
40840ee3e81f6f5fbcaa-1
Selected protocol:
AUTO
[/size][/size][/color]
Variable
Value
AVTransportURI
AVTransportURIMetaData
CurrentTrackURI
CurrentTrackMetaData
SinkProtocolInfo
http-get:*:audio/L16;rate=44100;channels=1:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;rate=44100;channels=2:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;rate=48000;channels=1:DLNA.ORG_PN=LPCM,http-get:*:audio/L16;rate=48000;channels=2:DLNA.ORG_PN=LPCM,http-get:*:audio/mpeg:DLNA.ORG_PN=MP3,http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMABASE,http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMAFULL,http-get:*:audio/mp4:DLNA.ORG_PN=AAC_ISO,http-get:*:audio/3gpp:DLNA.ORG_PN=AAC_ISO,http-wavetunes:*:audio/x-ms-wma:*,http-get:*:audio/wav:*,http-get:*:audio/x-wav:*,http-get:*:audio/flac:*,http-get:*:audio/x-flac:*,http-get:*:audio/x-m4a:*,http-get:*:audio/x-mp4:*,http-get:*:image/jpeg:*


Offline lolodomo

  • Moderator
  • Master Member
  • *****
  • Posts: 3484
  • Karma: +74/-10
Re: DLNA Media Controller plugin - version 1.3 released
« Reply #4 on: March 01, 2015, 06:21:19 am »
Hello lolodomo,

Despite many tries, I still not able to control my Denon receiver AVR-300 (DLNA 1.5 certified) --- only Mute function works from DLNA (perfectly, by the way).  Everything else (PLAY, TTS, etc) don't.  I don't see any error message, just simply it ignores my commands.  Your plug works fine with other DLNA devices that I have (thank you BTW!), so it must be something at the Denon side.

 Is there anything that I can do to troubleshot it?

First play a DLNA media using your Denon remote and then use the Play/Pause/Stop buttons from the Vera plugin and provide the logs at this time. If these actions are not working, I assume that you will get errors in the logs.

Offline mda

  • Sr. Member
  • ****
  • Posts: 464
  • Karma: +9/-0
Re: DLNA Media Controller plugin - version 1.3 released
« Reply #5 on: March 12, 2015, 06:30:43 pm »
@lolodomo - i am getting a luup crash once in a while (exit code 245) and MCV Tech Support says:

Quote
I took a look on the logs and from what I saw , those 2 restarts are caused by the DLNA plugin. ...

Although there is no clear indication of the causes of the crashes (Lua is crashing , not restarting), I think it might be linked to the warnings below :

02 02/26/15 0:08:56.123 luup_log:157: DLNA: warning: Call to NotifyAVTransportChange with bad SID uuid:3e005012-1dd2-11b2-8669-8c973db9f848 <0?2abbc000>

02 02/26/15 0:08:57.527 luup_log:158: DLNA: warning: Call to NotifyAVTransportChange with bad SID uuid:3dbc2e8c-1dd2-11b2-9593-85fb74a31505 <0?2abbc000>

02 02/26/15 0:09:41.550 luup_log:158: DLNA: warning: Call to NotifyAVTransportChange with bad SID uuid:b4ddc78c-1dd1-11b2-9598-85fb74a31505 <0?2b93b000>


I am not 100% sure but i think it does not happen (or not as frequently) if Debug mode is on for my DLNA devices (I have 2 DLNA devices). The crash does not happen at all if i uninstall the DLNA plug-in so i do think it is connected to the issue.

I would really appreciate any help with this, I love the plug-in.

Thanks.

Offline mda

  • Sr. Member
  • ****
  • Posts: 464
  • Karma: +9/-0
Re: DLNA Media Controller plugin - version 1.3 released
« Reply #6 on: March 18, 2015, 11:24:55 pm »
@lolodomo - luup restarted again (with DLNA debug on) right after DLNA plug-in doing something.

Attached is the log leading up to the restart. Could I trouble you to please help me solve this? Thanks !

Offline lolodomo

  • Moderator
  • Master Member
  • *****
  • Posts: 3484
  • Karma: +74/-10
Re: DLNA Media Controller plugin - version 1.3 released
« Reply #7 on: March 20, 2015, 06:39:41 pm »
I have not analyzed your logs but we know that any plugin can at a certain time triggers a luup restart. It is due to a lack of memory in the Vera and probably due to too many plugins installed in your Vera.

By the way, I would advice to not keep the debug traces because it will log a lot of information and possibily reduce your Vera stability.

Offline mda

  • Sr. Member
  • ****
  • Posts: 464
  • Karma: +9/-0
Re: DLNA Media Controller plugin - version 1.3 released
« Reply #8 on: March 20, 2015, 11:19:55 pm »
I have not analyzed your logs but we know that any plugin can at a certain time triggers a luup restart. It is due to a lack of memory in the Vera and probably due to too many plugins installed in your Vera.

By the way, I would advice to not keep the debug traces because it will log a lot of information and possibily reduce your Vera stability.

Yes, thanks. I have turned off Debug. I do check Top often on my vera 3/UI 5 and it tends to hover around 95m used with 30m of that being for cache (which of course fluctuates a big with cache flushing). For example, right now it is showing the following (which is typical and I think healthy?):

Code: [Select]
Mem: 95332K used, 32124K free, 0K shrd, 15920K buff, 31328K cached
and

Code: [Select]
22644  2381 root     S     126m 101%   1% /usr/bin/LuaUPnP
If you can find the time to look at the logs I would very much appreciate it. Thanks for your help!

Offline mda

  • Sr. Member
  • ****
  • Posts: 464
  • Karma: +9/-0
Re: DLNA Media Controller plugin - version 1.3 released
« Reply #9 on: March 21, 2015, 07:48:01 pm »
I do think it happens when I have 2 or more DLNA devices... Perhaps that might narrow down the issue? Thanks.

Offline aalmans

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
Re: DLNA Media Controller plugin - version 1.3 released
« Reply #10 on: April 23, 2015, 09:00:35 am »
Any update on this by any chance? I have the same issue...

Offline mda

  • Sr. Member
  • ****
  • Posts: 464
  • Karma: +9/-0
Re: DLNA Media Controller plugin - version 1.3 released
« Reply #11 on: April 24, 2015, 11:43:14 am »
I don't think lolodomo has had time to figure it out. Luup is still crashing for me once or twice a day sadly.