Author Topic: foscam fi8910w with vera lite U7  (Read 4761 times)

Offline ras81

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
foscam fi8910w with vera lite U7
« on: January 04, 2015, 01:25:10 pm »
hello,
i went threw a lot of threads and still i can't controll my cam tilt/pan.
can any1 help me plzzzzz

here are my settings:
device file: D_DigitalSecurityCamera2.xml
imp_file: I_FoscamPTZ.xml
URL: /snapshot.cgi?user=[USER]&Pwd=[PASS]
commands: camera_full_screen,camera_left,camera_right,camera_up,camera_down,camera_preset,camera_archive_snapshot,camera_zoom_in,camera_zoom_out

Offline krusemarks

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
Re: foscam fi8910w with vera lite U7
« Reply #1 on: January 17, 2015, 12:47:55 pm »
Bump for another user with the same issue.  No resolution.  I can get the static image, and by changing the commands I could get the control arrows to show up in UI7, but they don't work (no camera response, no errors on screen).

Offline infromatica

  • Sr. Newbie
  • *
  • Posts: 35
  • Karma: +0/-0
Re: foscam fi8910w with vera lite U7
« Reply #2 on: January 25, 2015, 09:55:18 am »
same problem with a FI8918W

Offline mht

  • Jr. Member
  • **
  • Posts: 69
  • Karma: +2/-1
Re: foscam fi8910w with vera lite U7
« Reply #3 on: January 25, 2015, 03:01:03 pm »
I have a similar problem with my D-link camera. Without knowing your camera and impl file here is my thoughts and findings...

After many hours trying to solve my problems I used Wireshark to see what my Vera UI7 acctually sends to the camera. I found that no authentication is passed by the luup command used in the impl file to send commands to the camera (luup.inet.wget).

If your camera accepts username and password passed as arguments in the URL, you may be able to create a workaround by modify the impl file. Sadly my D-link doesn't :-[

Right now I am waiting for respons from Vera support about my findings.

Update January 30:
Today I recieved an email from Vera support: My colleagues from the development have acknowledged that there is indeed a bug in the current firmware. Since the January release is already to be released on Monday, they cannot include the fix in this build, however, it will be included in the February release.
« Last Edit: January 30, 2015, 02:45:46 pm by mht »

Offline subtroll

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Re: foscam fi8910w with vera lite U7
« Reply #4 on: January 28, 2015, 10:52:45 am »
My VistaCam PT seems to work OK when cable connected to my router, except that I can not stop the pan/tilt at any point between the physical limits, i.e. press blue arrows and it moves in that direction but I can't stop/pause it in any intermediate position.

My bigger problem is getting it to work wirelessly. I've gone through the Support Center product "Make VisaCam PT Work Wirelessly" dtd Apr 28, 2013 twice and after I disconnect the cat 5 cable my Vera Lite control Dashboard says "camera not responding" and I receive no video.   My new Netgear N450 cable modem/router has multiple ports blocked. Can anyone tell me what ports the camera requires?
 Imac w/ OS 10.10.1, Vera lite

Marc Shenker

  • Guest
Re: foscam fi8910w with vera lite U7
« Reply #5 on: January 28, 2015, 11:45:43 am »
My VistaCam PT seems to work OK when cable connected to my router, except that I can not stop the pan/tilt at any point between the physical limits, i.e. press blue arrows and it moves in that direction but I can't stop/pause it in any intermediate position.

My bigger problem is getting it to work wirelessly. I've gone through the Support Center product "Make VisaCam PT Work Wirelessly" dtd Apr 28, 2013 twice and after I disconnect the cat 5 cable my Vera Lite control Dashboard says "camera not responding" and I receive no video.   My new Netgear N450 cable modem/router has multiple ports blocked. Can anyone tell me what ports the camera requires?
 Imac w/ OS 10.10.1, Vera lite

subtroll, I created a support ticket for you and prioritized it, you should hear from someone shortly. 

Offline mht

  • Jr. Member
  • **
  • Posts: 69
  • Karma: +2/-1
Re: foscam fi8910w with vera lite U7
« Reply #6 on: January 28, 2015, 03:41:53 pm »
Subtroll:

Regarding your pan/tilt problems, have you tried the VistaCam PT&HD IP camera plugin http://code.mios.com/trac/mios_foscam-camera#no1 ?

The plugin seems to have solved the issue by sending a pan command followed by a stop command.

Code: [Select]
1740             <name>MoveRight</name>
1741             <job>
1742                 if lug_p2p == "0" then
1743                     local command = (lug_reversePan == "0") and URLS[lug_model].PAN_RIGHT or URLS[lug_model].PAN_LEFT
1744                     luup.inet.wget(command, WGET_TIMEOUT)
1745                 else
1746                     local command = (lug_reversePan == "0") and URLS[lug_model].PAN_RIGHT or URLS[lug_model].PAN_LEFT
1747                     luup.inet.wget(command, WGET_TIMEOUT)
1748                     luup.sleep(PAN_TILT_SLEEP)
1749                     luup.inet.wget(URLS[lug_model].STOP, WGET_TIMEOUT)
1750                 end
1751             </job>

Offline chargernut69

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
Re: foscam fi8910w with vera lite U7
« Reply #7 on: January 29, 2015, 02:03:14 pm »
UI7 is almost impossible to figure out when installing a webcam --  still can't get my Foscam's to work yet either !   --   FI9805W, FI8919W, FI8918W    --     Let me try the VistaCam APP, since Foscom APP does not work....

Marc Shenker

  • Guest
Re: foscam fi8910w with vera lite U7
« Reply #8 on: January 30, 2015, 03:11:54 pm »
UI7 is almost impossible to figure out when installing a webcam --  still can't get my Foscam's to work yet either !   --   FI9805W, FI8919W, FI8918W    --     Let me try the VistaCam APP, since Foscom APP does not work....

In this video I give instructions on how to get basic video from most cameras. Some cameras are easy some are not. It is all in how the manufacturer sets them up. Let me know if it helps or not.

https://www.youtube.com/watch?v=Ja9urIg8LoA

Offline tylerh

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: foscam fi8910w with vera lite U7
« Reply #9 on: February 02, 2015, 08:32:51 pm »
Ive gotten my 8910W IP camera added to my Vera3.  In the web ui7, I see my image just fine.

In my Android App, my camera shows an image of Invalid Camera URL, although it shows up just fine and updates in the web UI

The same URL used for vera is the same URL I use for my DVR/NVR software.

Marc Shenker

  • Guest
Re: foscam fi8910w with vera lite U7
« Reply #10 on: February 03, 2015, 12:23:01 pm »
Tyler, not sure why it is. I submitted a support ticket for you, you should hear from them shortly.

Offline pleadwell

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: foscam fi8910w with vera lite U7
« Reply #11 on: February 20, 2015, 12:22:42 pm »
Hi can i get added to the ticket - I've 3 FI8910 cameras on firmware: 1.7.513 and the latest firmware on my cameras.  Pan/Tilt no longer works after a recent firmware upgrade although I can get an image. Any suggestions appreciated. 

Offline ohecht

  • Sr. Newbie
  • *
  • Posts: 24
  • Karma: +0/-0
Re: foscam fi8910w with vera lite U7
« Reply #12 on: December 15, 2017, 07:18:54 pm »
Sorry to revive such an old thread, but I'm having this same problem after recently upgrading to VeraPlus.  There are some mentions here about fixing this known bug in an "upcoming release", but that was about two years ago.  Is it possible this hasn't been fixed in that long?  Can anyone point me to the instructions to get these cameras to pan and tilt again if it has been solved?  Thanks in advance.  Olivier