Author Topic: Not getting data from weather underground  (Read 6012 times)

Offline breedm

  • Newbie
  • *
  • Posts: 7
  • Karma: +1/-0
Re: Not getting data from weather underground
« Reply #15 on: June 01, 2015, 04:46:21 pm »
See this post: http://forum.micasaverde.com/index.php/topic,31328.msg228961.html#msg228961

Check/update your settings in Setup > Location.

Offline Scoutmedic

  • Jr. Member
  • **
  • Posts: 78
  • Karma: +2/-1
Re: Not getting data from weather underground
« Reply #16 on: August 12, 2015, 08:57:38 pm »
I realize that this post is 2 months old, but I battled for several days trying to get this darn app to work. Being a newb and this my first app contributed to my ignorance when it comes to setting things up.

I logged in to Weather Underground (WU), navigated to the web developer API link, and signed up for  free account. I copied the 16 digit key for later use. I backed out and made sure Weather Underground knew where my home city was. I also searched for the nearest personal weather station (pws) to me and jotted down its station ID number.

In Vera UI7, I verified my location settings were correct. I opened the app, clicked on details, and selected the device. I went to settings, copy/pasted my API key into the provider key space, and clicked on set. For the location, I entered "pws:XXXXXXXXX", where XXX was the weather station ID from WU, and clicked set. I also set the polling for 900 so it would update every 15 min.

With these things figured out, I was able to get the plugin to work.

Offline DeltaNu1142

  • Hero Member
  • *****
  • Posts: 1148
  • Karma: +40/-67
Re: Not getting data from weather underground
« Reply #17 on: December 23, 2015, 07:23:42 am »
Exhuming this thread to express thanks to @Scoutmedic. I installed this plugin yesterday & it wasn't updating, but following the steps in your post got it up & running.
Vera 3 @ UI5 | HomeWave | PLEG

Offline gniknalu

  • Full Member
  • ***
  • Posts: 167
  • Karma: +3/-2
Re: Not getting data from weather underground
« Reply #18 on: June 13, 2017, 03:06:34 pm »
I realize that this post is 2 months old, but I battled for several days trying to get this darn app to work. Being a newb and this my first app contributed to my ignorance when it comes to setting things up.

I logged in to Weather Underground (WU), navigated to the web developer API link, and signed up for  free account. I copied the 16 digit key for later use. I backed out and made sure Weather Underground knew where my home city was. I also searched for the nearest personal weather station (pws) to me and jotted down its station ID number.

In Vera UI7, I verified my location settings were correct. I opened the app, clicked on details, and selected the device. I went to settings, copy/pasted my API key into the provider key space, and clicked on set. For the location, I entered "pws:XXXXXXXXX", where XXX was the weather station ID from WU, and clicked set. I also set the polling for 900 so it would update every 15 min.

With these things figured out, I was able to get the plugin to work.

I couldn't get it to update or even look decent in UI7. Prior to your post, I tried the same things but it still isn't usable. . . .

Offline Don Phillips

  • Hero Member
  • *****
  • Posts: 1289
  • Karma: +33/-32
Re: Not getting data from weather underground
« Reply #19 on: June 13, 2017, 08:11:17 pm »
The real value in this plug-in is integrating it with PLEG to give you even more control.  For instance, I use conditions to turn on/off the exterior lights.  If clear, on at sunset, off at sunrise.  If overcast, on 15 min before sunset, and off 15 min after sunset. Rain, 30 minutes. Otherwise, if I need to see the conditions, I look out the window  ;D

Edit: I forgot I also use the exterior temperature to switch heating/cooling mode. If outside temp < 60, switch to heat. If > 65, switch to cool. Because the weather station is less than a mile from my house, it is (slightly) more accurate than the MIOS temperature, which is probably measured at the airport about 15 miles away.
« Last Edit: June 13, 2017, 08:13:34 pm by Don Phillips »
Vera 3, 1.7.1030, CT101 t-stat, Everspring motion detector, GE/Jasco switch, Leviton outlet, AeonLabs sensor, NuTone garage door, Blue Iris, Sricam SP011, iPhone locator, APCUPSD, VeraMate, VeraAlerts, PLEG, House Modes, Countdown Timer, DVR, Virtual/Multi Switch, Weatherunderground, LB60Z-1 bulb