Author Topic: PLUGIN: Honeywell Total Connect Comfort Thermostats  (Read 165055 times)

Offline ranneman

  • Full Member
  • ***
  • Posts: 140
  • Karma: +7/-0
Re: PLUGIN: Honeywell Total Connect Comfort Thermostats
« Reply #720 on: October 02, 2017, 03:10:55 pm »
Yup, still works for me (evohome Europe). And if it stops working I expect/hope I can switch to ITTT.
Vera lite UI7 Europe, Vera Plus, Zwave.me switches/dimmers, Zwave.me plus multi switch, Fibaro switches and multi sensors, Everspring sensors motion, temp., humidity. Honeywell Evohome, Greenwave, Sonos, Brel shades, RFXCOM, MiLights, Alexa.

Offline curtm

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
Re: PLUGIN: Honeywell Total Connect Comfort Thermostats
« Reply #721 on: October 17, 2017, 05:35:16 pm »
Trying to use some Luup code for the first time, and not getting any result...

here is what i have...
Code: [Select]
local lul_arguments = {}
lul_arguments["ThermostatID"] = 2838483
lul_arguments["NewMode"] = "ContinuousOn"

   
luup.call_action("urn:upnp-org:serviceId:HVAC_FanOperatingMode1","HoldSetpoint",lul_arguments,33)

I have a VeraSecure and go to Apps/Develop Apps/Test Luup Code
and type the code above in, click GO and it shows a box saying "SUCCESS / Code sent successfully",
yet I dont see any changes to my HVAC Fan setting.

I'm trying to use the Luup code in a scene where if my humidity sensor gets above 50%, the HVAC units turn on the fan to circulate the air.

Does the Test Luup actually submit commands or just tell you if it would work if submitted in an actual scene?

thanks!

Offline curtm

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
Re: PLUGIN: Honeywell Total Connect Comfort Thermostats
« Reply #722 on: October 18, 2017, 11:28:10 pm »
I found out how to do this using the advanced editor and i know im doing it right because i can change the temp, mode (heat,cool) but the fan does not respond to this. Then i tried controlling the fan through the device UI and it does not work either. I can select Fan On and then wait a few minutes and it goes back to Fan Auto on its own.  Any where I should look?

Offline Nameless

  • Full Member
  • ***
  • Posts: 179
  • Karma: +3/-0
Re: PLUGIN: Honeywell Total Connect Comfort Thermostats
« Reply #723 on: October 19, 2017, 11:45:00 pm »
I found out how to do this using the advanced editor and i know im doing it right because i can change the temp, mode (heat,cool) but the fan does not respond to this. Then i tried controlling the fan through the device UI and it does not work either. I can select Fan On and then wait a few minutes and it goes back to Fan Auto on its own.  Any where I should look?

If you haven't already, go to post #683 in this thread. There is an updated file that never made it into the app/plugin marketplace. Without it, your Luup will tell you it's working, but won't. Fan control wasn't originally built into the plugin for that type of request.

After installing this file, try your Luup in the test and it'll likely work after a short delay. I use a scene with Luup to turn on PeriodicOn mode when the outdoor temperature hits a certain point to help circulate air from my cool basement to my other 2 floors.

Let us know how it turns out.

Offline curtm

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
Re: PLUGIN: Honeywell Total Connect Comfort Thermostats
« Reply #724 on: October 21, 2017, 11:35:21 pm »
worked perfectly!

thank you!

Offline kamakazie2

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Re: PLUGIN: Honeywell Total Connect Comfort Thermostats
« Reply #725 on: October 30, 2017, 10:07:57 pm »
Hi everyone.. love this plugin.. been using this  forever

I just installed the fan control fix. i noticed that the outdoor temp variable never populates. I get the indoor humidity,but no outdoor temp.
My unit has the outdoor sensor and it shows up just fine on the thermostat. Vera shows hasoutdoortemperature = true.




Offline Nameless

  • Full Member
  • ***
  • Posts: 179
  • Karma: +3/-0
Re: PLUGIN: Honeywell Total Connect Comfort Thermostats
« Reply #726 on: October 30, 2017, 11:15:20 pm »
Hi everyone.. love this plugin.. been using this  forever

I just installed the fan control fix. i noticed that the outdoor temp variable never populates. I get the indoor humidity,but no outdoor temp.
My unit has the outdoor sensor and it shows up just fine on the thermostat. Vera shows hasoutdoortemperature = true.

I, too, have the outdoor temperature sensor with the same result as you. It would be great if Vera could display this, but it must not have been added into the plugin, much like fan control originally. Unfortunately, I don't think this great plugin is supported by anyone anymore.

Offline DavidDiskin

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Cannot get "Auto" Working
« Reply #727 on: November 22, 2017, 06:33:27 pm »
Hello. I have installed the plugin and it's mostly working just fine. I can change modes between off, heat, and cool. I can set the target temp. I can create scenes that do this, too.

However, changing the mode to "Auto" has no effect. It thinks about it and then immediately returns to whatever mode it was previously on as if the command was ignored. This happens in scenes and in the interface (UI7).

Does this work for others?

My goal was to create a pair of scenes that, when triggered by the opening/closing of windows/doors, the thermostat will switch between Off and Auto.

Offline Nameless

  • Full Member
  • ***
  • Posts: 179
  • Karma: +3/-0
Re: Cannot get "Auto" Working
« Reply #728 on: November 25, 2017, 12:18:58 am »
Hello. I have installed the plugin and it's mostly working just fine. I can change modes between off, heat, and cool. I can set the target temp. I can create scenes that do this, too.

However, changing the mode to "Auto" has no effect. It thinks about it and then immediately returns to whatever mode it was previously on as if the command was ignored. This happens in scenes and in the interface (UI7).

Does this work for others?

My goal was to create a pair of scenes that, when triggered by the opening/closing of windows/doors, the thermostat will switch between Off and Auto.

Go to post #683 in this thread. There is an updated file that never made it into the app/plugin marketplace. Fan control wasn't originally built into the plugin for that type of request. Download and install that file, refresh your browser to restart Luup and you should be golden.

Offline knuppel

  • Sr. Newbie
  • *
  • Posts: 22
  • Karma: +0/-0
Re: PLUGIN: Honeywell Total Connect Comfort Thermostats
« Reply #729 on: January 22, 2018, 04:19:27 am »
For my understanding:

Is it normal behaviour for the "SetpointEndtime" parameter to be ignored, when setting a "TEMPORARY" temperature?
When sending below command my EvoHome sets the temperature untill 'currenttime + 4 hours'. What I would like is to set a time on which the normal schedule takes over. Setting it permanent is not really an option, because when the second command doesn't come through, the heating stays on. Moreover, the CancelSetPoint command does not work when set to either "TEMPORARY" or "PERMANENT".

Code: [Select]
local lul_arguments = {}
lul_arguments["ThermostatID"] = "..."
lul_arguments["newSetpointValue"] = 12
lul_arguments["SetpointMode"] = "HEAT"
lul_arguments["SetpointType"] = "TEMPORARY"
lul_arguments["SetpointEndtime"] = "14:00"

luup.call_action("urn:joeyd-com:serviceId:HoneywellTCC1","HoldSetpoint",lul_arguments,201)

If it is normal behaviour, is there a way to change the 4 hour interval to 8 or 24 hours? That way the heating stays on untill the normal schedule takes over.
The heating is normally off (set to 12 degrees Celsius), when we are at home I want to set it with the Vera, but 4 hours is too short.
« Last Edit: January 22, 2018, 04:40:42 am by knuppel »

Offline cohibafan

  • Jr. Member
  • **
  • Posts: 57
  • Karma: +0/-0
Re: PLUGIN: Honeywell Total Connect Comfort Thermostats
« Reply #730 on: February 11, 2018, 12:11:47 am »
Is there a way to use a scene to turn on the fan? Running firmware 1.7.35 on UI7 (I believe). The GUI gives me fan control when I click the arrow to the right, but when I create a scene I can only control the temp. I do have the latest code from post 683
Thanks in advance!

Offline rigpapa

  • Hero Member
  • *****
  • Posts: 625
  • Karma: +92/-1
Re: PLUGIN: Honeywell Total Connect Comfort Thermostats
« Reply #731 on: February 11, 2018, 08:36:54 am »
I haven't looked the plugin code, but the "standard" way of doing this would be to invoke the SetMode action in the urn:upnp-org:serviceId:HVAC_FanOperatingMode1 service with the NewMode parameter set to ContinuousOn.

Try this Lua stub in Apps > Develop apps > Test Luup code. You'll need to provide the device number of your thermostat:

luup.call_action( "urn:upnp-org:serviceId:HVAC_FanOperatingMode1", "SetMode", { NewMode="ContinuousOn" }, thermostat-device-number )

Type carefully; capitalizations matter here. If it turns on your fan, you can put that in scene Lua. To turn the fan back off, change ContinuousOn to Auto in the above.

If that doesn't work, a review of the plugin files will reveal how the UI is doing it. Let me know if it doesn't work and I'll take a peek.
« Last Edit: February 11, 2018, 08:39:06 am by rigpapa »
Author of Reactor, DelayLight, SiteSensor, Rachio, Deus Ex Machina II, Intesis WMP Gateway, Auto Virtual Thermostat and VirtualSensor plugins. Vera Plus w/100+ Z-wave devices. Vera3 sandbox.

Offline cohibafan

  • Jr. Member
  • **
  • Posts: 57
  • Karma: +0/-0
Re: PLUGIN: Honeywell Total Connect Comfort Thermostats
« Reply #732 on: February 11, 2018, 11:25:08 am »
Thanks for the quick reply!
I tried the lua code, but no luck. I wasn't sure of the HVAC ID, so I tired every number I could find in the advanced section. I received a "Failed to test code, please try again" each time.
I wonder why I have the option to see and trigger the fan in the device, but that I cannot access that same function when creating a scene.

Offline rigpapa

  • Hero Member
  • *****
  • Posts: 625
  • Karma: +92/-1
Re: PLUGIN: Honeywell Total Connect Comfort Thermostats
« Reply #733 on: February 11, 2018, 12:05:51 pm »
That's usually an indication that you fat-fingered something. For the device number, if you go into Advanced for the device, it's at the top in big green numbers, over the tabs.
Author of Reactor, DelayLight, SiteSensor, Rachio, Deus Ex Machina II, Intesis WMP Gateway, Auto Virtual Thermostat and VirtualSensor plugins. Vera Plus w/100+ Z-wave devices. Vera3 sandbox.

Offline cohibafan

  • Jr. Member
  • **
  • Posts: 57
  • Karma: +0/-0
Re: PLUGIN: Honeywell Total Connect Comfort Thermostats
« Reply #734 on: February 11, 2018, 12:09:37 pm »
My poor fingers - they'll never recover from such verbal abuse ;)

luup.call_action( "urn:upnp-org:serviceId:HVAC_FanOperatingMode1", "SetMode", { NewMode="ContinuousOn" }, 50)

I used copy and paste. Do you see anything incorrect?