We have moved at community.getvera.com

Author Topic: Devolo Door/Window Contact MT 02648 ERRORS ***SOLVED***  (Read 1021 times)

deejc

  • Guest
Devolo Door/Window Contact MT 02648 ERRORS ***SOLVED***
« on: March 26, 2016, 04:16:26 pm »
can anyone help with the reason my new Devolo home Control Door/Window Contact MT 02648 wont show the door as open when the senor is actually tripped ?
http://products.z-wavealliance.org/MarketCertification/File?folder=&filename=MarketCertificationFiles/1130/Devolo%20home%20Control%20Door-Window.pdf

i have included it as a generic zwave device, i see the Temperature Sensor, Light Sensor and Door & Window Sensor and i get entries for Lux, temp but not the door open, in the log i see

Code: [Select]
02 03/26/16 20:10:36.539 ZWaveNode::HandlePollUpdate node 10 device 275 Ignoring secure command for unsecure command class 0x8f command 0x1 m_iFrameID 932/24098136 data 0x4 0x3 0x80 0x3 0x64 0x4 0x30 0x3 0x0 0xa 0x5 0x31 0x5 0x3 0x1 0x15 0x6 0x31 0x5 0x1 0xa 0x0 0x51 (####d#0##\n#1#####1##\n#Q) <0x766c2520>
06 03/26/16 20:10:41.281 Device_Variable::m_szValue_set device: 275 service: urn:micasaverde-com:serviceId:SecuritySensor1 variable: LastTrip was: 1459023036 now: 1459023041 #hooks: 0 upnp: 0 skip: 0 v:0xc6fcc0/NONE duplicate:0 <0x766c2520>
06 03/26/16 20:10:41.282 Device_Variable::m_szValue_set device: 275 service: urn:micasaverde-com:serviceId:SecuritySensor1 variable: Tripped was: 0 now: 1 #hooks: 0 upnp: 0 skip: 0 v:0xc66f58/NONE duplicate:0 <0x766c2520>
02 03/26/16 20:10:41.431 ZWaveNode::HandlePollUpdate node 10 device 275 Ignoring secure command for unsecure command class 0x8f command 0x1 m_iFrameID 939/24352328 data 0x4 0x3 0x80 0x3 0x64 0x4 0x30 0x3 0xff 0xa 0x5 0x31 0x5 0x3 0x1 0xf 0x6 0x31 0x5 0x1 0xa 0x0 0x51 (####d#0##\n#1#####1##\n#Q) <0x766c2520>
02 03/26/16 20:10:42.159 ZWaveNode::HandlePollUpdate node 10 device 275 Ignoring secure command for unsecure command class 0x8f command 0x1 m_iFrameID 946/20227704 data 0x4 0x3 0x80 0x3 0x64 0x4 0x30 0x3 0x0 0xa 0x5 0x31 0x5 0x3 0x1 0xf 0x6 0x31 0x5 0x1 0xa 0x0 0x51 (####d#0##\n#1#####1##\n#Q) <0x766c2520>
02 03/26/16 20:10:42.281 ZWaveNode::HandlePollUpdate node 10 device 275 Ignoring unsecure command for secure command class 0x84 command 0x7 m_iFrameID 947/12757008 data  <0x766c2520>
02 03/26/16 20:10:42.465 ZWaveNode::HandlePollUpdate node 10 device 275 Ignoring secure command for unsecure command class 0x8f command 0x1 m_iFrameID 954/12939608 data 0x4 0x3 0x80 0x3 0x64 0x4 0x30 0x3 0xff 0xa 0x5 0x31 0x5 0x3 0x1 0xd 0x6 0x31 0x5 0x1 0xa 0x0 0x51 (####d#0##\n#1###\r#1##\n#Q) <0x766c2520>
06 03/26/16 20:11:13.741 Device_Variable::m_szValue_set device: 275 service: urn:micasaverde-com:serviceId:SecuritySensor1 variable: LastTrip was: 1459023041 now: 1459023073 #hooks: 0 upnp: 0 skip: 0 v:0xc6fcc0/NONE duplicate:0 <0x766c2520>
06 03/26/16 20:11:13.742 Device_Variable::m_szValue_set device: 275 service: urn:micasaverde-com:serviceId:SecuritySensor1 variable: Tripped was: 1 now: 0 #hooks: 0 upnp: 0 skip: 0 v:0xc66f58/NONE duplicate:0 <0x766c2520>
« Last Edit: April 05, 2016, 03:43:58 pm by deejc »

deejc

  • Guest
Re: Devolo Door/Window Contact MT 02648 ***SOLVED****
« Reply #1 on: April 05, 2016, 03:43:34 pm »
if you need to configure this :

Vera creates 4 devices, Lux, Temp and Door and Generic device.. so by setting

Generic Z-wave device :
all data 1 byte dec
Var 5 - Value 16 which equals binary 00010000 and this is Bit3: Setting the temperature scale 1:Celsius

Var 7 - Value 54  which equals binary 00110110 and this is Bit2: Enable PIR super sensitivity
mode (this sensor doesnt have PIR but tis the default), Bit3: Enable don't send out BASIC OFF after door closed, Bit5: Disable Multi CC in auto report, Bit6: Disable to report battery state when the device triggered.
then making it wake up a few times by hitting the tamper button 3 times over and over..

it now works correctly, variable settings are available on the link in my post above if you want to know what they do.

EDIT : i changed the settings slightly and now it seems to perform better and i no longer get the "Cannot detect device"
« Last Edit: April 09, 2016, 05:21:30 am by deejc »