We have moved at community.getvera.com

Author Topic: Rainforest Automation Eagle ZigBee Smart Meter HAN Gateway Plugin  (Read 42798 times)

Offline jswim788

  • Hero Member
  • *****
  • Posts: 809
  • Karma: +58/-2
Re: Rainforest Automation Eagle ZigBee Smart Meter HAN Gateway Plugin
« Reply #135 on: July 18, 2018, 04:59:20 pm »
Any chance that file got corrupted somehow?  I believe the error message is saying that line 7 has a '<', but it doesn't have that in the source code near line 7.  I suggest downloading the entire set of code from the green button here (https://github.com/jswim788/rainforest-eagle-vera), then getting the specific file.

If that doesn't work, let me know and we can work on this further.

Offline rklass

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: Rainforest Automation Eagle ZigBee Smart Meter HAN Gateway Plugin
« Reply #136 on: July 18, 2018, 07:11:38 pm »
Thanks, it appears to be working now!
Sorry, the issue was pretty much my fault, but I'm too embarrassed to explain...


Offline wilme2

  • Hero Member
  • *****
  • Posts: 1302
  • Karma: +33/-13
Re: Rainforest Automation Eagle ZigBee Smart Meter HAN Gateway Plugin
« Reply #137 on: March 07, 2019, 01:10:59 pm »
My Eagle 100 may be dead.  It dropped the meter connection a few weeks ago, and I can't get it to reconnect.  Even Oncor's HAN team has looked at the meter, and everything looks good there.

Is the Eagle 200 working well with the latest revision from jswim788?    http://forum.micasaverde.com/index.php/topic,79863.0.html  I bought my father a Eagle 200 a year or two back, and he had a lot of problems with it.  So trying to decide whether to bother buying another Eagle or go a different route...
Long Live UI5!  (OK finally made the switch to UI7 in January 2018, and am pretty happy....)

Offline jswim788

  • Hero Member
  • *****
  • Posts: 809
  • Karma: +58/-2
Re: Rainforest Automation Eagle ZigBee Smart Meter HAN Gateway Plugin
« Reply #138 on: March 07, 2019, 02:18:57 pm »
I had a few initial issues with the Eagle 200, but with their latest firmware it's been very good with no issues.  The biggest problem recently was that my utility replaced my electric meter without telling me.  This meant that the Eagle had to be reconnected, but Rainforest and I didn't know that.  I kept trying to get the Eagle closer to the meter and rebooting and so on.  Finally we realized it was a brand new meter, re-paired it, and all is good.

But I have to tell you that I do not have UI7, so it is impossible for me to test with that version.  I can only rely on users of the plugin providing feedback with logs if there is any issue and it may be slow to resolve.  I will try to help as much as I can.

Offline wilme2

  • Hero Member
  • *****
  • Posts: 1302
  • Karma: +33/-13
Re: Rainforest Automation Eagle ZigBee Smart Meter HAN Gateway Plugin
« Reply #139 on: March 12, 2019, 03:02:59 pm »
Took a full reboot of the meter by Oncor and back in service.
Long Live UI5!  (OK finally made the switch to UI7 in January 2018, and am pretty happy....)