We have moved at community.getvera.com

Author Topic: RFXtrx433 ===> Vera plugin vs openHAB binding  (Read 2424 times)

Offline lolodomo

  • Beta Testers
  • Master Member
  • *****
  • Posts: 3484
  • Karma: +74/-10
RFXtrx433 ===> Vera plugin vs openHAB binding
« on: March 28, 2015, 11:47:13 am »
Are you using the RFXCOM binding ? No problem with it ?

Pros and cons for toth ?



I tested the RFXCOM binding this morning and apparently it works well. No problem to install it. I am only using Oregon Scientific temperature / humidity sensors.

The automatic device creation by the Vera plugin is in my opinion an enormous advantage. For the RFXCOM binding, you will have to use first another application to find what are the device ids. And of course, you will have to delcare new items. I have not yet started OH in debug mode, does the binding logs useful information (received messages and ids) ?

Another advantage of the RFXtrx plugin is that it supports more protocols than the RFXCOM binding, even if we already have the main protocols supported by the RFXCOM binding.

And the Vera plugin provides an UI to setup what are the protocols you want to receive.

In fact, I see only advantages for the Vera plugin, but I am certainly not the right person to give an objective opinion ;D

But the RFXCOM binding is doing its job well ... and OH is never reloading ;D That being said, I will check if the RFXCOM binding is not introducing instability in OH.
« Last Edit: March 28, 2015, 11:56:22 am by lolodomo »

Offline jdr0berts

  • Newbie
  • *
  • Posts: 15
  • Karma: +0/-0
Re: RFXtrx433 ===> Vera plugin vs openHAB binding
« Reply #1 on: March 29, 2015, 07:22:15 am »
Hi there,

I'll watch this thread with interest, having battled my way into openhab over the last couple of weeks, I'm not sure I'm ready to take on moving all my rfxcom devices/rules, the points about config etc and needing to use a separate application to get those kind of put me off....

That said, I just connected to my desktop and ran openhab in debug to capture the output:
Code: [Select]
12:13:05.271 [DEBUG] [o.b.r.internal.RFXComActivator:34   ] - RFXCOM binding has been started.
12:13:05.301 [DEBUG] [.b.r.internal.RFXComConnection:49   ] - Activate
12:13:05.301 [DEBUG] [.b.r.internal.RFXComConnection:75   ] - Configuration updated, config true
12:13:05.301 [INFO ] [.b.r.internal.RFXComConnection:114  ] - Connecting to RFXCOM [serialPort='COM6' ].
12:13:05.311 [DEBUG] [.rfxcom.internal.RFXComBinding:60   ] - Activate
12:13:06.332 [DEBUG] [.b.r.internal.RFXComConnection:120  ] - Reset controller
12:13:06.332 [DEBUG] [.b.r.i.c.RFXComSerialConnector:152  ] - Data listener started
12:13:07.362 [DEBUG] [.b.r.internal.RFXComConnection:149  ] - Data received:
Raw data = 0D01000102534700020801010000
 - Packet type = INTERFACE_MESSAGE
 - Seq number = 1
 - Sub type = INTERFACE_RESPONSE
 - Command = GET_STATUS
 - Transceiver type = _443_92MHZ_TRANSCEIVER
 - Firmware version = 71
 - Hardware version = 1.1
 - Undecoded packets = false
 - RFU6 packets = false
 - RFU5 packets = false
 - RFU4 packets = false
 - RFU3 packets = false
 - FineOffset / Viking (433.92) packets = false
 - Rubicson (433.92) packets = false
 - AE (433.92) packets = false
 - BlindsT1/T2/T3 (433.92) packets = false
 - BlindsT0 (433.92) packets = false
 - ProGuard (868.35 FSK) packets = false
 - FS20 (868.35) packets = false
 - La Crosse (433.92/868.30) packets = false
 - Hideki/UPM (433.92) packets = false
 - AD (433.92) packets = true
 - Mertik (433.92) packets = false
 - Visonic (315/868.95) packets = false
 - ATI (433.92) packets = false
 - Oregon Scientific (433.92) packets = false
 - Meiantech (433.92) packets = false
 - HomeEasy EU (433.92) packets = true
 - AC (433.92) packets = false
 - ARC (433.92) packets = false
 - X10 (310/433.92) packets = false
12:15:05.832 [DEBUG] [.b.r.internal.RFXComConnection:149  ] - Data received:
Raw data = 0A140000F09EFD01010070
 - Packet type = LIGHTING5
 - Seq number = 0
 - Sub type = LIGHTWAVERF
 - Id = 15769341
 - Unit code = 1
 - Command = ON
 - Dim level = 0
 - Signal level = 7
12:15:09.012 [DEBUG] [.b.r.internal.RFXComConnection:149  ] - Data received:
Raw data = 0A140001F09EFD01000050
 - Packet type = LIGHTING5
 - Seq number = 1
 - Sub type = LIGHTWAVERF
 - Id = 15769341
 - Unit code = 1
 - Command = OFF
 - Dim level = 0
 - Signal level = 5
12:15:09.642 [DEBUG] [.b.r.internal.RFXComConnection:149  ] - Data received:
Raw data = 0A140002F09EFD01000050
 - Packet type = LIGHTING5
 - Seq number = 2
 - Sub type = LIGHTWAVERF
 - Id = 15769341
 - Unit code = 1
 - Command = OFF
 - Dim level = 0
 - Signal level = 5
12:15:15.432 [DEBUG] [.b.r.internal.RFXComConnection:149  ] - Data received:
Raw data = 0A140003F09EFD10030060
 - Packet type = LIGHTING5
 - Seq number = 3
 - Sub type = LIGHTWAVERF
 - Id = 15769341
 - Unit code = 16
 - Command = MOOD1
 - Dim level = 0
 - Signal level = 6
12:15:17.842 [DEBUG] [.b.r.internal.RFXComConnection:149  ] - Data received:
Raw data = 0A140004F09EFD01010070
 - Packet type = LIGHTING5
 - Seq number = 4
 - Sub type = LIGHTWAVERF
 - Id = 15769341
 - Unit code = 1
 - Command = ON
 - Dim level = 0
 - Signal level = 7
12:15:19.622 [DEBUG] [.b.r.internal.RFXComConnection:149  ] - Data received:
Raw data = 0A140005F09EFD01000060
 - Packet type = LIGHTING5
 - Seq number = 5
 - Sub type = LIGHTWAVERF
 - Id = 15769341
 - Unit code = 1
 - Command = OFF
 - Dim level = 0
 - Signal level = 6

They were all from a single mood controller, can't remember which buttons I pressed though!

Hope that's some help.

Cheers
J

Offline lolodomo

  • Beta Testers
  • Master Member
  • *****
  • Posts: 3484
  • Karma: +74/-10
Re: RFXtrx433 ===> Vera plugin vs openHAB binding
« Reply #2 on: March 29, 2015, 08:17:05 am »
 Yes that means we can get required data from debug traces. But it reqires to restart openHAB in debug mode.