Author Topic: RTSP stream link to ImperiHome  (Read 16382 times)

Offline Kalapa

  • Jr. Member
  • **
  • Posts: 55
  • Karma: +0/-1
RTSP stream link to ImperiHome
« on: May 19, 2015, 12:14:37 am »
Anyone tried adding RTSP stream link to ImperiHome?

Offline integlikewhoa

  • Master Member
  • *******
  • Posts: 5550
  • Karma: +149/-363
Re: RTSP stream link to ImperiHome
« Reply #1 on: May 19, 2015, 12:53:31 am »
Anyone tried adding RTSP stream link to ImperiHome?
YES

Offline fbockstael

  • Newbie
  • *
  • Posts: 15
  • Karma: +0/-1
Re: RTSP stream link to ImperiHome
« Reply #2 on: June 02, 2015, 08:42:22 am »
It would be very nice to give some information about what you did, how you did it and if it succeeded.
I guess that is what a forum is for.

Offline integlikewhoa

  • Master Member
  • *******
  • Posts: 5550
  • Karma: +149/-363
Re: RTSP stream link to ImperiHome
« Reply #3 on: June 02, 2015, 11:22:38 am »
It would be very nice to give some information about what you did, how you did it and if it succeeded.
I guess that is what a forum is for.

Info located here:
http://www.imperihome.com/blog/2014/11/09/imperihome-2-4-mpeg4-h264-cameras-rgb-lights/

Copy from above link:
Quote
MPEG4/h264 IP Cameras

Many users asked for this: it?s now there. ImperiHome now supports MPEG4/h264 streams delivered through unauthenticated RTSP (yes, unauthenticated only for now, this is a limitation of the current android implementation of rtsp protocol). How to use this? simple: just add/edit an IP Camera in the app as usual, and put the rtsp url (prefixed: rtsp:// ) in the corresponding fields, that?s all :)

Well, there is no special instructions really. I guess I thought it was pretty straight forward.

Your cameras might be a different then mine. Need to make sure in your camera that RTSP is set to no password or unauthenticated!
Let me know if you need more info.

EDIT: Also just to make sure I'm clear. Yes it works.

Offline dinkeldorf

  • Jr. Member
  • **
  • Posts: 54
  • Karma: +0/-8
Re: RTSP stream link to ImperiHome
« Reply #4 on: June 16, 2015, 12:11:20 pm »
Can you embed credentials in the URL?

Offline integlikewhoa

  • Master Member
  • *******
  • Posts: 5550
  • Karma: +149/-363
Re: RTSP stream link to ImperiHome
« Reply #5 on: June 18, 2015, 07:20:55 pm »
Can you embed credentials in the URL?

Not on the RTSP as far as I know. If they did then I don't think they would have said
Quote
ImperiHome now supports MPEG4/h264 streams delivered through unauthenticated RTSP (yes, unauthenticated only for now, this is a limitation of the current android implementation of rtsp protocol)

Offline Spilota

  • Sr. Newbie
  • *
  • Posts: 29
  • Karma: +0/-1
Re: RTSP stream link to ImperiHome
« Reply #6 on: July 06, 2015, 11:18:32 pm »
No, you cannot embed user / password in Url.  It would be huge if you could though!  Hopefully soon...

Offline dinkeldorf

  • Jr. Member
  • **
  • Posts: 54
  • Karma: +0/-8
Re: RTSP stream link to ImperiHome
« Reply #7 on: July 10, 2015, 10:30:21 am »
Just curious if it was like some apps you authenticate when prompted vs embed. I take it to mean now NO authentication whatsoever which I didn't want to hear given my external POE domes need authentication.

Can you embed credentials in the URL?

Not on the RTSP as far as I know. If they did then I don't think they would have said
Quote
ImperiHome now supports MPEG4/h264 streams delivered through unauthenticated RTSP (yes, unauthenticated only for now, this is a limitation of the current android implementation of rtsp protocol)

Offline dinkeldorf

  • Jr. Member
  • **
  • Posts: 54
  • Karma: +0/-8
Re: RTSP stream link to ImperiHome
« Reply #8 on: July 30, 2015, 12:50:54 pm »
Ahhhh. It's a library issue.

Offline integlikewhoa

  • Master Member
  • *******
  • Posts: 5550
  • Karma: +149/-363
Re: RTSP stream link to ImperiHome
« Reply #9 on: July 30, 2015, 12:52:33 pm »
Ahhhh. It's a library issue.

Not smart enough to understand but willing to listen if you care to explain.

Offline dinkeldorf

  • Jr. Member
  • **
  • Posts: 54
  • Karma: +0/-8
Re: RTSP stream link to ImperiHome
« Reply #10 on: August 02, 2015, 02:00:15 am »
"third party video decoding libraries and licencing concerns right now" when asking about it for the IOS app. However I got Synology DS Cam app added as a launch application (well and the Rachio app too!).

Offline knuppel

  • Sr. Newbie
  • *
  • Posts: 21
  • Karma: +0/-0
Re: RTSP stream link to ImperiHome
« Reply #11 on: September 03, 2015, 12:14:34 pm »
Same in the Homewave app.
Almost ready to give up on IOS.

Offline integlikewhoa

  • Master Member
  • *******
  • Posts: 5550
  • Karma: +149/-363
Re: RTSP stream link to ImperiHome
« Reply #12 on: September 03, 2015, 12:34:29 pm »
Almost ready to give up on IOS.

You Apple fans are strong. Keep holding in there for apple to be more open.......  ;D

Offline knuppel

  • Sr. Newbie
  • *
  • Posts: 21
  • Karma: +0/-0
Re: RTSP stream link to ImperiHome
« Reply #13 on: September 11, 2015, 11:08:38 am »
Almost ready to give up on IOS.

You Apple fans are strong. Keep holding in there for apple to be more open.......  ;D
Since I really like the Imperihome API function, I tried an Android tablet with Imperihome Pro.
RTSP is not working. Authentication is off. Error message:"This camera does not have a usable JPEG URL."

Using:
rtsp://ipadress:554/Streaming/Channels/1
Camera: Hikvision DS-2CD2032-I fw 5.3.0.

Opening the url in browser/video app works flawlessly. Any ideas?

Offline integlikewhoa

  • Master Member
  • *******
  • Posts: 5550
  • Karma: +149/-363
Re: RTSP stream link to ImperiHome
« Reply #14 on: September 11, 2015, 11:27:21 am »
Almost ready to give up on IOS.

You Apple fans are strong. Keep holding in there for apple to be more open.......  ;D
Since I really like the Imperihome API function, I tried an Android tablet with Imperihome Pro.
RTSP is not working. Authentication is off. Error message:"This camera does not have a usable JPEG URL."

Using:
rtsp://ipadress:554/Streaming/Channels/1
Camera: Hikvision DS-2CD2032-I fw 5.3.0.

Opening the url in browser/video app works flawlessly. Any ideas?

Your problem sounds to be with the JPEG or still shot not with the RTSP/MJPEG (live video). What do you have entered for the bottom line or the "LOCAL JPEG URL"? If that doesn't work you won't even get to the next step.