Author Topic: Altsteon image for Raspberry Pi  (Read 2289 times)

Offline Tank

  • Sr. Member
  • ****
  • Posts: 322
  • Karma: +11/-7
Altsteon image for Raspberry Pi
« on: May 21, 2015, 02:40:03 pm »
I see that a lot of users have moved away from Altsteon in favor of other options, being broken in UI7 didn't help.  I'm hoping to generate more interest in Altsteon now that I have it working (mostly) in UI7.

So for that reason I'm in the process of creating an SD Card image for the Raspberry Pi to make it a bit easier for users to get started.  If anybody has any thoughts or input or if you just think I'm wasting my time please let me know.

I'm almost ready to publish it, I just need to create a script that runs on first-boot and prompts the users to set a static IP address.  If anyone wants to help out let me know (I could use it  ;D )

I've attached an actual screenshot of the system that I'm testing.

Offline scravott

  • Jr. Member
  • **
  • Posts: 86
  • Karma: +0/-1
Re: Altsteon image for Raspberry Pi
« Reply #1 on: May 24, 2015, 08:26:21 pm »
I have tried ur version of altsteon files with ui7 but had no luck. Luup kept restarting. Therefore I had to revert back to ui5. I have 2 keypadlincs, 2 io lincs, and ezflora. I believe the keypadlincs have child devices also. I would be very interested in getting altsteon working on ui7. Also I run altsteon on the vera 3 itself.

Offline scravott

  • Jr. Member
  • **
  • Posts: 86
  • Karma: +0/-1
Re: Altsteon image for Raspberry Pi
« Reply #2 on: May 24, 2015, 08:36:30 pm »
Also forgot to mention  I have a fan Linc

Offline Tank

  • Sr. Member
  • ****
  • Posts: 322
  • Karma: +11/-7
Re: Altsteon image for Raspberry Pi
« Reply #3 on: May 27, 2015, 01:54:53 pm »
I have tried ur version of altsteon files with ui7 but had no luck. Luup kept restarting. Therefore I had to revert back to ui5. I have 2 keypadlincs, 2 io lincs, and ezflora. I believe the keypadlincs have child devices also. I would be very interested in getting altsteon working on ui7. Also I run altsteon on the vera 3 itself.

Can you post the logs on pastebin and send me a link so I can see whats going on during the restart?

Offline scravott

  • Jr. Member
  • **
  • Posts: 86
  • Karma: +0/-1
Re: Altsteon image for Raspberry Pi
« Reply #4 on: May 28, 2015, 10:31:25 pm »
I have already reverted back to ui5 since I have my ezflora and keypadlincs controlling my pool. I would have to try ui7 again to do this. How do u pastebin the logs and where are they located

Offline brbrice

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: Altsteon image for Raspberry Pi
« Reply #5 on: August 21, 2015, 03:41:16 pm »
I have Altsteon running on UI7 as well.  I am not seeing any constant reboots though I only have SwitchLinc relay on/off Insteon devices.  The interface does need to be updated to UI7 though.  Too bad you don't have another Vera to test with while the production one can run away till it all works.