Author Topic: vision shock sensor/vibration sensor ZS5101-5 (UI7 vera edge)  (Read 1495 times)

Offline morpheus75

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-1
hello all
i have purchased this sensor as an alarm sensor for my window, this is a gen 5 module and it includes in vera edge but seems to get stuck on 'setting specials permissions'
any thoughts

thanks
 
« Last Edit: July 14, 2015, 05:33:29 pm by morpheus75 »

Offline ldomingues

  • Newbie
  • *
  • Posts: 19
  • Karma: +0/-0
Re: vision shock sensor/vibration sensor ZS5101-5 (UI7 vera edge)
« Reply #1 on: December 02, 2015, 05:17:03 pm »
Cannot connect mine to Vera... Stops in exchanging security keys... Tried several times with no luck.

Anyone has been lucky with this device?

Offline ldomingues

  • Newbie
  • *
  • Posts: 19
  • Karma: +0/-0
Re: vision shock sensor/vibration sensor ZS5101-5 (UI7 vera edge)
« Reply #2 on: December 23, 2015, 11:59:10 am »
I have the same problem. "Z-Wave device 151 ERROR: Failed to setup security. Please exclude this device from your system, and then include again."

Offline ldomingues

  • Newbie
  • *
  • Posts: 19
  • Karma: +0/-0
Re: vision shock sensor/vibration sensor ZS5101-5 (UI7 vera edge)
« Reply #3 on: December 27, 2015, 07:10:13 am »
I've managed to get mine to work in Vera - finally!!!

This is what I've done:
- removed the previous instances
- pressed the program switch for two seconds
- the led should blink - if it doesn't, click the program sensor quickly and again for two seconds - try several times
- once it goes into blink state, remove the battery
- go to vera and add the new device
- once vera is searching for the device, put back the battery
- the led should blink
- click on the program button for 2 seconds
- don't click anything else until configuration is completed, otherwise it will fail
- if you don't succeed at first, try again

The caveat is that the configuration is not completed, and it will not ask you for the name of the device. Anyway, if you go back to the device list, it will be there as _GenericIO. Not really usable yet (alerts are generated, but you cannot trigger scenes or send email alerts).

I couldn't get it to work any further than this yet...

Offline ghost

  • Newbie
  • *
  • Posts: 2
  • Karma: +1/-0
Re: vision shock sensor/vibration sensor ZS5101-5 (UI7 vera edge)
« Reply #4 on: November 20, 2016, 05:11:28 am »
Hi Guys,
I was finally able to get the vision shock sensor/vibration sensor ZS5101 to work on UI7 vera edge after 3 days of trying
Posting the solution here, it might help someone

1. Follow the solution given by ldomingues above. If it keeps failing to connect, restore the device to factory settings as stated in the manual (hold the program switch for some secs then remove the battery, then insert the battery back in again)

2. When the device connects to Vera, it will not fire up scenes when shaken. To fix this, we need to change the device type to a motion sensor in vera. Vera currently sees it as an on and off switch. Follow these steps to change it:

Find the device in your device list and go into its control
In the control section go to the advanced section
In the advanced section (Params Tab), find the 'device_type' field and change it to 'urn:schemas-micasaverde-com:device:MotionSensor:1' (without the quote)
Find the 'device_file' and change it to 'D_MotionSensor1.xml'
Find the 'device_json' and change it to 'D_MotionSensor1.json'

Exit the device page and wait, it can take several minutes for it to update
The device should now work as a motion sensor. I have 2 working fine at the moment

Offline gstephen

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: vision shock sensor/vibration sensor ZS5101-5 (UI7 vera edge)
« Reply #5 on: February 22, 2017, 04:33:41 pm »
I followed these instructions but the sensor dissapears from the list of devices. I've tried it twice and both the same outcome.
Oddly, it still appears in my iphone app but still as an on/off device and doesn't show up as an option in scene triggers.

Any advice greatly appreciated.

Offline zhenggb

  • Newbie
  • *
  • Posts: 18
  • Karma: +1/-0
Re: vision shock sensor/vibration sensor ZS5101-5 (UI7 vera edge)
« Reply #6 on: September 07, 2017, 10:22:52 pm »
Once you paired the sensor, it shows up as a on/off switch.
Make these changes:

In the advanced section (Params Tab), find the 'device_type' field and change it to 'urn:schemas-micasaverde-com:device:MotionSensor:1' (without the quote)
Find the 'device_file' and change it to 'D_MotionSensor1.xml'
Find the 'device_json' and change it to 'D_GlassBreakSensorWithTamper.json'

change category_num to 4
change subcategory_num to 6

after these changes, the sensor works properly for me.