We have moved at community.getvera.com

Author Topic: delay delivering message to one of my devices  (Read 2310 times)

Offline mikee123

  • Hero Member
  • *****
  • Posts: 1521
  • Karma: +18/-11
delay delivering message to one of my devices
« on: August 03, 2015, 05:46:01 am »
I have 2 fixed tablets in the house. Normally, when I send a notification (tts message) to them, they are both within a second or two with delivering the tts message. Since a week or so, one of the tablets is behind by about 5 minutes, sometimes more. It also sometimes truncates the message, but in this case its the first part of the message which does not get delivered, only the second part. This message is set up in a scene, as 2 separate vera alerts send message actions. To clarify, both tablets are registered as 1 address in Vera Alerts, so every message sent to this recipient goes to both tablets at the same time. This has worked for over a year now, and they have always been within a seconds or two of each other. I have rebooted both tablets, but no change. They both are only used to display a security camera, and both run tasker. If I send notifications via autoremote to the tablets, which triggers a voice message, they are both within a second or two as Vera Alerts used to be.

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +764/-143
Re: delay delivering message to one of my devices
« Reply #1 on: August 03, 2015, 08:28:26 am »
Are you using LAN mode or using a Vera Mobile ID ?

Quote
tablets are registered as 1 address
If this is a Vera Mobil ID ... this is wrong .... Each phone/tablet must have it's own ID.

Offline mikee123

  • Hero Member
  • *****
  • Posts: 1521
  • Karma: +18/-11
Re: delay delivering message to one of my devices
« Reply #2 on: August 03, 2015, 08:37:50 am »
I think I've written it wrong. Each device has its own ID, but they are grouped in 1 profile together (User - Profile Association). They both have a different Vera Alerts IDs. I have not heard about LAN mode, I guess I am using Vera Mobile ID as I also have other devices (mobile phones) which I am sending other notifications too, and they are not always on my LAN (WiFi). The tablets in question though never leave the house and are connected via WiFi

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +764/-143
Re: delay delivering message to one of my devices
« Reply #3 on: August 03, 2015, 09:32:31 am »
Did you try to  unregister/register  ... this should not change you Vera Mobile ID ... but it makes sure Google has you registered properly.
Google can loose the registration when you update Google software (i.e. Android Version or some of the Google Play apps)

Offline mikee123

  • Hero Member
  • *****
  • Posts: 1521
  • Karma: +18/-11
Re: delay delivering message to one of my devices
« Reply #4 on: August 03, 2015, 10:14:35 am »
I will try that tonight. The thing is messages are coming through, just with a huge delay. But worth trying that, especially if the ID stays the same. Will report back in a few hours...

Offline mikee123

  • Hero Member
  • *****
  • Posts: 1521
  • Karma: +18/-11
Re: delay delivering message to one of my devices
« Reply #5 on: August 04, 2015, 06:11:17 am »
I have tried unregistering and re registering. That did not solve the problem. I noticed that sometimes the tablet which used to have the delay was first now, and the other tablet late and truncating the message. So I deleted the second send alert from by scene, and they were both at the same time again. So it seems that even with a delay between 2 vera alerts send message, if you send it to more than one device, it causes problems.
I have now split the 2nd part of the message into a separate scene, which is launched from scene 1 with a delay. That seems to work so far. Not that I see why that would make a difference, but I tested it about 10 times last night and it always worked fine. I will keep testing, but there seems to be a problem when sending (maybe due to long tts message ?) multiple send alerts to multiple devices

Offline mikee123

  • Hero Member
  • *****
  • Posts: 1521
  • Karma: +18/-11
Re: delay delivering message to one of my devices
« Reply #6 on: August 05, 2015, 03:42:57 am »
I thought it was working. It still isn't. I had a message on my tablet, and it took 7 minutes before it came through on the other one. Other messages were delayed too, but that was the worst one. Is there anything I can do, or anything I can do to find out what's causing this ?

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +764/-143
Re: delay delivering message to one of my devices
« Reply #7 on: August 05, 2015, 07:49:16 am »
This is very difficult to trace without looking at all of the log files at the same time to see what is happening.
One of the log files is on a google server.
I never see delays ... so It must be something that is unique to your environment ... can be the Android Version/Service Provider/...

Offline mikee123

  • Hero Member
  • *****
  • Posts: 1521
  • Karma: +18/-11
Re: delay delivering message to one of my devices
« Reply #8 on: August 05, 2015, 10:13:40 am »
It s very strange as both tablets are on the same wifi, and the message is (or should be) sent at the same time. One thought. My Vera over the last few months can be very very slow at times, taking anything up to 30 seconds for a command (on / off on a device for example) to be executed. Could that have anything to do with the delay ? Even though the problem with delayed commands on my Vera have been there for at least 6 months, while the Vera Alerts message delays only a couple of weeks maybe a month

Offline RichardTSchaefer

  • Moderator
  • Master Member
  • *****
  • Posts: 10091
  • Karma: +764/-143
Re: delay delivering message to one of my devices
« Reply #9 on: August 05, 2015, 06:15:06 pm »
You can turn Debug on for Vera Alerts ... then check the Vera Log file to see if there is any delay sending out the messages.