We have moved at community.getvera.com

Author Topic: New TTS engine: MaryTTS  (Read 10520 times)

Offline johnmcc

  • Sr. Newbie
  • *
  • Posts: 47
  • Karma: +0/-0
Re: New TTS engine: MaryTTS
« Reply #30 on: April 05, 2016, 04:35:24 pm »
Hi, went back over and entered everything again, now plays the message from a scene, though repeats. Guess I had a typo and maybe another, thanks for a great app

Offline MNB

  • Hero Member
  • *****
  • Posts: 689
  • Karma: +4/-9
Re: New TTS engine: MaryTTS
« Reply #31 on: March 15, 2017, 07:01:22 pm »
Is there a quick way of getting the server's IP address?
Edge-1.7.2607, VRI06-1LX Dimr (6), VS05-1LX Sw (4), GE ZW3002 Dimr (1), HA01C Outlet (12), HA02C Sw (6), HA04C Sw (4), GE Sw (2), HA05 Sw (3), MiniMote Contr (5), HSM200/100 Sensor (2), ZW100A Sensor (8), Nest thermostat (1) & Protect Fire/CO (6) Kwikset Locks (3), F18918W (1) & IP3M-9 (6) Cam's

Offline BOFH

  • Sr. Hero Member
  • ******
  • Posts: 2409
  • Karma: +112/-140
Re: New TTS engine: MaryTTS
« Reply #32 on: March 15, 2017, 07:38:28 pm »
On the server itself:

Windows -> run CMD.exe and type IPCONFIG
Unix        -> In a command window type ifconfig
Vera3 UI5 UI7 Edge Plus
Trane TZEMT400AB32 | Schlage BE369 FE599 | GE 45601 45602 45603 45604 45606 45609 45631 | Intermatic HA01C HA03C HA05C HA07C CA600 CA3000 | Aeon DSC06106 | Telguard GDC1 | Foscam FI8910W FI8905W FI9821W | D-Link 930L | Wanscam JW0011 | ZModo ZPIBH13W

Offline MNB

  • Hero Member
  • *****
  • Posts: 689
  • Karma: +4/-9
Re: New TTS engine: MaryTTS
« Reply #33 on: March 15, 2017, 08:01:57 pm »
@BOFH, thanxs for the comeback, when I run IPCONFIG I only get the address and server name for the PC connected to the router, I also have both the MARY Server running and am able to get the MaryTTS client to work (get text to audio working) with MARY Server.

When I run the client I get the following in the cmd window
Quote
Mary TTS client 5.2 (imp. unknown)
connected to localhost:59125, Mary TTS server 5.2 (impl. unknown)

PS: I did try the IP address for the PC:59125 in my browser with no success.

Never mind I found it via looking at the devices connected to my router. both IPCONFIG and NSLOOKUP did not find the server. I'm now able to invoke the client via browser (webb).
« Last Edit: March 15, 2017, 08:40:05 pm by MNB »
Edge-1.7.2607, VRI06-1LX Dimr (6), VS05-1LX Sw (4), GE ZW3002 Dimr (1), HA01C Outlet (12), HA02C Sw (6), HA04C Sw (4), GE Sw (2), HA05 Sw (3), MiniMote Contr (5), HSM200/100 Sensor (2), ZW100A Sensor (8), Nest thermostat (1) & Protect Fire/CO (6) Kwikset Locks (3), F18918W (1) & IP3M-9 (6) Cam's