Author Topic: Vera Edge mysteriously added several sensors  (Read 3405 times)

Offline chris66

  • Sr. Member
  • ****
  • Posts: 303
  • Karma: +9/-8
Re: Vera Edge mysteriously added several sensors
« Reply #15 on: June 11, 2018, 09:45:30 am »
For me Ghost devices appeared again! latest firmware on my Veralite. These are motion sensors from Aeotec 4 in 1.  asked support to help me to resolve this, they deleted all my 4 in 1 sensors... I tried to set parent_id to 1 and was able to delete it but re-appeared just 10 seconds after...
i've seen in wiki that there is an NoChildren parameter, where can I activate this? http://wiki.micasaverde.com/index.php/Luup_UPnP_Variables_and_Actions

Offline chris66

  • Sr. Member
  • ****
  • Posts: 303
  • Karma: +9/-8
Re: Vera Edge mysteriously added several sensors
« Reply #16 on: June 12, 2018, 04:09:13 am »
Suddenly I see that most probably in the last week (I look into Vera often) I have 3 extra motion sensors as childs fro my EZMotion+ device. Can't delete them.

Seems this problem has not been addressed correctly in the last firmware update then?

Hi, issue is still present with latest firmware on Veralite UI7.

Offline jeubanks

  • Full Member
  • ***
  • Posts: 208
  • Karma: +6/-1
Re: Vera Edge mysteriously added several sensors
« Reply #17 on: June 12, 2018, 11:23:56 am »
Hi there,

This was an issue present in one of the older firmware. As paulstephenson003 mentioned, the latest official firmware, will not only stop these devices being created, but it will also let you delete them right from the UI.

Wrong.

The LATEST firmware still creates "ghost" devices with no category or sub-category so they are hidden from the UI.  However they are created and created at RANDOM. 

Example Device Issue:
I have several devices that are "supported" per the web site, but not completely when you look into it.  Example the NYCE Motion sensors all have temp/humidity capabilities.  Vera does NOT support those so devices are not created.  However every now and again at random after a luup reload a ghost device is created as a child of the NYCE sensor but with no name or category/sub-category and it's pulling data and can be seen through the http api.

I'm speculating that if you have devices that Vera doesn't know how to deal with then it's not gracefully creating devices, or it's doing like it does for my sensors and creating the device and HIDING it by not assigning a name or category/sub-category to the device.