Author Topic: PE653 & 953 MultiWave should I upgrade from 3.1 to 3.4???  (Read 2561 times)

Offline Technigogo

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
PE653 & 953 MultiWave should I upgrade from 3.1 to 3.4???
« on: August 26, 2015, 08:21:46 pm »
I just installed the MultiWave and I am missing some functionality but it does connect with Vera Edge. If I upgrade, will I lose that?

Anyone have 3.1, 3.2 and 3.3 available in case I want to back up?

Sent from my Nexus 6 using Tapatalk
« Last Edit: August 27, 2015, 08:12:13 am by Technigogo »

Offline Technigogo

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
Re: PE653 & 953 MultiWave should I upgrade from 3.1 to 3.4???
« Reply #1 on: August 28, 2015, 08:16:40 am »
I spoke with InterMatic and they told me that I should not upgrade to 3.4. They are sending me 3.3 to use. They also said that the new release is slated for September 15(ish) and will include full support from/with Vera.

Offline Bb98

  • Sr. Newbie
  • *
  • Posts: 30
  • Karma: +0/-0
Re: PE653 & 953 MultiWave should I upgrade from 3.1 to 3.4???
« Reply #2 on: August 29, 2015, 12:31:06 pm »
It will be interesting to see what drama the new firmware holds.  Right now I'm pretty happy with UI7 and the controller.  My only complaint is the "thermostat" created when the device is included constantly reports that it can not be detected - and there's no auto, cool so the display is kinda useless.  The guys at vera say there's a problem with the algorithm used to detect the device and that will be corrected in their next update.
Upgrading the firmware will be difficult if indeed it requires their $47 z-stick and a pc with a 32-bit OS.  Surely there's a cheaper / better way.

Offline dinosinc

  • Jr. Member
  • **
  • Posts: 56
  • Karma: +0/-0
Re: PE653 & 953 MultiWave should I upgrade from 3.1 to 3.4???
« Reply #3 on: September 08, 2015, 03:25:39 pm »
Im on 3.4 and have the same issues can you send me a copy of 3.3 when you get it

Offline donperry

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
Re: PE653 & 953 MultiWave should I upgrade from 3.1 to 3.4???
« Reply #4 on: September 26, 2015, 10:26:58 pm »
PLEASE!
WHERE DO I DOWNLOAD MW34P.INT ????

I can't find it anywhere.

Offline Wilder4u

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: PE653 & 953 MultiWave should I upgrade from 3.1 to 3.4???
« Reply #5 on: October 04, 2015, 09:18:04 pm »
I have 3.4 and it does not work so I called Intermatic who told me to get 3.3.  Options were to send 953 & 653 back to Intermatic or buy a CA8700 USB for ~ $50 to reprogram back to 3.3.

Offline Technigogo

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
Re: PE653 & 953 MultiWave should I upgrade from 3.1 to 3.4???
« Reply #6 on: December 03, 2015, 01:56:21 am »
donperry, sorry I just now saw your request for the 3.3 firmware. Here you go:

www.technigogo.com/MW33.zip

Offline donperry

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
Re: PE653 & 953 MultiWave should I upgrade from 3.1 to 3.4???
« Reply #7 on: December 23, 2015, 04:40:32 am »
Thanks so very much.

Offline dxbwhite

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: PE653 & 953 MultiWave should I upgrade from 3.1 to 3.4???
« Reply #8 on: May 20, 2016, 12:32:38 pm »
Hello,  I am giving this information because I to have tried to connect up the Intermatic PE653 to the Veraegde with no success.   All I wanted to do is be able to put my Pool in what I call Spa mode remotely away from home (Switch the valves, turn on the main pump and heater) all done by the PE653.   

The information below is a way to remotely run the 5 functions (Relays) of the PE653 using the Veraedge as the controller and associated Z-Wave Relays.   (NOTE this does not give any feed back as to TEMP, TEMP control, Status of button Position "on/off" within the PE653)

Simple explanation of what I did is I HARD wired directly to the 5 momentary switches located on the PE653 front control board (See Photo) and installed Z Wave momentary relays to act as though you where standing in front of the Intermatic PE653 pushing the buttons!!! 

Solder wires to the top left pin of all 5 switches.  1 Common wire can be attached to the Bottom of any switch or to the solder hole I found on the board as seen on the Photo.

NOTE:  You must use a MIMOlite relay on Switch 1.   MIMOlite allow the relay to act as a "Momentary" Switch.   Set the Scene control in the Veraedge to "When turned ON to immediately turn OFF"  Remove the J5 jumper as stated in the MIMOlite instructions that turns this unit into a Momentary Switch.  This relay reacts very fast which is what the Switch 1 on the PE653 works best (Quick ON then OFF).   If there is any long delay and the relay holds closed too long then it will not trigger the internal relay in the PE653 or will lock it up.   (You must have access to 120V outlet.  MIMOlite has 9V power transformer)
   
 I used a ZMF-80 (Wired to 120V) on the other switches with no problems and set the Scene control also in the Veraedge to "When turned ON to immediately turn OFF"  You can use MIMOlite on all the switches if you want but they are more expensive than the ZMF-80.   

ENJOY RUNNING THE PE653 FROM YOUR SMARTPHONE OR TABLET!!

 

Offline j9brown

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
Re: PE653 & 953 MultiWave should I upgrade from 3.1 to 3.4???
« Reply #9 on: May 27, 2016, 09:25:32 pm »
Last night I discovered that my PE653 had mysteriously dropped off of my Z-wave network after working fine for years.  I remember it being quite difficult to set up in the first place, and that's when I was on Zwave 2.78.  Since I don't want to risk breaking the rest of my network by downgrading, I'm just going to pair the remote and leave it alone.

Any word on when a 3.5 firmware might arrive?  The last email said September 2015.

Offline blueman2

  • Sr. Newbie
  • *
  • Posts: 37
  • Karma: +0/-0
Re: PE653 & 953 MultiWave should I upgrade from 3.1 to 3.4???
« Reply #10 on: June 22, 2016, 09:01:32 pm »
j9brown,

I wish I knew.  They first promised 3.5 would be ready in July of last year.  So already a year behind.

Intermatic released the much awaited P5043ME about 2 years ago (in Sept 2014, when originally promised in mid 2013), yet you still cannot buy them anywhere.   

I think Intermatic has largely abandoned the Multiwave controller. 

Offline kmheid

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: PE653 & 953 MultiWave should I upgrade from 3.1 to 3.4???
« Reply #11 on: August 03, 2016, 08:06:00 pm »
You can purchase a P5043 directly from Intermatic if you call them.  You have to be running firmware version 3.4 to use it.  I upgraded to 3.4, but am still working through issues from that, so I can't comment on how well the 5043 works.  They did tell me that they have been working closely with MiCasaVerde and would be releasing version 3.5 "soon" with much better control.  We will see.
After upgrading from 3.1 to 3.4, I haven't been able to get the PE953 to work.  I decided to go ahead and make Vera the primary controller since the 953 handheld wouldn't work anyway, and Vera can now control the 5 primary circuits, but she can't control my Pentair variable speed pump.  I was able to control that from the 953 with version 3.1, so that is a bit frustrating, but I'm hopeful I can fix it.  I never connected the PE653 to Vera when it was running 3.1, so this is a new challenge for me and I know there is a lot of info on this forum, so I will keep searching for tips and hoping for a solution.

Offline LindsiWains

  • Jr. Member
  • **
  • Posts: 79
  • Karma: +0/-39
PE653 953 MultiWave should I upgrade from 3 1 to 3 4
« Reply #12 on: November 12, 2016, 08:32:02 am »
I found the file and it uploaded fine, all working correctly.  I should have realized it was in the archive......

Offline j9brown

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
Re: PE653 & 953 MultiWave should I upgrade from 3.1 to 3.4???
« Reply #13 on: April 17, 2017, 07:03:32 pm »
My PE953 handheld unit bit the dust so I had to replace it only it had firmware v3.4 on it and wouldn't speak to my PE653 running firmware v3.1.  So I finally sat down and figured out how to perform the firmware upgrade.  Some observations for future intrepid souls who go down this route:

1. You really do need Windows XP 32-bit to run the Intermatic Firmware Updater.  For this, I downloaded Microsoft's "XP Mode" installer, extracted the VHD file it contains, and ran it inside of Virtual Box.

2. You don't need Intermatic's Z-wave stick.  I was able to perform the upgrade using an Aeotec Z-Stick Gen 5.  It registers as a serial device and speaks the same Z-wave serial protocol.  To make it work in Virtual Box, associate the Z-stick with a virtual serial port (eg. COM1).  The Intermatic Firmware Updater won't automatically detect the Z-Stick but you can ask it to manually connect to the COM port, which will work.

3. I wasn't able to get the Intermatic Firmware Updater to successfully Include devices from its UI.  So I took advantage of the Z-Stick's portable nature and built-in battery and manually included the PE653 to it's network.  Once done, I plugged the Z-Stick back into the computer, selected the PE653, and successfully updated the firmware.  This got me onto v3.4 so at least my PE953 and PE653 could talk to each other, but not Vera.

4. I called Intermatic and spoke with Frank about getting other firmware binaries to gain compatibility with Vera.  He kindly sent me v3.3 and v3.7.13.

5. With v3.7.13, I was able to pair both devices with Vera running UI5 with Z-wave v3.2 but the PE953 handheld showed "Out of Range" and I was unable to pair it with or configure the PE653.

I haven't tried v3.3 yet but I expect it'll be the same.

The issue as far as I can tell is that when Vera is using Z-wave 3.2 it doesn't support secondary inclusion server mode so the PE953 handheld ends up as a secondary controller and is unable to configure the network.  When I first set this up, I had Vera running Z-wave 2.78 but it would be too disruptive for me to go back and reset everything.  I wonder whether I could remotely configure the handheld by setting the right associations or configuration registers but I don't know what I would set them to.

Anyhow, at this point I think I'm going to give up and just use the handheld separately from Vera.  :(

Offline dbeck52

  • Sr. Newbie
  • *
  • Posts: 20
  • Karma: +0/-0
Re: PE653 & 953 MultiWave should I upgrade from 3.1 to 3.4???
« Reply #14 on: April 18, 2017, 02:13:05 pm »
j9brown,
I configured my device 2 years ago and it was common to remove the batteries from the pe953 hand controller and then re-install them to get it to resolve the "out of range" problem.  I don't know if this is your issue or not but it may be worth a try.