Author Topic: DLNA Media Controller plugin - version 1.4 released  (Read 8851 times)

Offline lolodomo

  • Moderator
  • Master Member
  • *****
  • Posts: 3484
  • Karma: +74/-10
DLNA Media Controller plugin - version 1.4 released
« on: September 12, 2015, 01:58:32 pm »
Version 1.4 is released.

You can download it here (ZIP archive at the bottom of this page): http://code.mios.com/trac/mios_dlna-cntroller/browser/tags/1.4

This version will be available in the MiOS app store later.


What's new in version 1.4:

  • Fix: compatibility with Vera firmware 7.0.11
  • Fix: Google TTS engine
  • New Microsoft Translator TTS engine
  • New MaryTTS engine
  • New language per country for TTS

Offline lolodomo

  • Moderator
  • Master Member
  • *****
  • Posts: 3484
  • Karma: +74/-10
Re: DLNA Media Controller plugin - version 1.4 released
« Reply #1 on: September 12, 2015, 02:08:25 pm »
V1.4 has just been submitted for approval in the store. Should be available in few days.

Offline n0ir

  • Sr. Member
  • ****
  • Posts: 352
  • Karma: +4/-1
Re: DLNA Media Controller plugin - version 1.4 released
« Reply #2 on: September 13, 2015, 07:54:47 am »
The Say-button under the TTS option in the created devices is not responsive. I can't seem to send test TTS to devices.

Offline lolodomo

  • Moderator
  • Master Member
  • *****
  • Posts: 3484
  • Karma: +74/-10
Re: DLNA Media Controller plugin - version 1.4 released
« Reply #3 on: September 13, 2015, 10:30:37 am »
The Say-button under the TTS option in the created devices is not responsive. I can't seem to send test TTS to devices.

Did uou setup and control your renderer ?

Of course I tested before releasing. It is working with XBMC as renderer and UI5 firmware.

Offline n0ir

  • Sr. Member
  • ****
  • Posts: 352
  • Karma: +4/-1
Re: DLNA Media Controller plugin - version 1.4 released
« Reply #4 on: September 15, 2015, 02:33:05 pm »
Got it to work again! :)

I don't know why but the first sentence isn't spoken using Google TTS. I needed to add a "dummy" sentence first (i.e. "Good morning! Good morning!"), to get the renderer to read the announcement properly. Probably something not relating to the app, but I haven't had the issue before.

Offline cw-kid

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1569
  • Karma: +16/-2
Re: DLNA Media Controller plugin - version 1.4 released
« Reply #5 on: September 15, 2015, 05:27:29 pm »
Got it to work again! :)

I don't know why but the first sentence isn't spoken using Google TTS. I needed to add a "dummy" sentence first (i.e. "Good morning! Good morning!"), to get the renderer to read the announcement properly. Probably something not relating to the app, but I haven't had the issue before.

I've had a similar problem before, but not an entire sentence. I have several Kodi PCs and on some of them it works OK on others it misses off the first  few letters of the first word and I had to pad it out with other characters at the beginning, so my sentence was then spoken out correctly.

The Google TTS seems to be working again when sent to my Kodi PC in the living room, just tested it.

When you manually upload the plug-in files to Vera, the version has stayed on 1.3* and not changed to 1.4 is that normal?

Many thanks. 
« Last Edit: September 15, 2015, 05:29:20 pm by cw-kid »

Offline cw-kid

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1569
  • Karma: +16/-2
Re: DLNA Media Controller plugin - version 1.4 released
« Reply #6 on: September 15, 2015, 05:47:24 pm »
One thing I noticed after sending a Google TTS to the Kodi PC, I was playing a TV Show at the time, the DLNA device in Vera on the Control tab it still says

Playing...Google TTS

After the TTS is spoken the TV Show resumes playback OK but the DLNA device in Vera does not update its playing status to the name of the TV Show episode that is playing etc.

However if I look on the Help tab it does say the name of the playing episode in a path. I can also see the plug-in version is 1.4 on the Help tab.

If I look in the Advanced tab I can see:

TransportState   
STOPPED
TransportStatus   
ERROR_OCCURRED

CurrentStatus   
Google TTS
CurrentTitle   
Google TTS

If I Reload Vera these values change:

TransportState   
PLAYING
TransportStatus   
OK

CurrentStatus & CurrentTitle are now blank.

The Control tab now says just: Playing..

Not sure if this is expected behaviour or not.

Thanks

Offline cw-kid

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1569
  • Karma: +16/-2
Re: DLNA Media Controller plugin - version 1.4 released
« Reply #7 on: September 15, 2015, 06:05:13 pm »
Another strange thing I have two Kodi PCs that say Upnp Proxy is in use. But one Kodi PC says Proxy not in use and I can't seem to make it change.

EDIT: Rebooted that PC and now it says Proxy in use so seems to have fixed it.
« Last Edit: September 15, 2015, 06:20:57 pm by cw-kid »

Offline lolodomo

  • Moderator
  • Master Member
  • *****
  • Posts: 3484
  • Karma: +74/-10
Re: DLNA Media Controller plugin - version 1.4 released
« Reply #8 on: September 16, 2015, 02:27:08 am »
Got it to work again! :)

I don't know why but the first sentence isn't spoken using Google TTS. I needed to add a "dummy" sentence first (i.e. "Good morning! Good morning!"), to get the renderer to read the announcement properly. Probably something not relating to the app, but I haven't had the issue before.

I've had a similar problem before, but not an entire sentence. I have several Kodi PCs and on some of them it works OK on others it misses off the first  few letters of the first word and I had to pad it out with other characters at the beginning, so my sentence was then spoken out correctly.

The Google TTS seems to be working again when sent to my Kodi PC in the living room, just tested it.

When you manually upload the plug-in files to Vera, the version has stayed on 1.3* and not changed to 1.4 is that normal?

Many thanks.

You certainly forgot to upload the updated I_***.XML file. If you check the beginning of this file, you will see 1.4.

Offline lolodomo

  • Moderator
  • Master Member
  • *****
  • Posts: 3484
  • Karma: +74/-10
Re: DLNA Media Controller plugin - version 1.4 released
« Reply #9 on: September 16, 2015, 07:38:37 am »
V1.4 was approved and so should be available in the store.

Offline cw-kid

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1569
  • Karma: +16/-2
Re: DLNA Media Controller plugin - version 1.4 released
« Reply #10 on: September 16, 2015, 11:46:57 am »

I did upload all the files.

In one place in the Vera GUI it says version 1.3 and in another place it says version 1.4

Please see attached


Offline lolodomo

  • Moderator
  • Master Member
  • *****
  • Posts: 3484
  • Karma: +74/-10
Re: DLNA Media Controller plugin - version 1.4 released
« Reply #11 on: September 16, 2015, 01:05:05 pm »
That just means you installed 1.3 from the store and then overwrited it manually by 1.4 files.

Offline cw-kid

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1569
  • Karma: +16/-2
Re: DLNA Media Controller plugin - version 1.4 released
« Reply #12 on: September 16, 2015, 01:10:33 pm »
OK thanks, so I don't need to worry about it then.

Cheers

Offline cw-kid

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1569
  • Karma: +16/-2
Re: DLNA Media Controller plugin - version 1.4 released
« Reply #13 on: October 20, 2015, 06:42:25 am »
Hi

The Google TTS rarely seems to work for me these days, so I am trying the Microsoft TTS with the DLNA plug-in.

It works initially for like 4 or 5 times using the SAY option in the TTS tab. I am using UI7 on a Vera Edge for testing.

However it then seems to just stop working and I see this in the logs:

Code: [Select]
02 10/20/15 11:29:33.252 luup_log:24: DLNA: warning: Microsoft TTS: failed! <0x74ece520>
02 10/20/15 11:29:33.253 luup_log:24: DLNA: warning: Microsoft TTS: trying again with a new session token <0x74ece520>
02 10/20/15 11:29:34.623 luup_log:24: DLNA: warning: Microsoft TTS: failed! <0x74ece520>
35 10/20/15 11:29:34.640 ImplAction::HandleActionRequest SDLNAMediaController1_DLNAMediaController1_Say_run returned 0 <0x74ece520>
10 10/20/15 11:29:34.641 luvd_get_info_data_request creating file buffer /data_request?id=lu_action&output_format=xml&DeviceNum=24&serviceId=urn:dlna-org:serviceId:DLNAMediaController1&action=Say&Text=Beer%20Assistant&Language=en&Engine=MICROSOFT&Volume= pMem 0xd65000/14045184 diff: 5697536 <0x74ece520>
10 10/20/15 11:29:34.642 luvd_get_info_data_request done /data_request?id=lu_action&output_format=xml&DeviceNum=24&serviceId=urn:dlna-org:serviceId:DLNAMediaController1&action=Say&Text=Beer%20Assistant&Language=en&Engine=MICROSOFT&Volume= ret 0 size 124 pMem 0xd65000/14045184 diff: 5697536 took 0 info 0x74ecdd28 <0x74ece520>
10 10/20/15 11:29:34.643 luvd_open /data_request?id=lu_action&output_format=xml&DeviceNum=24&serviceId=urn:dlna-org:serviceId:DLNAMediaController1&action=Say&Text=Beer%20Assistant&Language=en&Engine=MICROSOFT&Volume= FileBuffer 0xba9830 <0x74ece520>
10 10/20/15 11:29:35.000 GlobalLog: mongoose ctx2: 0x866c68 s: d:4929 <0x742b2520>

If I delete the application on the Microsoft Azure website and create a new one it then works again but only for a little while and then stops working again.  :(

Reloading or rebooting Vera doesn't seem to get it working again either.

EDIT:

This might have fixed it, seems to be working better now, fingers crossed

http://forum.micasaverde.com/index.php/topic,33223.msg252458.html#msg252458
« Last Edit: October 20, 2015, 07:21:03 am by cw-kid »

Offline lolodomo

  • Moderator
  • Master Member
  • *****
  • Posts: 3484
  • Karma: +74/-10
Re: DLNA Media Controller plugin - version 1.4 released
« Reply #14 on: December 26, 2015, 06:42:13 am »
We have to forget Google TTS. The service is now only partially available.
Rather use Microsoft engine. Works well.