We have moved at community.getvera.com

Author Topic: Leviton Status Issue - VRMX1  (Read 4882 times)

Offline tbully

  • Sr. Member
  • ****
  • Posts: 285
  • Karma: +1/-1
Re: Leviton Status Issue - VRMX1
« Reply #15 on: February 01, 2016, 01:46:46 pm »
I don't do that, either.  (Usually use 5% - 95%)  My wife has a habit of putting the dimmer all the way down prior to bed while watching the news which then makes the "going asleep" crap fire off.  I was going to install an IR blaster to shut off the TV as part of the logic but will wait on that for the obvious reasons.

I will continue to test but this is a pretty bad miss on Vera's part and I'm surprised that I/we are just catching it now.  (Which is why I was initially blaming myself or something local to me.)


Offline oTi@

  • Community Beta
  • Master Member
  • ******
  • Posts: 4041
  • Karma: +32/-6
  • UI what ?!
Re: Leviton Status Issue - VRMX1
« Reply #16 on: February 01, 2016, 02:20:40 pm »
Assuming the wife does not interact with Vera, but does interact with the physical dimmer buttons and the remote for the tv, possibly, as alternate implementation, you could use a Z-Wave energy monitoring switch to detect tv on/off state. Turn tv on (and night? and ...): dim lights to 5%. Turn tv off (and ... and ...): kill lights?

(I don't know if they have implemented energy events yet in UI7... I did my own years ago, in UI5. Use cases: if computer on -> set motion sensor to bypass; if tv on -> set motion sensor to bypass; if garage door opener built-in light on -> turn additional garage lighting on.)

I will continue to test but this is a pretty bad miss on Vera's part and I'm surprised that I/we are just catching it now.
:) The 'full on'/'use 95 instead of 100' issue was reported on 2012/07/21.
« Last Edit: February 01, 2016, 02:38:44 pm by oTi@ »
Dezwaved at the moment...

Offline tbully

  • Sr. Member
  • ****
  • Posts: 285
  • Karma: +1/-1
Re: Leviton Status Issue - VRMX1
« Reply #17 on: February 01, 2016, 02:49:13 pm »
Using energy monitoring is a great idea!  I haven't done much with that but I should probably look in to it.

Thanks!

Offline tbully

  • Sr. Member
  • ****
  • Posts: 285
  • Karma: +1/-1
Re: Leviton Status Issue - VRMX1
« Reply #18 on: February 01, 2016, 03:01:30 pm »

:) The 'full on'/'use 95 instead of 100' issue was reported on 2012/07/21.

Do you think that is related to the 1% (but show it as off) issue?  They are eerily similar, I guess. 


Offline oTi@

  • Community Beta
  • Master Member
  • ******
  • Posts: 4041
  • Karma: +32/-6
  • UI what ?!
Re: Leviton Status Issue - VRMX1
« Reply #19 on: February 03, 2016, 09:40:51 am »
Tested with the physical buttons: same result.

Yes, both are related in that they have to do with Vera mapping Z-Wave dimmer range to a 'human' value for the GUI. But I imagine these are separate pieces of code. I can understand what drives the mapping at the high end (99 -> 100); not sure why they did this at the low end (1 -> 0).
Dezwaved at the moment...

Offline tbully

  • Sr. Member
  • ****
  • Posts: 285
  • Karma: +1/-1
Re: Leviton Status Issue - VRMX1
« Reply #20 on: February 03, 2016, 09:59:06 am »
Tested with the physical buttons: same result.

Yes, both are related in that they have to do with Vera mapping Z-Wave dimmer range to a 'human' value for the GUI. But I imagine these are separate pieces of code. I can understand what drives the mapping at the high end (99 -> 100); not sure why they did this at the low end (1 -> 0).

@oTi@ - Really appreciate you putting this to rest. This means that it always worked this way and I'm just crazy about thinking my logic *just* broke.  Would love to have a Leviton (or other?) user try this on UI7.   This may be another in the "pro" column for upgrading.  I need to read about power monitoring stuff.  I've been a user for a few years and never had the need to scratch the surface.  This would be a good way around this issue for now.

Any UI7 Leviton people out there willing to test for this issue?



Offline oTi@

  • Community Beta
  • Master Member
  • ******
  • Posts: 4041
  • Karma: +32/-6
  • UI what ?!
Re: Leviton Status Issue - VRMX1
« Reply #21 on: February 03, 2016, 10:08:09 am »
Well, my bug report (for the possibly relates scene issue) notes that things worked ok with UI5 load 1.5.346; which was released March 19, 2012.

But yeah, I would guess things have not worked since then.

If I have an appropriate test dimmer sitting around, I'll try with UI7 on VeraEdge.
Dezwaved at the moment...

Offline oTi@

  • Community Beta
  • Master Member
  • ******
  • Posts: 4041
  • Karma: +32/-6
  • UI what ?!
Re: Leviton Status Issue - VRMX1
« Reply #22 on: February 06, 2016, 10:17:33 am »
If I have an appropriate test dimmer sitting around, I'll try with UI7 on VeraEdge.
VRMX1 on VeraEdge/UI7: Vera does not mess with level 1.

(99 still gets converted to 100, understandably. (In UI7 set slider to 99%; dash shows 99; turn device off with physical button; turn device back on with physical button; dash shows 100 (or instead of physical button, do a poll)))

Sequence below is: from 100 to 1, off, on; with physical buttons.
Code: [Select]
42 02/06/16 10:08:13.266 0x1 0x9 0x0 0x4 0x0 0x3 0x3 0x26 0x3 0x1 0xd6 (#######&###) <0x7711d520>
06 02/06/16 10:08:13.285 Device_Variable::m_szValue_set device: 4 service: urn:upnp-org:serviceId:Dimming1 variable: LoadLevelStatus was: 100 now: 1 #hooks: 0 upnp: 0 skip: 0 v:0xa49208/NONE duplicate:0 <0x7791d520>

42 02/06/16 10:08:23.197 0x1 0x9 0x0 0x4 0x0 0x3 0x3 0x26 0x3 0x0 0xd7 (#######&###) <0x7711d520>
06 02/06/16 10:08:23.217 Device_Variable::m_szValue_set device: 4 service: urn:upnp-org:serviceId:Dimming1 variable: LoadLevelStatus was: 1 now: 0 #hooks: 0 upnp: 0 skip: 0 v:0xa49208/NONE duplicate:0 <0x7791d520>

42 02/06/16 10:08:27.946 0x1 0x9 0x0 0x4 0x0 0x3 0x3 0x26 0x3 0x1 0xd6 (#######&###) <0x7711d520>
06 02/06/16 10:08:27.968 Device_Variable::m_szValue_set device: 4 service: urn:upnp-org:serviceId:Dimming1 variable: LoadLevelStatus was: 0 now: 1 #hooks: 0 upnp: 0 skip: 0 v:0xa49208/NONE duplicate:0 <0x7791d520>
Dezwaved at the moment...

Offline tbully

  • Sr. Member
  • ****
  • Posts: 285
  • Karma: +1/-1
Re: Leviton Status Issue - VRMX1
« Reply #23 on: February 06, 2016, 01:11:19 pm »
VRMX1 on VeraEdge/UI7: Vera does not mess with level 1.

Thanks for the test, oTI.  I guess that's another reason to think about upgrading.


Offline oTi@

  • Community Beta
  • Master Member
  • ******
  • Posts: 4041
  • Karma: +32/-6
  • UI what ?!
Re: Leviton Status Issue - VRMX1
« Reply #24 on: February 07, 2016, 09:48:21 am »
As a workaround, you could consider something like on-off-on within X seconds -> set light to 2%.

(Quickly tried this with a PLEG and a (relaxed) 20 second window. Appears to do the trick. Vera3/UI5.)
Dezwaved at the moment...

Offline tbully

  • Sr. Member
  • ****
  • Posts: 285
  • Karma: +1/-1
Re: Leviton Status Issue - VRMX1
« Reply #25 on: February 07, 2016, 09:56:09 am »
So you're saying if she happens to dim down to 1% (off) the PLEG will pop it back to 2% to hold it?  I have to admit that I'm pretty horrible with creative PLEG logic.   Would you mind sharing your test example?


Sent from my iPhone using Tapatalk