We have moved at community.getvera.com

Author Topic: FYI - Corrupt upload causes "received invalid json response" in AutoHomation app  (Read 2038 times)

Offline Aaron

  • Hero Member
  • *****
  • Posts: 1985
  • Karma: +61/-193
Public Service Announcement

I have always had about a 20-30% failure rate (meaning something didn't go right) when manually uploading ANY large set of files under Apps \ Develop ... and this plugin has a ton of files so the failure rate has been more like 50% with Wink Connect manual uploads (App store uploads have been perfectly fine)

About a week ago I uploaded a version manually and never got any errors in Vera or Imperihome... but Authomation threw "received invalid json response" when either local (wifi lan) or remote (Internet).

Today I manually uploaded 0.20.20 and instantly the error in Autohomation is gone.

This is not Wink Connect issue - I'm sure this is an issue with Authomation interacting with Vera and not handling errors properly (likely from a corrected file that was uploaded).

... just be aware that manual uploads often fail and/or corrupt files.
« Last Edit: December 02, 2015, 01:28:42 am by Aaron »

Offline cybrmage

  • Moderator
  • Hero Member
  • *****
  • Posts: 1104
  • Karma: +113/-43
Today I manually uploaded 0.20.20

Are you still uploading ALL the files??? Did you read my response to you in the other thread HERE

Offline Aaron

  • Hero Member
  • *****
  • Posts: 1985
  • Karma: +61/-193
Today I manually uploaded 0.20.20

Are you still uploading ALL the files??? Did you read my response to you in the other thread HERE

Yes, uploading ALL files was the only way to fix it since I didn't know what file was corrupt. Again, no errors on Vera to tell me... and the only thing that failed was Authomation app. Even Wink Connect was working for the most part (except I was not getting the tab for color for the bulb)

Offline cybrmage

  • Moderator
  • Hero Member
  • *****
  • Posts: 1104
  • Karma: +113/-43
Yes, uploading ALL files was the only way to fix it since I didn't know what file was corrupt.

The pkugin tells you what files are mismatched... On the Wink Connect device summary tab...

File Mismatch is NOT a fatal error... the plugin will still run and you can still (mostly) control devices.. But some (usually new) features (such as RGBW or TW bulbs) may be missing...

Did your RGBW bulbs show up?


Also... If you are going to upload ALL files... Uncheck the option to restart the LuaUPnP engine after the upload... Upload the files in several smaller groups... then restart the LuaUPnP engine manually.


« Last Edit: December 03, 2015, 01:26:00 pm by cybrmage »

Offline Aaron

  • Hero Member
  • *****
  • Posts: 1985
  • Karma: +61/-193
Yup, all is well now. Altui even shows the color control.
Wish Garrett still updated Authomation. Imperihome is missing so much but I hope they will support Color change bulbs soon

Sent from my HTC6525LVW using Tapatalk